Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Paar vraagjes over linux begrippen en SuSE 8.0

danieldk
13 antwoorden
  • Ik kom in linux de volgende termen tegen en ik zou graag willen weten wat ze betekenen:

    CVS
    devel (b.v. pim-devel, gimp-devel enz)
    i386 (ik d8 altijd dat dat een andere benaming is voor ibm compatible pc processor)

    maar opeens kwam ik meerdere begrippen tegen die daar op leken en toen was ik de weg kwijt. Dus ik zou ook graag willen weten wat de onderstaande begrippen beteken

    i486
    i586
    i686

    en zijn er nog meer?



    Vraag over SuSE
    ——————-
    Ik heb SuSE 8.0 van www.linuxiso.org gedownload. Ik geloof dat het een evaluation versie is, want het is ook maar 1 cd. Nou vind ik het belangrijkste punt van een linux distro dat het voldoende libraries bevat en de nieuwste kde en gnome versie.

    Ik heb altijd Red Hat 7.1 gehad. En die vond ik zwaar bacher, bij onderhand ieder programma kreeg ik depencies problemen. Dat ik niet de juiste libraries had enz. Dus die moest ik iedere keer downen en ik was weer een middag bezig. Vooral het QT updaten was een zware ramp. Als ik die had geupdated en ik ging software installeren die dat nodig had, gaf die nog steeds als melding dat de nieuwe QT versie niet gevonden werd maar dat er een oude versie gevonden werd. Zou ik die problemen ook met SuSE 8.0 kunnen krijgen omdat ik daarvan maar 1 cd heb (evaluation versie heb). Dus met andere woorden moet ik een complete distro hebben omdat deze problemen niet meer te hebben?
  • Als ik me niet vergis betekent het het volgende:

    CVS:
    De laatste versie die er bestaat, bestaat uit enkel broncode en word iedere avond (o.i.d.) venieuwd, en kan naar binen gehaald worden en dmv make geinstalleerd worden en kijken of alles naar behoren werkt.
    Nadat er voldoende wijzigingen gemaakt zijn in de broncode komt er een binairy uit.

    Devel:
    De laatste binairy die uitgekomen is van de CVS-tree bijv. gimp-3.2.2.4-devel. Dit is een development versie die later "stabiel" word en dan word de devel erachter weggehaald.

    I386: (Hier ben ik niet zeker van!)
    Volgens mij is de benaming bij programma's voor de IBM-compatible, en werkt deze dus op alle ibm-compatible comp. in de kernel gebruiken ze ook de aanduiding I486, I586, I686, K7, etc. dit wil zeggen dat er bepaalde verbeteringen zijn die speciaal voor die proc. aanwezig zijn. Zo zal een I686 bepaalde voordelen hebben op een Intel pentium-III, terwijl die kernel op een Intel Pentium I waarschijnlijk ook wel zal lopen, maar langzamer.

    Wat Suse betreft.
    Je hoeft niet bang te zijn dat bepaalde dependecies ge-update moeten worden aangezien die benodigd zijn voor Suse zelf en dus standaard erin gebakken zitten.
    De CD die jij bezit is een evaluatie CD die loopt vanaf de CD zelf. Als je Suse wil installeren ben je tot nu nog gebonden aan het downloaden van Suse 7.3 iso-images of naar de winkel gaan en Suse 8.0 kopen aangezien deze nog niet via anonymous ftp te krijgen is. (tenzij iemand de dvd/cd's op zijn prive ftp set).
  • zodra je regelmatig nieuwe software van het net plukt, kan het zijn dat die software nieuwere libs nodig heeft dan die jij bij je distro meekrijgt.. voorlopig hoef je bij suse8 of RH 7.3 je daar niet zorgen overmaken.. echter komt die tijd vanzelf weer..
    het dependecy probleem is niet distro afhankelijk. . het gebeurd bij elke distro. zodra een bepaald progsel een nieuwere versie van bijv. de XML libs verreist.. moet je die gewoon downloaden en compilen..
    RH 7.1 is dus zo bagger nog niet. hij is enkel verouderd t.o.v. suse 8 en.of RH 7.3
    overigens heeft RH 7.1 wel andere issues.
  • Dus CVS is dus niets anders als een beta-versie van een bepaald programma/software?

    En een devel package is dus de laatste beta-versie die verschenen is van een programma/software? Als dat zo is waarom worden dan veel devel packages meegeleverd bij een bepaalde distro van linux. Ze kunnen dan toch beter de laatste stabiele versie meeleveren?

    En ik heb inmiddels die SuSE 8.0 uitgeprobeerd, en dat is inderdaad een CD-versie. Dus daar heb ik zelf niet veel aan.

    Maar ik heb nu van een collega Mandrake 8.2 (3 cd's) gekregen. Dus ik denk dat ik die maar eens ga proberen. Is dat volgens jullie een goede distro en een goede versie van deze distro?

    Ik lees hier namelijk op dit form dat niet iedereen te spreken is over 8.2 van Mandrake. 8.1 zou beter zijn. Ik las gister een vraag over Sjoerd Boerhout die problemen had om een msn-client aan de praat te krijgen onder 8.2, omdat die in de /opt directory geïnstalleerd wordt. En dan zou het niet goed werken (dat zei maximilaan). Maar als ik programma op de volgende manier installeer:
    ./configure –prefix /usr/bin

    dan komt tie niet in de /opt directory terecht. Werkt alles dan wel goed? Of is 8.2 gewoon een afrader?
  • Volgens mij wordt het e.e.a. fout beantwoord…

    [quote:5052258249="roy_startpag"]Ik kom in linux de volgende termen tegen en ik zou graag willen weten wat ze betekenen:

    CVS
    [/quote:5052258249]

    CVS is een systeem waarmee verschillende onwikkelaars gezamelijk aan een broncode kunnen werken. De broncode wordt in een CVS tree geplaats, vervolgens kan elke ontwikkelaar (en vaak ook buitenstaanders) de nieuwste versies van de broncode krijgen, veranderingen maken (met een speciaal mechanisme dat eventuele conflicten tussen veranderingen van verschillende personen probeert op te lossen), enzovoorts.

    [quote:5052258249]
    devel (b.v. pim-devel, gimp-devel enz)
    [/quote:5052258249]

    Deze packages bevatten de libraries en headers die nodig zijn om zelf programma's te ontwikkelen die gebruik maken van deze bibliotheken.

    [quote:5052258249]
    i386 (ik d8 altijd dat dat een andere benaming is voor ibm compatible pc processor)

    maar opeens kwam ik meerdere begrippen tegen die daar op leken en toen was ik de weg kwijt. Dus ik zou ook graag willen weten wat de onderstaande begrippen beteken

    i486
    i586
    i686
    [/quote:5052258249]

    i386 is inderdaad de processor van een PC met een Intel 80386 processoren. Processoren die nieuwer zijn (486 etc.) zijn compatible met de i386 processor. De C compiler voor Linux/*nix (gcc) biedt mogelijkheden om te optimaliseren voor bepaalde processoren. Vrijwel altijd is de code backwards compatible met de i386, behalve in het geval van de kernel.
  • [quote:e215d94169="roy_startpag"]
    Ik lees hier namelijk op dit form dat niet iedereen te spreken is over 8.2 van Mandrake. 8.1 zou beter zijn. Ik las gister een vraag over Sjoerd Boerhout die problemen had om een msn-client aan de praat te krijgen onder 8.2, omdat die in de /opt directory geïnstalleerd wordt. En dan zou het niet goed werken (dat zei maximilaan). Maar als ik programma op de volgende manier installeer:
    ./configure –prefix /usr/bin

    dan komt tie niet in de /opt directory terecht. Werkt alles dan wel goed? Of is 8.2 gewoon een afrader?[/quote:e215d94169]

    Ik denk dat ik me er ook ff mee moet bemoeien :D
    Wat wordt er trouwens [b:e215d94169]over[/b:e215d94169] mij gevraagd? :) :wink:

    Ik heb net zelf een paar dagen fatsoenlijk Mandrake 8.2 draaien. Tot nu toe ben ik heel tevreden. Installeren is heel goed te doen. Linux is nog helemaal nieuw voor me dus dat ik die MSNkloon niet meteen aan de praat kreeg is niet zo gek. Ik heb intussen Imici werkende.
    Laat je iig geval niet ontmoedigen door mijn vraag en installeer gewoon Linux. Mocht je een andere versie willen hebben, dan wil ik die best voor je downloaden en opsturen als je wilt.
  • en ik ben niet te spreken over 8.2
    heb er een tijdje mee gevogeld. kwam er op neer dat ik standaar een supermount kreeg bij mijn installatie…bleh dat wil ik niet,..zelf mounten.
    deze supermount gaf weer conflicten met me scsi emu zodat ik nie kon fikken.
    grootste euvel bij 8.2 was de crontab, die na 2 dagen rustig even 150 processen meer de toren afblies, waardoor de pids niet meer konden verwerkt.. systeem ging ten onder hangende. kon niet eens inloggen in een console.
    Ook zoiets is, dat ik nooit de mogelijkheid heb gevonden die grafische interface bij opstarten heb kunnen uitzetten, zodat ik niet kon zien wat er eventeel fout ging bij booten.
    8.2 ging mij teveel op windows lijken.. dat wil ik niet
  • [quote:c91d5ddf5a="KayJay"]en ik ben niet te spreken over 8.2
    heb er een tijdje mee gevogeld. kwam er op neer dat ik standaar een supermount kreeg bij mijn installatie…bleh dat wil ik niet,..zelf mounten.
    [/quote:c91d5ddf5a]

    Haal ik nou de verkeerde dingen door elkaar of…
    Bij de installatie kon ik opgeven welke schijven ik evt. en zo ja onder welke naam wilde mounten. Ik vind het juist wel makkelijk, maar dat zal wel komen omdat ik niet gewend ben te moeten mounten :D
    Ik heb es ff bij de instellingen zitten kijken en zag ineens dat ik volgens Mandrake een SCSIbrander heb??? Zoiets riep XP ook na de installatie en Nero heeft het ook een keer beweerd. En dat terijl ik m'n computer helemaal zelf gebouwd heb en dus heel zeker weet dat er geen SCSI in zit. Ik heb Mandrake 8.1 trouwens ook. Is die dan meer aan te raden dan 8.2? Zo ja, waarom precies.
  • mmm, ik heb draakje 8.2 voor de aardigheid ook maar eens geinstalleert (op 2 pc's)

    en het werkt wel aardig. (geen grafische boot overigens)

    eigenljk zou ik suse 8 eens moeten proberen maar ik vind het veel te duur…

    ftp kan nog niet…

    slackware&debian moet ik ook nog eens proberen.
    slackware 7 is mij iig tegengevallen :(
  • Bedankt voor jullie reacties, ik ga Mandrake gewoon installeren en ik zie vanzelf wel of het mij bevalt. En dan kan ik eventueel altijd overwegen om een andere distro te proberen.

    Om fff op de vraag van Sjoerd Boerhout terug te komen. Ik geloof dat Linux een brander als SCSI apparaat moet zien om goed te functioneren. Het kan zijn dat wat ik nu zeg fout is. Maar ik heb me dat een keer laten vertellen door iemand die zegt veel van linux te weten, en die daarvoor ook een cursus heeft gevolgd. Maar misschien heb je wat aan deze informatie :)
  • [quote:fc11b3f286="roy_startpag"]Om fff op de vraag van Sjoerd Boerhout terug te komen. Ik geloof dat Linux een brander als SCSI apparaat moet zien om goed te functioneren. Het kan zijn dat wat ik nu zeg fout is. [/quote:fc11b3f286]

    Het lijkt me een beetje raar eigenlijk…
    Maar voorlopig fik ik toch alle cd's vanuit windows, want Linux blijft toch nog ff een test. Zodra ik me daar goed thuisvoel kan ik dat wel eens een keer proberen.
  • [quote:bcf00e517b="Sjoerd Boerhout"][quote:bcf00e517b="roy_startpag"]Om fff op de vraag van Sjoerd Boerhout terug te komen. Ik geloof dat Linux een brander als SCSI apparaat moet zien om goed te functioneren. Het kan zijn dat wat ik nu zeg fout is. [/quote:bcf00e517b]

    Het lijkt me een beetje raar eigenlijk…
    Maar voorlopig fik ik toch alle cd's vanuit windows, want Linux blijft toch nog ff een test. Zodra ik me daar goed thuisvoel kan ik dat wel eens een keer proberen.[/quote:bcf00e517b]

    of je het raar vindt of niet… het is zo :D

    dat geldt overigens ook voor windows als ik het me goed herinner. met dat verschil dat het in windows netjes weggemoffeld wordt…

    overigens klinkt die scsi-emulatie veel ingewikkelder dan het is… :lol:
  • [quote:d5b10cf7fa="Sjoerd Boerhout"]
    Haal ik nou de verkeerde dingen door elkaar of…[/quote:d5b10cf7fa]
    Ik denk het ;)
    [quote:d5b10cf7fa]
    Bij de installatie kon ik opgeven welke schijven ik evt. en zo ja onder welke naam wilde mounten. Ik vind het juist wel makkelijk, maar dat zal wel komen omdat ik niet gewend ben te moeten mounten :D [/quote:d5b10cf7fa]
    Supermount is een applicatie waarmee je verwisselbare media (floppies, cd-rom's) automatisch kunt mounten als je ze er in stopt en vanuit een programma wilt openen. Beetje zoals in Windows dus.
    KayJay vindt dat niks, hij mount liever handmatig, dus floppy er in, commando "mount /mnt/floppy" floppy benaderen, floppy unmounten via commando "umount /mnt/floppy" en floppy er uit halen. (dit proces kan in een pictogram gevangen worden, zodat je met 1 muisklik mount/unmount)

    Klinkt omslachtig, maar als je dit gewend bent wil je vaak niet meer anders.
    Concurrent van Supermount is Automount, (gebruikt SuSe), deze is minder ergelijk dan automount, sterker nog, iemand die altijd handmatig mount zal de automount niet eens merken :D
    [quote:d5b10cf7fa]

    Ik heb es ff bij de instellingen zitten kijken en zag ineens dat ik volgens Mandrake een SCSIbrander heb??? Zoiets riep XP ook na de installatie en Nero heeft het ook een keer beweerd. En dat terijl ik m'n computer helemaal zelf gebouwd heb en dus heel zeker weet dat er geen SCSI in zit.[/quote:d5b10cf7fa]
    cd's branden gebeurt mbv SCSI-emulatie, waarom weet ik niet, is nu eenmaal zo :P
    [quote:d5b10cf7fa]
    Ik heb Mandrake 8.1 trouwens ook. Is die dan meer aan te raden dan 8.2? Zo ja, waarom precies.[/quote:d5b10cf7fa]

    Geen idee, je zou verwachten dat 8.2 beter is??

    Max

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.