Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

cd brander niet herkent

None
17 antwoorden
  • ik gebruik mandrake 8.2 maar deze herkent niet direct mijn IDE brander

    Als ik als root cdrecord -scanbus doe ziet hij niets.

    Wat kan ik doen om dt wel voor elkaar te krijgen ..??

    Alvast bedankt.
  • SCSI emulatie aanzetten voor je cd-brander.
    Op Google staat hoe en wat..
    Ik hoefde zelf alleen me lilo.conf aan te passen en daarmee werd me cd-brander en cd-rom speler gevonden.

    M.
  • in de lilo.conf file wordt the emulatie aangeroepen met het append statement ,
    of moet ik nog meer doen ??
  • append = " acpismp=force hdb=ide-scsi hdc=ide-scsi"
  • In lilo.conf moet een regel met
    [code:1:f9003fefbf]
    append = "hdx=ide-scsi"
    [/code:1:f9003fefbf]
    staan, waarin x vervangen wordt met de letter van de CD schrijver. Dit zet de normale toewijzing als ATAPI/IDE aparaat (/dev/hdx) uit. Vervolgens moet je de SCSI emulatie laden, als er een module voor is kan dit gewoon met "modprobe ide-scsi".
  • in de lilo.conf file staat de volgende lijn

    append=" devfs=mount hdd=ide-scsi hdc=ide-floppy"

    het commando modprobe ide-scsi geeft niets terug, werkelijk niets ..

    Ik heb in de kernel configuration gekeken en hier staat de scsi ondersteuning aan.

    Wat kan ik nog bekijken ??

    de cdrecord -scanbus optie geeft aan dat hij de scsi driver niet kan laden terwijl er via dmesg wel e.e.a. te zien is …
  • [quote:9d66344002="polinski"]in de lilo.conf file staat de volgende lijn

    append=" devfs=mount hdd=ide-scsi hdc=ide-floppy"

    het commando modprobe ide-scsi geeft niets terug, werkelijk niets ..

    Ik heb in de kernel configuration gekeken en hier staat de scsi ondersteuning aan.

    Wat kan ik nog bekijken ??

    de cdrecord -scanbus optie geeft aan dat hij de scsi driver niet kan laden terwijl er via dmesg wel e.e.a. te zien is …[/quote:9d66344002]

    OK, we komen al ergens, het modprobe commando geeft geen foutmelding dus de ide-scsi module is er zowieso. Controleer eerst even of de append regel daadwerkelijk uitgevoerd wordt door te proberen een CD met /dev/hdd te mounten, dan moet niet kunnen. Als dat OK is, geeft modprobe ide-scsi niks in de dmesg of /var/log/messages af? Alsie dat niet doet is het enige wat ik me kan bedenken dat er geen SCSI CD-ROM (misschien wel SCSI) support in de kernel zit…
  • gek genoeg gaf mandy 8.1 nooit van dit soort euvels..
    ik ken erken dit probleem bij 8.2, omdat ik het daar ook heb meegemaakt.
    zou het temaken kunnen hebben met de supermount? ( staat /etc/mtab)
    ik vind het raar dat 8.1 gewoon standaard al kan fikken en 8.2 ineens niet meer.. belachelijk eigenlijk voor een distro als MDK
  • Hoe werkt dat "append" regeltje bij GRUB? Zelfde manier?
  • danieldk,

    ik kan inderdaad de drive niet mounten, de melding zegt :

    mount: special device /dev/hdd does not exist

    ik kan verder niets vinden met dmesg over ide-scsi.

    er is wel een echte scsi adaptor ind e amchine aanwezig met daaraan een scsi cdrom speler, een jaz drive en een tapestreamer.

    Alvast bedankt
  • dmesg is waarschijnlijk ook vaan Mandy niet meer de juiste opdracht

    kijk eens of Mandrake een /var/log/boot.??? aanmaakt

    doe dan
    [code:1:2a14972524]
    cat /var/log/boot.msg | grep scsi
    [/code:1:2a14972524]

    nu moet ja AL je scsi apparaten zien dus ook sr0 (ide-scsi cdrom)
  • dit wat ik vind in de diverse log files :

    syslog :

    Jun 19 19:18:16 etsoft kernel: Kernel command line: BOOT_IMAGE=linux ro root=301 devfs=mount hdd=ide-scsi hdc=ide-floppy
    Jun 19 19:18:16 etsoft kernel: ide_setup: hdd=ide-scsi
    Jun 19 19:18:16 etsoft kernel: scsi-ncr53c7,8xx : at PCI bus 0, device 11, function 0
    Jun 19 19:18:16 etsoft kernel: scsi-ncr53c7,8xx : warning : revision of 18 is greater than 2.
    Jun 19 19:18:16 etsoft kernel: scsi-ncr53c7,8xx : NCR53c810 at memory 0xcfffff00, io 0xd800, irq 3
    Jun 19 19:18:16 etsoft kernel: scsi0 : burst length 2
    Jun 19 19:18:16 etsoft kernel: scsi0 : reset ccf to 3 from 0
    un 19 19:17:29 etsoft : Loading module: scsi_hostadapteuun 19 19:17:29 etsoft : Loading module: scsi_hostadapten 19 19:17:29 etsoft : Loading module: scsi_hostadapteJun 19 19:18:16 etsoft kernel: scsi0 : NCR code relocated to 0x1fcd0614 (virt 0xdfcd0614)
    Jun 19 19:18:16 etsoft kernel: scsi0 : test 1 started
    Jun 19 19:18:16 etsoft kernel: scsi0 : NCR53c{7,8}xx (rel 17)
    Jun 19 19:18:16 etsoft kernel: scsi0 : target 1 accepting asynchronous SCSI
    Jun 19 19:18:16 etsoft kernel: scsi0 : setting target 1 to asynchronous SCSI
    Jun 19 19:18:16 etsoft kernel: scsi0 : target 3 accepting asynchronous SCSI
    Jun 19 19:18:16 etsoft kernel: scsi0 : setting target 3 to asynchronous SCSI
    Jun 19 19:18:16 etsoft kernel: scsi0 : target 6 accepting asynchronous SCSI
    Jun 19 19:18:16 etsoft kernel: scsi0 : setting target 6 to asynchronous SCSI
    Jun 19 19:18:16 etsoft kernel: Attached scsi removable disk sda at scsi0, channel 0, id 6, lun 0
    Jun 19 19:18:16 etsoft kernel: /dev/scsi/host0/bus0/target6/lun0: p1 p2 p3 p4
    Jun 19 19:18:16 etsoft kernel: st: Found incompatible tape at scsi0, channel 0, id 1, lun 0
    Jun 19 19:18:16 etsoft kernel: scsi1 : SCSI host adapter emulation for IDE ATAPI devices
  • kijk eens mbv. een file manager (MC ofzo)
    in /dev/scsi/host1/……

    of je hier je cdrom in kan terugvinden

    Anders zou ik zeker tot je je systeem echt doorheb eerst maar
    [code:1:805955d75c]
    devfsd
    [/code:1:805955d75c]
    installeren. Deze maakt je systeem dan weer volgens de oude normen toegangkelijk (dus er wordt een koppeling gemaakt naar bijv. /dev/sda en voor je cdrom /dev/sc0

    Helaas kunnen nml. nog niet alle proggies met devfs overweg (volgens mij tenminste)

    overigens zie ik in je lijst wel dat ide-scsi geladen wordt en toegewezen aan je ATAPI-cdrom maar niet dat die een devicenaam krijg.


    Dat mandrake 8.1 geen problemen gaf heeft mijn inziens met devfs te maken (8.1 gaf dacht ik de optie om het te gebruiken maar installeerde standaard dan ook devfsd mee)
  • hier kan ik inderdaad twee cdrom's vinden, waarschijnlijk de echte scsi en de ide … /dev/scsi/host0/target5/lun0/ en op /dev/scsi/host0/target3/lun0

    wat nu verder ??
  • [quote:ac821ff19a="polinski"]hier kan ik inderdaad twee cdrom's vinden, waarschijnlijk de echte scsi en de ide … /dev/scsi/host0/target5/lun0/ en op /dev/scsi/host0/target3/lun0

    wat nu verder ??[/quote:ac821ff19a]

    nope dat zijn niet twee cdrom' s

    Kijk maar hier wordt alleen host0 opgegeven dus kun je checken welk apparaat target 1 -3 -6 hebben
    dus je cdrom, tapedrive en je jazzdrive

    als het goed is moet er volgens mij (wie weet er meer van devfs ?? ) ook
    /dev/scsi/host1/….. zijn
  • ik heb het gevonden, zoals eerder beshreven stond er in de lilo.conf de volgende lijn :

    append=" devfs=mount hdd=ide-scsi hdc=ide-floppy"

    Door 'devfs=mount' weg te halen werkt het wel.

    Kan iemand mij vertelle wat dit doet ??

    Nog bedankt voor alle antwoorden.
  • zoals hierboven al aangetipt
    devfs is ene andere manier van /dev opbouw, met devfs is deze "dynamisch" oftewel ipv. al je devices vooraf aan te maken doet de kernel dit tijdens het booten.

    Gevolg hiervan is dat /dev/hdc helemaal niet bestaat of, wanneer je devfsd, de deamon dus, opstart slechts als link naar /dev/scsi enz

    Hoe devfs verder met ide-scsi omgaat weet ik niet

    kijk anders ff op
    http://www.vandekamer.com/linux/devfs.asp

    hier staat een goede uitleg over devfs

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.