Vraag & Antwoord

OS Linux

Nieuwe uitgave KDE: KDE 3.02!!

11 antwoorden
  • VOOR ONMIDDELIJKE UITGAVE KDE-project verscheept uitgebreide service release voor toonaangevende Open Source Desktop Het KDE-project verscheept de derde generatie van de toonaangevende desktop voor Linux/UNIX. Het biedt daarmee de overheid, het bedrijfsleven, scholen en andere instituten een uitstekende vrije en open Desktop-oplossing. 2 juli, 2002 (het Internet).Het KDE-project kondigt vandaag de onmiddelijke beschikbaarheid aan van KDE 3.02, de derde generatie van KDE's vrije, krachtige desktop voor Linux en andere Unix-systemen. KDE 3.02 is beschikbaar in 50 talen en wordt verscheept met KDE's kernbibliotheken, de basis desktop environment, een integrated development environment, en honderden applicaties en andere desktop-uitbreidingen afkomstig uit de andere basis KDE-pakketten (PIM, administration, network, edutainment, development, utilities, multimedia, games, artwork, en anderen). KDE 3.0.2 biedt primair verbeteringen in de stabiliteit en bruikbaarheid van het systeem t.o.v. KDE 3.01, welke eind mei 2002 uitkwam. Een complete lijst met wijzigingen sinds KDE 3.0 kunt u vinden in de change log. "KDE 3.0.2. is de tweede onderhoudsuitgave van de KDE 3.0-serie," legt Dirk Mueller, de uitgavecoördinator voor KDE 3 uit. "Een aantal stabiliteits- en bruikbaarheidsverbeteringen uit de actieve KDE 3.1 branch zijn overgebracht naar de KDE 3.0 codebase en gebundeld in deze uitgave. We adviseren alle gebruikers van KDE 3 om hun systemen op te waarderen naar deze nieuwste stabiele uitgave." KDE, inclusief al haar bibliotheken en applicaties, is gratis en vrij beschikbaar onder Open Source-licenties. KDE kan worden opgehaald als broncode en diverse binaire formaten van KDE's http- of ftp-mirrors. Daarnaast is KDE verkrijgbaar op CD-ROM of bij een van de grote Linux/Unix-systemen die vanaf vandaag worden verscheept. Voor meer informatie over de KDE 3-serie kunt u de aankondiging van KDE 3.0 en de KDE 3.0.2 information page lezen. Het installeren van de binaire pakketten van KDE 3.0.2 Binaire pakketten. Enkele uitgevers van Linux/Unix-systemen zijn zo vriendelijk geweest om binaire pakketten van KDE 3.02 beschikbaar te maken voor bepaalde versies van hun distributies. En in andere gevallen zijn er vrijwilligers uit de gemeenschap geweest die deze pakketten beschikbaar hebben gemaakt. Enkele van deze binaire pakketten zijn gratis en vrij verkrijgbaar op KDE's http- of ftp-mirrors. Additionele binaire pakketten als ook bijwerkingen van de nu beschikbare pakketten zullen de komende weken te vinden zijn op de KDE-servers. Opmerking: het KDE-project maakt deze pakketten beschikbaar op haar websites als service voor haar gebruikers. Het KDE-project is niet verantwoordelijk voor deze pakketten, aangezien ze door derden zijn aangeverd, meestal, maar niet altijd, de uitgever van de betreffende distributie. Hierbij worden tools, compilers, bibliothekenversies en kwaliteitsgarantieprocedures gebruikt waar KDE geen enkele controle over heeft. Daarnaast zijn er enkele uitgevers die de binaire pakketten alleen via hun eigen servers beschikbaar maken. Als u geen binaire pakketten kunt vinden voor uw besturingssysteem, of u bent niet tevreden met de kwaliteit van de pakketten die voor uw systeem beschikbaar zijn, lees dan de KDE Binary Package Policy en/of neem contact op met de uitgever van uw besturingssysteem.. Vereiste/optionele bibliotheken. De bibliotheekvereisten voor een bepaald binair pakket is afhankelijk van het systeem waarop het pakket is gecompileerd. Houd er rekening mee dat sommige binaire pakketten een nieuwere versie van QT en andere biblioteken vereisen dan met uw systeem is meegeleverd (bijv. LinuxDistro X.Y is verscheept met Qt-3.0.0, maar de pakketten genoemd hieronder kunnen Qt-3.0.3 vereisen). Voor de algemene bibliotheekvereisten van KDE leest u de Bibliotheekvereisten voor de broncode hieronder. Pakketlocaties. Ten tijde van deze uitgave zijn voorgecompileerde pakketten beschikbaar via de KDE-servers (of ergens anders, waar aangegeven) voor de volgende distributies en versies (lees altijd eerst de eventuele README-bestanden): Conectiva Linux: 8.0: Intel i386 Mac OS / OpenDarwin (downloads via het Fink-project): X Mandrake Linux: 8.2: Intel i586 8.1: Intel i586 8.0: Intel i586 Zie ook in de map noarch voor i18n-pakketten (taalmodules). SuSE Linux: 8.0: Intel i386 7.3: Intel i386 en IBM PowerPC 7.2: Intel i386 7.1: Intel i386 7.0: Intel i386 Kijk ook in de map noarch voor i18n-pakketten (taalmodules). Tru64: 4.0d, e, f en g en 5.x: Compaq Alpha Meer binaire pakketten zullen de komende dagen en weken beschikbaar komen. KDE 3.0.2 compileren Vereiste/optionele bibliotheken. KDE 3.0.2 vereist Qt 3.0.3 voor X11. Daarnaast kan KDE gebruik maken van een aantal andere optionele bibliotheken en applicaties waarmee u uw desktop-ervaring en -mogelijkheden kunt uitbreiden. Compiler-vereisten. KDE is ontworpen als cross-platform-software en is daarom te compileren met een grote verscheidenheid aan Linux/UNIX-compilers. Maar KDE ontwikkelt zich razendsnel en de mogelijkheid om met native compilers op diverse UNIX-systemen KDE te kunnen compileren is afhankelijk van gebruikers van die systemen die eventuele problemen bij het compileren van KDE melden bij de verantwoordelijke ontwikkelaars. Met respect voor de meest populaire KDE-compiler gcc/egcs, houdt u er rekening mee dat sommige onderdelen van KDE niet correct zullen compileren met versies van gcc ouder dan gcc-2.9.5, zoals egcs-1.1.2 of gcc-2.7.2, of met niet-gepatchte versies van gcc 3.0.x. Daarentegen dient KDE goed te compileren met gcc 3.1. Broncode / SRPM's. De complete broncode van KDE 3.0.2 is beschikbaar om te downloaden. Deze broncodes zijn digitaal ondertekend met GnuPG waarbij gebruik is gemaakt van de KDE Archives PGP Key (beschikbaar op de KDE Signature page of op public key-servers), en hun respectievelijke MD5 sums staan vermeld op de KDE 3.0.2 Info Page. Daarnaast zijn er broncode-rpm's beschikbaar voor Conectiva Linux, Mandrake Linux en SuSE Linux. Meer informatie. Voor verdere instructies voor het compileren en installeren van KDE 3.0.2 kunt u terecht bij de installation instructions en, als u problemen ondervindt bij het compileren, de KDE Compilation FAQ. KDE Sponsorschap Naast de fantastiche en onschatbare inspanningen van de KDE-ontwikkelaars zelf is er belangrijke ondersteuning voor KDE-ontwikkeling aangeleverd door MandrakeSoft en SuSE. Bovendien leveren de leden van de KDE League belangrijke ondersteuning voor het promoten van KDE, en levert de University of Tübingen het grootste deel van de Internet-bandbreedte voor het KDE-project. Bedankt! Over KDE KDE is een onafhankelijk project van honderden ontwikkelaars, vertalers, grafische designers en professionals die wereldwijd samenwerken via het Internet om een vrij verkrijgbare desktop- en kantoor-omgeving te creëren. Hierbij maakt men gebruik van een flexibele, componenten-gebaseerde, netwerk-transparante architectuur waarbij KDE fungeert als het perfecte ontwikkelplatform. KDE voorziet in een stabiele, volwassen desktop, een compleet Office-pakket (KOffice), een groot aantal netwerk- en adminstratieprogramma's en een efficiënte, intuitief ontwikkelplatform waarbij men gebruik kan maken van de voortreffelijke IDE KDevelop. KDE is het bewijs dat het Open Source software-model "Bazaar-style" een eersteklas technologie kan voortbrengen wat gelijkwaardig zoniet beter is dan de meeste complexe commerciële software. Trademarks Notices. KDE, K Desktop Environment, KDevelop en KOffice zijn handelsmerken van KDE e.V. Compaq, Alpha en Tru64 zijn handelsmerken en/of service-merken of geregistreerde handelsmerken en/of service-merken van Hewlett-Packard. IBM en PowerPC zijn geregistreerde handelsmerken van IBM Corporation. Intel is een handelsmerk of geregistreerd handelsmerk van Intel Corporation of haar subsidiaries in de Verenigde Staten en andere landen. Linux is een geregistreerd handelsmerk van Linus Torvalds. Trolltech en Qt zijn handelsmerken van Trolltech AS. UNIX en Motif zijn geregistreerde handelsmerken van The Open Group. Alle andere handelsmerken of auteursrechten waarnaar wordt verwezen in deze aankondiging zijn eigendom van hun respectievelijke eigenaars..
  • Ik ben zeer onder de indruk van KDE3, en denk dat het voor veel bedrijven dé motivatie zal zijn desktops op basis van Linux in te richten. Dan volgen de thuisgebruikers ook wel. Echt prachtig werk. Trouwens ook GNOME2 mag er wezen.
  • [quote:6cc076fac6="wbsoft"]Ik ben zeer onder de indruk van KDE3, en denk dat het voor veel bedrijven dé motivatie zal zijn desktops op basis van Linux in te richten. Dan volgen de thuisgebruikers ook wel. Echt prachtig werk. Trouwens ook GNOME2 mag er wezen.[/quote:6cc076fac6] Geloof toch dat het andersom vaker voorkomt. Was KDE2/ SuSE 7 niet zo goed geweest dan werkte ik nu dagelijks met win2k ipv Linux Overigens nu we SuSE 7.2 & 7.3 draaien met bijbehorende KDE versies (2.1 & 2.2 ??? ) en dat naar tevredenheid draaid zie ik het niet zitten om te upgraden ondanks dat KDE3 betere proggie's bevat en sneller is.
  • Heb KDE3.0.2 gedownd vanuit Heilbronn (ja het stond in de 'stable' dir) en wilde hem eerst maar eens naast KDE3.0.1 zetten, die ik al had. Dus: /opt/kde veranderd in /opt/kde.orig, en daarna gaan installeren. In kdelibs ./configure opgeven, wat halverwege er mee op houdt omdat hij een bepaald proggie niet kan vinden. locate geeft aan dat dit staat in wat nu /opt/kde.orig heet. Dan maar even een linkje gemaakt en opnieuw proberen, juist ja, het volgende proggie dient zich aan, wat ook weer in /opt/kde.orig staat. Nu heb ik van /opt/kde.orig maar weer /opt/kde gemaakt en nu compileert het wel. Leuk vind ik dit niet, want het houdt in dat KDE3.0.1 overschreven wordt met KDE3.0.2, en er allerlei rotzooi van 3.0.1 achterblijft. Iemand die KDE nog niet op zijn computer heeft en het mbv. deze sourcecode wil installeren zal daar dus geen succes mee hebben, of zie ik dat verkeerd? Alvorens bij KDE te gaan klagen gooi ik het probleem hier eerst maar eens in de groep.
  • Als je kde wilt compileren naast je bestaande kde, dan is het misschien een optie om de originele kde niet te verplaatsen, maar een kopie ervan te maken. Op die manier voorkom je dat de compilatie onderdelen die niet met de broncode van kde 3.02 zijn meegeleverd niet kan vinden, en voorkom je dat je huidige installatie wordt overschreven. Overigens moet kde 3.02 te compileren zijn zonder de aanwezigheid van een kde-installatie. Max
  • Fijn, kan ik WEER gaan compilen >:(
  • [quote:6f44a29ff0="phaas"]Fijn, kan ik WEER gaan compilen >:([/quote:6f44a29ff0] Had je nu maar voor Gentoo gekozen, dan had je kunnen updaten. :lol:
  • [quote:8f6566b9d0="maximilaan"]Als je kde wilt compileren naast je bestaande kde, dan is het misschien een optie om de originele kde niet te verplaatsen, maar een kopie ervan te maken. Op die manier voorkom je dat de compilatie onderdelen die niet met de broncode van kde 3.02 zijn meegeleverd niet kan vinden, en voorkom je dat je huidige installatie wordt overschreven.[/quote:8f6566b9d0] Ja, dat had ik wel begrepen, maar had geen zin in copieren. Herinstalleren van kde 3.0.1 vanuit voorgecompileerd Slackware-package dan maar als dat moet. [quote:8f6566b9d0="maximilaan"]Overigens moet kde 3.02 te compileren zijn zonder de aanwezigheid van een kde-installatie. [/quote:8f6566b9d0] Je zou het denken, maar mij lukte dat dus niet, zoals ik al vertelde, want de 'oude' kde was door mij 'verborgen', en ik had een lege /opt/kde dir aangemaakt. En als dit waar is, dan is er een serieus probleem met deze nieuwe versie.
  • Probeer eerst eens arts te installeren ipv kdelibs, anders kan die inderdaad bepaalde programma's (zoals artscfg) niet vinden, uit eigen ervaring met kde3.0.0.
  • Zo he, over een maandje komt kde 3.03 ook alweer uit zag ik. En voor wie nieuwsgierig is naar kde 3.1, [url=http://static.kdenews.org/mirrors/qwertz/kde31alpha/]hier[/url] kun je vast een voorproefje krijgen Max
  • Zogauw LFS 4.0 uit is en KDE 3.1 ga ik een nieuw systeem from scratch bouwen, en dan [i:4f11681c1f]zou het wel eens kunnen zijn[/i:4f11681c1f] dat ik helemaal voor de KDE environment ga. :o wie had dat 3.5 jaar geleden gedacht :-)

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.