Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[suse 7.3] Qt-free versie vraagt toch om licensie?!?

None
4 antwoorden
  • Ik heb qt-x11-free-3.0.4.tar.bz2 gedownload van ftp://ftp.trolltech.com/ maar krijg het niet geinstalleerd. Volgens Trolltech zou je hem gewoon moeten kunnen installeren (dit i.t.t. de commerciele versie, daar heb je een licensiefile voor nodig). Maar als ik ./configure run, krijg ik dit:
    [code:1:3fb4167d60]./configure: [: too many arguments
    ./configure: [: too many arguments
    ./configure: [: too many arguments
    ./configure: [: too many arguments
    The LICENSE, LICENSE.QPL, or LICENSE.GPL file shipped with
    this software has disappeared.

    Sorry, you are not licensed to use this software.
    Try re-installing.[/code:1:3fb4167d60]
    Heeft iemand enig idee hoe dit komt, en hoe ik het op kan lossen? Op de Trolltech-site kan ik er niets over vinden.
  • Oh ja, en de INSTALL-file zegt hierover:

    Install your license file as $HOME/.qt-license.
    For the free edition, you do not need a license file. For Professional
    and Enterprise editions, install your license file as described in your
    distribution.
  • Het lijkt op een foutje in ./configure, hij gebruikt het commando '[' (ofwel test) maar er zijn teveel argumenten.

    Gokje: heb jij ergens in je PATH of huidige directory spaties in je filenamen? Zoiets lijkt het eigenlijk.

    Kijk ook eens even zelf of de file LICENSE, LICENSE.QPL, of LICENSE.GPL wel aanwezig zijn. Waarschijnlijk gaat die check mis door de mislukte test (al dan niet (maar waarschijnlijk niet) een syntaxisfout in de ./configure file).

    Succes!
  • Ah, precies, ik had spaties in die directorynaam (in Opera gemaakt met het downloaden, ik schaam me diep :oops: :wink: ). Die heb ik al weggehaald, omdat ik daar meer problemen mee kreeg. Van die 's steeds in de commandline ga je ook scheelkijken, dus waarom ik ueberhaupt nog spaties gebruik als ik in een grafische omgeving directorynamen verzin … Ik zal mijn leven beteren! :)

    Ik had trouwens al een oplossing gevonden voor het QT-probleem, hetzij een beetje met een omweg. Heb nl. de source-RPM van QT geinstalleerd en dat ging wel :)

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.