Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[SuSE 7.3] KDE start niet meer op na geklooi met QT

None
7 antwoorden
  • Verdorie, af en toe baal ik zo van mezelf! (zoals nu dus :evil: :() Had ik QT 3.0.4 al van source-RPM, en ben ik *toch* gaan klooien met die source (inderdaad, de spaties weghalen uit die directorynaam was voldoende om het te laten runnen). Vraag me niet waarom ik dat gedaan heb .. maar nu zit ik wel met de gebakken peren.

    Ik heb de source alsnog geinstalleerd. Toen ik ./configure runde, kreeg ik een foutmelding dat ie QTDIR verwachtte onder /usr/lib/qt2. Aangezien ik zo gauw niet kon vinden hoe ik die verwijzing moest veranderen, dacht ik, als Mohammed niet naar de berg gaat, dan de berg maar naar Mohammed, en heb ik de bups naar die dir verhuisd en alles gecompileerd en geinstalleerd. Dom dom dom! Nu wil KDE2.2.2 niet meer opstarten, omdat hij een file van qt2 niet kan vinden. Dat geldt ook voor programma's als Kmail en Opera (al heb ik van die laatste maar ff de statische versie gedownload. .. FWVM is tot daaraantoe, maar van Lynx ga ik echt scheelkijken :D)

    De foutmelding is als volgt:
    [code:1:649c918bbf] error while loading shared libraries: libqt.so.2: cannot open shared object file: No such file or directory[/code:1:649c918bbf]
    Wat kan ik hieraan doen? Mijn plan was om KDE 3.0.2. te gaan compileren/installeren en nu kan ik niet eens meer in mijn oude KDE komen! Ik baal als een stekker en schaam me diep :oops: :cry: Ik hoop dat jullie me met dit heikele probleem kunnen helpen. Alvast bedankt.
  • Is het niet mogelijk om die oude qt dir te linken naar de nieuwe?

    Bart
  • Hmm, je hebt qt3 over qt2 heen gecompileerd?
    kde 2.2 is niet compatible met qt3, dus start die niet meer op
    Hoe los je dat op?
    doe een make uninstall in de map waarin je qt3 hebt gecompileerd, deinstalleer qt2 met de packagemanager van je distro, eventueel geforceerd. Ruim de eventuele troep van de qt's op en installeer qt2 opnieuw.

    Max
  • [quote:8a2e1f8ef5="maximilaan"]Hmm, je hebt qt3 over qt2 heen gecompileerd?[/quote:8a2e1f8ef5]
    Inderdaad!
    [quote:8a2e1f8ef5]kde 2.2 is niet compatible met qt3, dus start die niet meer op[/quote:8a2e1f8ef5]
    LOL, dat heb ik gemerkt! ;)
    [quote:8a2e1f8ef5]Hoe los je dat op?
    doe een make uninstall in de map waarin je qt3 hebt gecompileerd, deinstalleer qt2 met de packagemanager van je distro, eventueel geforceerd. Ruim de eventuele troep van de qt's op en installeer qt2 opnieuw.[/quote:8a2e1f8ef5]
    Bedankt voor de uitleg, zodra ik tijd heb, ga ik dit doen. En dan eens *goed* kijken hoe ik qt3 naast qt2 kan installeren, zodat ik met KDE3 aan de slag kan.
  • Mmm, als ik make uninstall doe, krijg ik de volgende foutmelding:[code:1:2c7ec50f3c]linux:/usr/lib/qt2 # make uninstall
    make[1]: Entering directory `/usr/lib/qt2'
    cd qmake && make uninstall
    make[2]: Entering directory `/usr/lib/qt2/qmake'
    make[2]: *** No rule to make target `uninstall'. Stop.
    make[2]: Leaving directory `/usr/lib/qt2/qmake'
    make[1]: *** [qmake-uninstall] Error 2
    make[1]: Leaving directory `/usr/lib/qt2'
    make: *** [uninstall] Error 2[/code:1:2c7ec50f3c]Enig idee wat er mis gaat en hoe dit op te lossen?
  • Vogens make uninstall valt er niks te verwijderen. Kan 2 dingen betekenen:
    1: er is niks geinstalleerd (geen make install gedaan)
    2: de optie make uninstall is niet aangemaakt in de broncode die je hebt gecompileerd.

    Geeft op zich niks, gewoon qt2 verwijderen met de packagemanager, zo goed en kwaad dat gaat, de restanten opruimen en qt2 opnieuw installeren.

    Kijk op www.kde.org hoe je qt 3 veilig kunt compileren zonder t2 te slopen.

    [quote:eaca027b41]

    Een leuk ontwerp voor een Linux t-shirt: http://spywarefreeag.ods.org/div/linux-t-shirt.jpg
    [/quote:eaca027b41]
    Jep is een hele mooie.
    Probleem is dat de afbeelding die je aanbiedt eigenlijk te klein is.

    Max
  • [quote:a0a478138c="maximilaan"]Vogens make uninstall valt er niks te verwijderen. Kan 2 dingen betekenen:
    1: er is niks geinstalleerd (geen make install gedaan)[/quote:a0a478138c]Dat is niet het geval.[quote:a0a478138c]2: de optie make uninstall is niet aangemaakt in de broncode die je hebt gecompileerd.[/quote:a0a478138c]?? Nou ja het zal wel ..
    [quote:a0a478138c]Geeft op zich niks, gewoon qt2 verwijderen met de packagemanager, zo goed en kwaad dat gaat, de restanten opruimen en qt2 opnieuw installeren.[/quote:a0a478138c]OK, ik zal mijn best doen ;)
    [quote:a0a478138c]Kijk op www.kde.org hoe je qt 3 veilig kunt compileren zonder t2 te slopen.[/quote:a0a478138c]Goed![quote:a0a478138c]Jep is een hele mooie.
    Probleem is dat de afbeelding die je aanbiedt eigenlijk te klein is.[/quote:a0a478138c]Oh? Ik heb hem op een t-shirt staan en hij ziet er goed uit. Oeps, nu zie ik wel wat je bedoelt .. Ik moest het in A4 formaat aanbieden, dacht dat ik dat gedaan had, maar hij is inderdaad kleiner uitgevallen. Hoe kan dat?!

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.