Vraag & Antwoord

OS Linux

[SuSE 8.0] Probleem met OpenGL

Anoniem
Marcel de Reus
70 antwoorden
  • Idd kijk ook maar eens op PinquinPower.nl daar staat ook hoe de Windhoos UT onder Linux te draaien. Ik heb hem net gehaald en ga er zo mee aan de slag.
    Dan ga ik ook gelijk ff de linkies bekijkeken en kijken of Q3 wil draaien.
    Waar heb jij je demo vandaan gevist? Ik heb hem namelijk gewoon van idsoftware en daar was dit de nieuwste versie.
  • [quote:9cbd455739="Marcel de Reus"]Idd kijk ook maar eens op PinquinPower.nl daar staat ook hoe de Windhoos UT onder Linux te draaien. [/quote:9cbd455739]Weet je zeker dat je het goed getypt heb, zelf google kent géén pinquinpower.
    Ik dacht dat je een Linux Unreal Tournament bedoelde.
    http://www.unrealtournament.com/linux/ Maar ik kon me al niet voorstellen dat ze deze in een reguliere winkel verkopen. [quote:9cbd455739]
    Ik heb hem net gehaald en ga er zo mee aan de slag.[/quote:9cbd455739]Ok, we wachten je reactie af. [quote:9cbd455739]Dan ga ik ook gelijk ff de linkies bekijkeken en kijken of Q3 wil draaien. Waar heb jij je demo vandaan gevist? Ik heb hem namelijk gewoon van idsoftware en daar was dit de nieuwste versie. [/quote:9cbd455739]Rpmfind, maar dat had ik toch al gemeld in mijn post van Ma Jul 29, 2002 10:08 am. :D
  • Idd typo: http://www.penguinpower.nl/
    En er bestaat geen Linux versie hoor, je koopt gewoon de Windows versie en download de installer op Lokigames.
    Ik heb alleen de GOTY versie en de installer daarvan is BETA.
    Het installen was een eitje maar hij doet het niet :(
    [quote:5e7ef4d057]marcel@linux:~> ut
    Unreal engine initialized
    Bound to SDLDrv.so
    Joystick [0] : THRUSTMASTER FireStorm Dual Analog 2
    Joystick has 12 buttons
    Joystick has 10 axes
    SDLClient initialized.
    Bound to Render.so
    Lighting subsystem initialized
    Rendering initialized
    LoadMap: Entry
    Failed to load 'Entry': Can't find file 'Entry'
    Failed to load 'Level None.MyLevel': Can't find file 'Entry'
    appError called:
    Failed to enter Entry: Can't find file 'Entry'
    Executing UObject::StaticShutdownAfterError
    Executing USDLClient::ShutdownAfterError
    Signal: SIGIOT [iot trap]
    Aborting.
    Exiting.
    Name subsystem shut down
    marcel@linux:~>[/quote:5e7ef4d057]
    Ik heb al gekeken maar de file entry is er wel gewoon in de map Maps.
    In de readmy staat hier niets over bij most common problems.
    Ik ga ff jouw versie van Quake3 proberen en deze unistallen. Kijken of die het wel doet.
  • Q3 doet het bij jou niet omdat je een pointer versie hebt gedownload. Dat zijn alleen de binaries. Je moet ff de 1.16 versie downen van rpmfind.

    [edit]voor die file heb je de originele CD nodig het is dus geen demo :(
    Hoe deinstalleer je een rpm BTW?
  • [quote:bb0de3f1e4="Marcel de Reus"]Idd typo: http://www.penguinpower.nl/
    En er bestaat geen Linux versie hoor, je koopt gewoon de Windows versie en download de installer op Lokigames.
    Ik heb alleen de GOTY versie en de installer daarvan is BETA.
    Het installen was een eitje maar hij doet het niet :(
    Ik heb al gekeken maar de file entry is er wel gewoon in de map Maps.
    In de readmy staat hier niets over bij most common problems.
    [/quote:bb0de3f1e4]
    Dus deze Unreal Tournament draait onder Linux via Wine.
    Ik had deze Unreal Tournament ook wel wiilen proberen, maar het Computercollectief verkoopt deze niet. Ik heb je output geprint, wellicht nog niet goed geconfigureerd. :roll:
  • [quote:f68dc61b5e="Marcel de Reus"]Q3 doet het bij jou niet omdat je een pointer versie hebt gedownload. Dat zijn alleen de binaries. Je moet ff de 1.16 versie downen van rpmfind.[/quote:f68dc61b5e]
    Je bedoelt dus dat deze pointer versie pak0.pk3 van de Windows versie nodig heeft. [quote:f68dc61b5e][edit]voor die file heb je de originele CD nodig het is dus geen demo :([/quote:f68dc61b5e]Dat had ik inmiddels al begrepen
    [quote:f68dc61b5e] Hoe deïnstalleer je een rpm BTW? [/quote:f68dc61b5e] Een RPM deinstalleer je via SuSE KPackage. :wink:
  • SuSE Kpackage? Waar zit dat dan? Niet onder YAST/Software toch?
    Tenminste ik kan het niet vinden.

    Heb jij Q3 voor Windhoos dan?
    Unreal Tournament draait niet onder WineX hoor, maar Loki heeft daar een aparte installer voor gemaakt die bepaalde files omzet. Ze hebben er een OpenGL game van gemaakt.
    Hoe bedoel je nog niet goed geconfigureerd? Ik zie namelijk geen optie iets te configureren aangezien er niets draait. Ook in UT.ini kan ik niks vinden wat met Entry te maken heeft.
  • Kpackage heb ik al gevonden.
    Ik weet al waar de OpenGL foutmelding aan lag. Ik heb hem per ongeluk met mijn user geinstalleerd en dat werkt niet goed.
    Nu heb ik hem gereinstalled met de root en 10x raden wat ik krijg:
    [quote:9198c76d86]marcel@linux:~> q3demo
    Q3 1.11 linux-i386 Dec 4 1999
    —– FS_Startup —–
    Current search path:
    /home/marcel/.q3a/baseq3
    q3demo/baseq3

    ———————-

    Running in restricted demo mode.

    —– FS_Startup —–
    Current search path:
    /home/marcel/.q3a/demoq3
    q3demo/demoq3

    ———————-
    —– CL_Shutdown —–
    ———————–
    —– CL_Shutdown —–
    ———————–
    Error: Couldn't load default.cfg
    marcel@linux:~>
    [/quote:9198c76d86]

    Dus nu zitten we in hetzelfde schuitje.
  • [quote:4d2713d56c="Marcel de Reus"]Heb jij Q3 voor Windhoos dan?
    Unreal Tournament draait niet onder WineX hoor, maar Loki heeft daar een aparte installer voor gemaakt die bepaalde files omzet. Ze hebben er een OpenGL game van gemaakt.
    Hoe bedoel je nog niet goed geconfigureerd? Ik zie namelijk geen optie iets te configureren aangezien er niets draait. Ook in UT.ini kan ik niks vinden wat met Entry te maken heeft.[/quote:4d2713d56c]Op http://www.penguinpower.nl/pcontent/unreal.php staat: [quote:4d2713d56c] Unreal draait onder Linux via Wine. Via een script kun je Unreal levels ook native met de Unreal Tournament engine spelen. [/quote:4d2713d56c] En Wine behoort doorgaans te worden geconfigureerd, alhoewel dat bij SuSE dat voor een groot deel automatisch gaat. Dat begint al te lijken op een Windows 9x. wizard. :lol: Dat wil dus zeggen dat je de Wine configuratie toch nog behoort te controleren. :D [quote:4d2713d56c] Dus nu zitten we in hetzelfde schuitje.
    [/quote:4d2713d56c] Die foutmelding die jij heb lijkt wel op die van mij, alleen bij mij zijn er dan nog die pack1.pk3 t/m pack5.pk3
    Die Q3A demo 1.17 geeft de zelfde foutmelding als die 1.31 en heeft ook de orinele Q3A cd nodig waar ook een default.cfg opstaat. :wink:

    [update 20:58]
    Nee, ik heb Windows Quake nog niet, maar bij het Computercollectief verkopen ze twee versie. 1. Quake III Arena 26,75 euro’s (1999) 2. Ultlmate Quake 44,90 euro’s (2001)

    Nu ik op de website van Dynabyte kijk zie ik dat ze daar ook Quake3 verkopen: Arena en Gold en ook nog Unreal Tounament: G.O.T.Y en - 2003 (verwacht 27-09-2002)
  • Idd ik heb Unreal Tournament GOTY daar gehaal.
    Voor Quake 3 bestaat er overigens een speciale Linux versie dus dan kan je die beter nemen.
    Unreal werkt idd met Wine maar Unreal is een ander spel dan Unreal Tournament.
    Je moet de Quake demo gewoon ff van ftp.idsoftware.com vissen en dan testen.
    Hoe ik UT nu aan de praat moet krijgen? :(
    Ik ga zo ook maar es op NedLinux vragen, ik heb me net aangemeld daar en ik ga ook ff op het UT forum kijken.
  • Hier de thread van UT forums, maar hoe los je het nu op? :-?
    Mijn engels is niet zo best en ik weet dus nu nog niet hoe het op te lossen.
    jolo kan jij er iets uit opmaken?

    http://ina-community.com/forums/showthread.php?s=8d5cd2911a774ca9da9b91d856a657fe&threadid=95661&highlight=Linux+entry
  • [quote:bd827258a2="Marcel de Reus"]Hier de thread van UT forums, maar hoe los je het nu op? :-?
    Mijn engels is niet zo best en ik weet dus nu nog niet hoe het op te lossen.
    jolo kan jij er iets uit opmaken?

    http://ina-community.com/forums/showthread.php?s=8d5cd2911a774ca9da9b91d856a657fe&threadid=95661&highlight=Linux+entry[/quote:bd827258a2] Ik heb ’t even vluchtig doorgelezen. (morgen lees ik het nog wel over) Wat ik er vast uit kan halen dat de GOTY CD niet goed werkt met de Loki 436 installer. De mappen worden niet automatisch uitgepakt, kan wel handmatig. Of gekopieerd worden vanaf een Windows install. :roll:

  • Idd dat dacht ik dus ook.
    Ik heb hem nu onder Wonderdoos geinstalleerd en ga nu ff de mappen overzetten. Kijken of dat werkt.
    Anders ga ik denk ik maar een manuel instalation doen.
    Ik heb BTW een aparte GOTY installer die daar speciaal voor gemaakt is (vraagt ook om 2de CD ed) dus dat is het probleem niet.
    De mappen zijn idd nog compressed dus ik zal ook ff op de ucc link gaan speuren om uit te vogelen hoe dat werkt.
    Ik vertel je mijn bevindingen ;)
  • Ik heb de mappen door die van Windhoos vervangen en het draait als een tierelier :)
    Ik ga nu kijken of ik de mod Infiltration aan de praat krijg.
    Ik heb echter nog ff een vraagje: ondersteund Linux geen 32bits kleuren? Want ik kan zoowel in UT als in mijn desktop niet voor 32bit kiezen :(
  • Ja, de Linux Nvidia drivers ondersteunen 32 bits. Alleen wordt dit in sax2 24 Bit genoemd. De uitleg hier over staat in de Nvidia readme. :roll:

    Ik ben nog bij Dynabyte geweest voor die twee spellen. Ik kwam echter met lege handen weer naar buiten. Uitverkocht, verwacht… de gebruikelijke bla bla. :-?

    By Mycom heb ik 2 Audigy’s kunnen kopen. Retail (130 euro per stuk) maar dan in een zakje. Volgens de verkoper retail. Het modelnummer is SB0090. En is volgens deze website OEM http://www.shentech.com/creatsbsounb.html
    Marcel, is die Audigy OEM versie die jij gekocht ook modelnummer SB0090 ? :roll:
  • Ja volgens mij wel en hij zat ook in een zakje.
    Zijn de audio pluggies van goud? Dan is het retail ander OEM en ben je genaaid.
    Jammer dat ze waren uitverkocht want ik heb net UT gespeeld en het is erg tof. Moet je anders ff voor een bestelsite kijken waar ze het nog hebben.
    Nvidia readme had ik al gelezen en ik weet adt het 24bit heet, maar die keuze heb ik dus niet bij mijn desktop :(
    Jij wel?
  • Of de plugjes van goud zijn is moeilijk te zeggen. Het enigste wat ik van goud weet, dat het altijd een legering is. Maar ik zou het niet kunnen herkennen. De plugjes lijken koper kleurig. :oops:
    Ik heb nog wel de MyCom supportlijn gebeld, het modelnummer doorgegeven. Ze weten het daar ook niet. Zouden me nog terugbellen. :o Op Pricegrabber staan nog wel verschillede Audigy’s http://www.pricegrabber.com/search_attrib.php/page_id=59/ut=1884048e871cdc94

    Ik ben nog wel bij het Computercollectief geweest. Ik heb nu Quake 1 t/m 3 – RollerCoaster Tycoon en Spiderman. Tja, ik ben een Spiderman fan. :D


    Ik heb die bestanden vanaf de Quake 3 cd-rom al naar de ./baseq3 map gekopieerd.
    De foutmelding die dat oplevert lijkt enigszins op die jij postte op Ma Jul 29, 2002 11:09 am :o
    [code:1:f26cfce4ff]
    jolo@linux:~> cd /usr
    jolo@linux:/usr> cd bin
    jolo@linux:/usr/bin> quake3
    Q3 1.17 linux-i386 Apr 28 2000
    —– FS_Startup —–
    Current search path:
    /home/jolo/.q3a/baseq3
    ./baseq3/pak6.pk3 (64 files)
    ./baseq3/pak5.pk3 (7 files)
    ./baseq3/pak4.pk3 (272 files)
    ./baseq3/pak3.pk3 (4 files)
    ./baseq3/pak2.pk3 (148 files)
    ./baseq3/pak1.pk3 (26 files)
    ./baseq3/pak0.pk3 (3539 files)
    ./baseq3

    ———————-
    execing default.cfg
    execing q3config.cfg
    couldn't exec autoexec.cfg
    —– Client Initialization —–
    —– Initializing Renderer —-
    ——————————-
    —– Client Initialization Complete —–
    — Common Initialization Complete —
    Opening IP socket: localhost:27960
    Hostname: linux.local
    Alias: linux
    IP: 127.0.0.2
    —– R_Init —–
    …loading libGL.so: Initializing OpenGL display
    …setting mode 3: 640 480
    Using XFree86-VidModeExtension Version 2.1
    XF86DGA Mouse (Version 2.0) initialized
    XFree86-VidModeExtension Activated at 800x600
    Using 8/8/8 Color bits, 24 depth, 0 stencil display.
    GL_RENDERER: Mesa X11
    ****************************************
    …no hardware acceleration found…
    If this is in error, add
    "+set r_allowSoftwareGL 1"
    to the command line.
    ****************************************
    …WARNING: could not set the given mode (3)
    …loading libMesaVoodooGL.so: QGL_Init: Can't load libMesaVoodooGL.so from /etc/ld.so.conf or current dir: /usr/games/quake3/libMesaVoodooGL.so: cannot open shared object file: No such file or directory
    failed
    —– CL_Shutdown —–
    RE_Shutdown( 1 )
    ———————–
    —– CL_Shutdown —–
    ———————–
    Error: GLimp_Init() - could not load OpenGL subsystem

    jolo@linux:/usr/bin> [/code:1:f26cfce4ff] Nee, de kleuren diepte instellen kan niet bij mijn desktop, maar alleen via sax2
    In bovenstaande foutmelding wordt de kleuren diepte weergegeven.

    [code:1:f26cfce4ff]Using 8/8/8 Color bits, 24 depth, 0 stencil display.

    [/code:1:f26cfce4ff]
  • Ik heb nu Quake3 1.31geïnstalleerd onder Redhat 7.3 en de pak*.pak3 + de default.cfg q3config.cfg naar de ./baseq3 map gekopieerd.
    Bij de eerste start werd het beeld op de monitor en mijn TV zwart, zodat ik op de resetknop moest drukken. Toen ik Quake3 voor de tweede keer startte werd om de cd-key gevraagd. Deze heb ik ingevuld en inderdaad het spel werkt. :wink:
  • En onder SuSE deed je hetzelfde en het werkte niet?
    Ik weet BTW wel hoe het komt, lees de error maar es goed ;)
    Hij load het MESA bestand en die moet je dus niet hebben. Kun je waarschijnlijk in de .ini file aanpassen.
  • [quote:f51405edf6="Marcel de Reus"]En onder SuSE deed je hetzelfde en het werkte niet?
    Ik weet BTW wel hoe het komt, lees de error maar es goed ;)
    Hij load het MESA bestand en die moet je dus niet hebben. Kun je waarschijnlijk in de .ini file aanpassen.[/quote:f51405edf6] Bedoel je /etc/ld.so.conf :roll:
    Deze file lijkt me ok.
    Maar de file /usr/games/quake3/libMesaVoodooGL.so bestaat inderdaad niet. Ik zal er morgen weer verder naar kijken. Werkt Quake 3 bij jouw nu dan wel onder SuSE 8.0?

    Overigens die demo van Quake die het systeem benched met ~
    timedemo 1
    demo demo001
    werkt bij mij alleen onder Windows: 153,4 fps
    Onder Redhat zijn er geen demos beschikbaar. :o

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.