Vraag & Antwoord

OS Linux

Suse 8.0 Burning issues

46 antwoorden
  • Wanneer /dev/hdc je brander is dan moet je in /etc/lilo.conf de volgende regel toevoegen: [code:1:e814d7e70d] append="hdc=ide-scsi" [/code:1:e814d7e70d] daarna /bin/lilo intypen en rebooten. hierna moet je als het goed is een /dev/hdd (je gewone cdrom) en een /dev/sr0 hebben. in /etc/fstab nog even een regel maken voor je brander en je bent klaar om te branden :D
  • [quote:de49adde38="wstolk"]in /etc/fstab nog even een regel maken voor je brander en je bent klaar om te branden :D[/quote:de49adde38]Hm, je bedoelt zeker deze regel:[quote:de49adde38]/dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0 [/quote:de49adde38]Als SuSE 8.0 wordt geïnstalleerd op een PC waar de cd-rom en cd-rewriter al zijn ingebouwd, worden de wijzigingen in /etc/lilo.conf en /etc/fstab door het installatie programma Yast2 al uit gevoerd. Dit kan worden gecontroleerd met cdrecord -scanbus[quote:de49adde38]jolo@linux:~> cdrecord -scanbus Cdrecord 1.11a19 (i686-suse-linux) Copyright (C) 1995-2002 Jörg Schilling Linux sg driver version: 3.1.22 Using libscg version 'schily-0.6' scsibus0: 0,0,0 0) 'PHILIPS ' 'CDRW2412A ' 'P1.5' Removable CD-ROM 0,1,0 1) * 0,2,0 2) * 0,3,0 3) * 0,4,0 4) * 0,5,0 5) * 0,6,0 6) * 0,7,0 7) * jolo@linux:~>[/quote:de49adde38]Bij mij crashed KonCD ook, maar dan pas als ik op Start klik. (Bij het uitvoeren van de Setup van KonCD waren geen problemen. :wink:)
  • Je cd-brander op read-only???????? Dat lijkt me idd niet goed gaan, of ik snap het even niet :-? .
  • Ja, heb ik allemaal gedaan (misschien wel voor niks want zoals Jolo al opmerkt schijnt Yast2 dit allemaal automatisch te doen), maar zonder enig effekt. Ik heb de cdrecord -scanbus gedaan en krijg dan een keurig verhaal als bij Jolo. In Yast2 wordt het spul herkend als een scsi device (brander) op sr0 en een ide device (cd-rom) op hdd. Ik heb inmiddels de cd's gekocht met manual, leek me wel handig, maar als ik dan even opsla hoe dat zit met cd's spelen staat er doodleuk cd'tje erin leggen en spelen. ERG behulpzaam! Ik kan er een cd'tje inleggen (thank God for small favours), maar spelen ho maar!. Toen ik het spul de eerste keer installeerde en ik rechtsklikte op de cd-r en cd-rom en daarna aangaf dev/cdrom en dev cdrecord, kreeg ik daarna een groen pijltje bij de ikoon. Leek me een goed teken. Ik kon toen ook inderdaad schijven "zien" als ik erop klikte. Maar na het rebooten waren de pijltjes weg en wat ik ook deed, ze bleven weg. Ik heb inmiddels "writeprotect" weggevinkt. Allemaal bedankt voor de reakties. Verder advies van harte welkom!
  • Wellicht kun je het met X CD-Roast proberen. Dit CD brand programma is minder gebruikersvriendelijk dan KonCD, maar een CD branden op 24 speed is me hiermee gelukt. Op deze website staat nog wat nuttige info: http://seismo.ethz.ch/linux/xcdroast.html :wink:
  • Jolo, ook dat heb ik geprobeerd, instrukties uitgevoerd zoals beschreven, geen resultaat. cd-roast neergeladen, herkent alleen de brander en verder helemaal niks.
  • [quote:d211c18fd2="LennartII"]Jolo, ook dat heb ik geprobeerd, instrukties uitgevoerd zoals beschreven, geen resultaat. cd-roast neergeladen, herkent alleen de brander en verder helemaal niks.[/quote:d211c18fd2] Waar ging het dan mis met X CD-Roast en welke foutmeldingen? Zou je eventueel stap voor stap kunnen beschrijven wat je gedaan hebt om X CD-Roast te configureren en van het CD brand proces zelf. Bij de Configuratie is vooral Harddisk instellingen belangrijk. (voor tijdelijke opslag images) Voor het maken van een back-up met X CD-Roast: Dan wordt er met: CD maken > Master Tracks een image gemaakt, die dan met write tracks naar de CD wordt geschreven. Daar zijn heel wat muis klikken voor nodig. :roll:
  • Jolo, dit is wat ik gedaan heb (instrukties volgens suse knowledge base en cd-roast: Situation You want to use your IDE CD writer with SuSE Linux. Procedure Disable the IDE support for the CD writer First, disable the IDE support for the corresponding drive. The following section applies to SuSE Linux 8.0 (YaST2): Log in as root and start the YaST2 Control Center. First select "System", then "Boot loader configuration". Click the item "Modify current configuration" then "Next". Do not change the preset values in the next mask "Where should the boot loader be installed?". On the following mask, click "Expert settings" then "Add options". A new window opens: "Implement new option". The option name is already predetermined with "Append". Click the "Option value" field and insert the following. The remaining procedure is identical for all versions: Insert the following: hdX=ide-scsi into the "Appendline", replacing X with the device label of your CD drive. hda = primary master (usually the hard disk) hdb = primary slave hdc = secondary master (usually the CD drive) hdd = secondary slave Search for ide in the file /var/log/boot.msg to find out to what controller your drive is attached. If there are already some entries in the append line, add hdX=ide-scsi to them separated with a blank. If you still have one or more additional IDE CD drives (not necessarily CD writers), you will have to make entries for each of them (separated with blanks). Na dit gedaan te hebben is er niets veranderd: cd-roast vindt nog steeds mijn cd-rom niet. en hwinfo -scancdrom levert hetzelfde lijstje op zonder veranderingen; één scsi en één ide eenheid dus. Als ik op de cd-r klik krijg ik: Couldn't mount unit; Error reported was:r: /dev/cdrecorder: Input/output error mount: you must specify the filesystem type en hetzelfde ook voor de cd-rom.
  • [quote:1b67051eb1="LennartII"]Na dit gedaan te hebben is er niets veranderd: cd-roast vindt nog steeds mijn cd-rom niet. en hwinfo -scancdrom levert hetzelfde lijstje op zonder veranderingen; één scsi en één ide eenheid dus. Als ik op de cd-r klik krijg ik: Couldn't mount unit; Error reported was:r: /dev/cdrecorder: Input/output error mount: you must specify the filesystem type en hetzelfde ook voor de cd-rom.[/quote:1b67051eb1] Werken je cd-rom en cd-writer overigens wel onder een ander besturingsysteem? Dos of Windows 9x/Me? :roll: Zou je /etc/fstab hier kunnen posten? Want als ik goed begrijp kun je dus je cd-rom en cd-writer helemaal niet benaderen. En type in een console: [color=blue:1b67051eb1]dmesg | grep sr0[/color:1b67051eb1] [code:1:1b67051eb1] linux:~ # dmesg | grep sr0 Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0 sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray [/code:1:1b67051eb1] En ook: [color=blue:1b67051eb1]dmesg | grep hdd[/color:1b67051eb1] [code:1:1b67051eb1] linux:~ # dmesg | grep hdb ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:DMA hdb: AOPEN 16XDVD-ROM/AMH 20011108, ATAPI CD/DVD-ROM drive hdb: no flushcache support hdb: ATAPI 48X DVD-ROM drive, 512kB Cachelllinux:~ # [/code:1:1b67051eb1] Tja, bij mij is de cd-rom primair slave. En de rest van dit probleem is dus voor morgen. :wink:
  • Jolo, bedankt voor je hulp. Dit is mijn fstab: /dev/hda8 / reiserfs defaults 1 2 /dev/hda6 /boot ext2 defaults 1 2 /dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0 /dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0 devpts /dev/pts devpts defaults 0 0 /dev/fd0 /media/floppy auto noauto,user,sync 0 0 proc /proc proc defaults 0 0 usbdevfs /proc/bus/usb usbdevfs noauto 0 0 /dev/hda1 /windows/C vfat noauto,user 0 0 /dev/hda5 /windows/D vfat noauto,user 0 0 /dev/hda7 swap swap pri=42 0 0 In windows (xp) werkt alles goed. dmesg | grep sr0: Attached scsi cd-rom sr0 at scsi0, channel 0, id 0, lun 0, sr 0: scsi 3 mmc drive: 32x32 writer cd/rw xa/form2 cdda tray dmesg | grep hdd: ide1 BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:DMA, hdd:DMA hdd: CRD 8322b, ATAPI CD/DV-ROM drive hdd: ATAPI 32x cdrom drive, 128kb cache, dma Primaire slave vind ik ook prima, maar lost dat iets op?
  • Je [color=blue:f6ca7f156e] /etc/fstab [/color:f6ca7f156e] en de output van [color=blue:f6ca7f156e] dmesg | grep sr0 [/color:f6ca7f156e] en [color=blue:f6ca7f156e] dmesg | grep hdd [/color:f6ca7f156e] zijn in orde. :) Cd-rom op primair slave is alleen nodig als je burn on the fly wilt doen. Met op cd-r en cd-rom klikken neem ik aan dat je bedoelt die op je Desktop staan. De Toegangs rechten van de cd-r staan standaard op: Gebruiker: Lezen en Schrijven. Groep en Overige op Lezen. En Station op: /dev/cdrecorder (waarbij Alleen lezen is gevinkt) De Toegangs rechten van de cd-rom zijn het zelfde als cd-r. En bij station /dev/cdrom Het vinkje van de writeprotect ofwel alleen lezen van de cd-rom en cd-r kun je beter laten staan. Als dat klopt dan zou een klik op cd-r of cd-rom voldoende moeten zijn om een data cd of cd-r te kunnen lezen. (geen muziek cd uiteraard) Overigens dat dat groene pijltje bij cd-rom of cd-r na de reboot verdwijnt is in orde. Ook zou je /etc/mtab kunnen controleren met: [color=blue:f6ca7f156e] cat /etc/mtab [/color:f6ca7f156e] [code:1:f6ca7f156e] jolo@linux:~> cat /etc/mtab /dev/hda14 / ext2 rw 0 0 proc /proc proc rw 0 0 devpts /dev/pts devpts rw 0 0 /dev/hda13 /boot ext2 rw 0 0 shmfs /dev/shm shm rw 0 0 usbdevfs /proc/bus/usb usbdevfs rw 0 0 /dev/hdb /media/dvd iso9660 ro,nosuid,nodev,user=jolo 0 0 jolo@linux:~> [/code:1:f6ca7f156e]
  • Jolo, als ik het zo bekijk is dus alles goed ; het probleem is echter dat het niet werkt. Ik las iets over mounten en filetype -plaats definiëren. Moet ik dat nog doen of is dat al automatisch gebeurd? Ik kan nu inderdaad een data-cd zien op mij cd-r maar nog steeds niet op mijn cd-rom. Daar krijg ik nog dezelfde foutmelding. Hoe speel ik een audio cd? Xmms geeft helemaal geen sjoege wat ik ook in de cd-r leg; het enige wat toto nu toe gelukt is is konqueror openen, /audiocd schrijven en dan begint ie te kopieren en kan ik na een slordig kwartiertje luisteren. Is er een betere manier? Deze beide manieren worden tussen haakjes voorgesteld in de "basics" handleiding, en verder niks. Ik moet misschien overstappen naar "gevorderden" :lol:
  • [quote:39d083a299="LennartII"]Jolo, als ik het zo bekijk is dus alles goed ; het probleem is echter dat het niet werkt. Ik las iets over mounten en filetype -plaats definiëren. Moet ik dat nog doen of is dat al automatisch gebeurd? [/quote:39d083a299] File type definiëren is bij SuSE niet nodig. (filetype staat al in /etc/mtab) Automatisch mounten dat doet Supermount van Mandrake. In het KDE menu is bijvoorbeeld > CD > CD-Player. Het is een Gnome CD speler, dus als je Gnome hebt geïnstalleerd dan moet die CD speler erbij zijn. Gevorderd? Als je dat wilt kun je het beste SuSE 8.0 instellen dat deze opstart in init 3. Yast2 > Systeem > Runlevel Editor > 3 Full multiuser met Netwerk. . Al die grafische cd write programma's maken gebruik van cdrecord en mkisofs Probeer eerst vanuit init 3 je cd-rom te mounten: mount /media/cdrom Voor het branden van CD's met mkisofs en cdrecord is info op: http://nl.linux.org/doc/HOWTO/CD-Writing-HOWTO-NL-3.html Succes :)
  • Jolo, bedankt voor je hulp. "Overstappen naar gevorderden" was een grapje. Ik denk dat ik daarmee wacht tot ik 1) mijn spullen "aan de praat" heb gekregen en 2) weet hoe ik ermee om moet springen. Ik denk derhalve ook dat ik mij voorlopig beperk tot KonCD en CdRoast. De link zal ik aandachtig lezen. Ik kom er allicht weer iets verder mee.
  • [quote:e65acca98a="LennartII"]Jolo, bedankt voor je hulp. "Overstappen naar gevorderden" was een grapje. Ik denk dat ik daarmee wacht tot ik 1) mijn spullen "aan de praat" heb gekregen en 2) weet hoe ik ermee om moet springen. Ik denk derhalve ook dat ik mij voorlopig beperk tot KonCD en CdRoast. De link zal ik aandachtig lezen. Ik kom er allicht weer iets verder mee.[/quote:e65acca98a] Daarom heb er ook een gebruiksaanwijzing aan toe gevoegd. :wink: Eventueel kun het ook nog met Gnome Toaster Proberen. http://members.home.nl/rl.koelewijn/linux/ide-scsi.html :D
  • Jolo, ja hoor, bedankt, weer een stapje verder. In level 3 de cd gemount en jawel! het groene pijlteje is weer terug en als ik op de cdrom (op mijn Desktop wel te verstaan) klik dan krijg ik zowaar de inhoud van mijn cd te zien. Ook Koncd doet een stuk minder vervelend, ziet nu zonder enig aansporen mijn cdrom in "setup", maar als ik nu bijv. wil kopiëren dan brult ie: "couldn't start readcd! Weet je daar nog iets op?
  • Vervolg, er schijnt iets niet helemaal goed te zitten. Als ik op de cdrom klik, krijg ik de inhoud te zien van de schijf die in mijn cd-r ligt. Rechtsklikken op zowel cd-r als cd-rom levert wel de goed info op; cd-r verwijst naar dev/cd-record en cdrom verwijst naar dev/cdrom.
  • Jolo, of wie dan ook; ik zou verdere hulp bijzonder op prijs stellen. Ik ben hier nu een hele dag mee bezig en kom er niet uit. Nadere omschrijving van het probleem: ik heb nu toegang tot zowel cd-r als cd-rom maar de brandprogramma's zien alleen maar mijn cd-r en niet mijn cd-rom. Ik vermoed dat die cd-rom nog steeds als een ide eenheid gezien wordt en niet als een scsi (maar ik kan het mis hebben). Alle ideeën, tips, hinten eetc van harte welkom.
  • Ik ben er ook uren mee bezig geweest, maar KonCD werkt alleen als je ingelogd bent als root [color=red:efbc1ebe92] (KDE desktop rood) [/color:efbc1ebe92] Couldn't start readcd kan worden weergegeven als in setup bij paths niets is in gevuld. Bij Setup klik op Paths en op Defaults. Nu zijn de paths ingevuld. Als ik voor Reader de CD-Rom kies. Error No such device or derectory: Path /dev/scdk Voor dit probleem heb ik nog geen oplossing. :-? Maar als ik voor Reader de CD-Writer kies dan werkt het wel. Getest Disk Copy (gevinkt Disk at ones, Dummy mode, No fixiating en Eject CD after write.) Test OK. :)
  • De brander wordt door KonCD gevonden, maar als ik de cd-rom aangeef crashed de boel (KonCD). Beiden worden gevonden in Yast2; de brander als een scsi en de cd-rom als een ide. Ik heb het volgende geprobeerd: ------- dd if=/dev/hdc of=/dev/null dd. reading '/dev/hdc': Input/output error 0+0 records in 0+0 records out dd if=/dev/hdd of=/dev/null dd: opening '/dev/hdd': No medium found ------ Hdc=brander hdd=cd-rom Ik las een verhaal op de Suse Kb dat ide herkend moet worden als scsi en dat daartoe (o.a.) één en ander in het mbr veranderd moet worden. Dat deed ik gisteren zonder enig effekt. Ik heb het toen voor zowel brander als cd-rom gedaan en ook alleen voor de cd-rom. Zonder effekt. Ik heb nu de zaak opnieuw geïnstalleerd en dacht eerst maar eens advies te vragen. Alle tips/advies van harte welkom. Ook; bij het starten krijg ik de volgende foutmelding in de console: linux modprobe: modprobe: Can't locate module sound-slot-1 linux modprobe: modprobe: Can't locate module sound-service-1-0 linux modprobe: modprobe: Can't locate module sound-slot-1 linux modprobe: modprobe: Can't locate module sound-service-1-0 Geluid werkt (AC97).

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.