Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

hoe installeer ik pangoft2?

wbsoft
14 antwoorden
  • Eindelijk is het gelukt om pango te installeren, hiervoor heb ik freetype2 niet in de defautl dir geinstalleerd ( /usr/local/ ) maar in /usr/X11R6/ .

    Werkt verder ook prima, het compilen van de meeste gnome2 sources gaat nu lekker. Totdat ik bij libgnomecanvas ineens de error krijg : pangoft2.pc niet gevonden ( of iets dergelijk, als iemand de exacte error wil weten geeft ie maar een gil ). Dat bestandje bevond zich nog in de sourcedir van pango en heb ik vervolgens gekopieerd naar de /opt/gnome/lib/pkgconfig/ dir. Ging allemaal goed, geen geklaag meer over missende bestandjes. Tot ik een eindje verderop weer een melding kreeg dat lpangoft2-1.0 niet gelinkt kon worden.

    Naderhand ben ik eens naar de configure output gaan kijken en daar stond idd dat ie de package pangoft2 niet kan vinden.

    Helaas kan ik pangoft2 ook niet vinden en kom er verder mbv google ook niet echt uit. Iemand een idee?
  • www.rpmfind.net kent pangoft2 ook niet. Als je bij Google kijkt (toch!) zie je dat je niet de enige bent :wink:

    http://www.google.com/linux?q=pangoft2&hl=nl&lr=&ie=UTF-8&start=0&sa=N

    Greetz, dJezzer 8)
  • pangoft2 is de Freetype2 module voor Pango. Waarschijnlijk is die niet gecompileerd bij het compileren van pango. Je moet echt opletten bij configure van pango of hij de Ft2 module ook maakt. Bij mij kostte het wat moeite om het aan de praat te krijgen. Ook moet je de allernieuwste freetype2 hebben. (Ik heb freetype 2 geïnstalleerd, gewoon in /usr, ook al komt XFree 4.x ook met deze library.)

    succes,
  • ik heb natuurlijk al op de zoekterm pangoft2 gezocht :D
    Wat ik probeerde te zeggen is dat ik er niet veel wijzer van ben geworden. Ik ben idd niet de enige, maar ik zou graag een oplossing vinden :wink:

    Ik heb idd freetype 2.1.2 geinstalleerd in /usr/ en ook al een keer in /usr/X11R6 en zelfs al in allebei.
    Ook heb ik een keer freetype2.0.9 geinstalleerd, omdat ik ergens las dat vanaf toen er een verandering in sommige naamgevingen was gekomen. Maar ook dit heeft niet geholpen.

    Moet ik misschien tijdens de configure van pango deze module "enablen"?
    iets als –enable-FT2 ? Dit heb ik namelijk nnoit gedaan.
  • WBsoft, hoe heb jij pango dan gecompiled? met welkr opties bedoel ik. Ik zit nu al een hele tijd bezig, maar het lukt niet om een module pangoft2 te krijgen. :-?
  • bij pango heb ik gewoon ./configure –prefix=/usr gedaan. Hij vind zelf de freetype-config als freetype2 correct geinstalleerd is.

    Let goed op de output van de ./configure opdracht. Hij zegt of bij de ft2 module wel of niet bouwt.

    Ik zou freetype2 gewoon in /usr installeren. Lees de README van freetype2 over info hoe de gepatenteerde hinter in te schakelen, dan heb je bij sommige truetype fonts mooiere kleine fonts.

    succes.
  • Even een vraag van een noob: wat is Pango? Het zit blijkbaar op mijn gentoo-bak, maar hoe of wat?
  • Pango is een framework voor layout en rendering van internationale tekst (dus ook aziatisch, rechts naar links etc.) zie voor info www.pango.org. Cool stuff!
  • GELUKT!!! :D

    Wel niet helemaal op de "officiele" manier, maar toch…

    kheb nu eerst xfree864.0.2 en xf86prog 4.0.2 geinstalleerd (eerst had ik 4.0.1 van beide ). Freetype2 blijkt dus ook in deze packages te zitten. Hierna wilde pangoft2 wel en daarmee eindelijk de rest van mijn gnome2 installatie!

    Ik ben echt blij, ik begon er al half en half over te denken om maar weer terug naar 1.4 te gaan.

    Nu moet ik nog al mijn oude vertrouwde apps aan het draaien zien te krijgen. Ik geloof dat ze nogal wat problemen hebben met de versies 2 van gtk en glib. Maar we zien wel…

    Nautilus 2 is bij mij iig een enorme verbetering wat snelheid betreft! :D
    Wel jammer dat drag&drop in listview niet ondersteunt wordt, maar dat komt ongetwijfeld nog wel.
  • Gefeliciteerd!!

    Maar is het niet beter om gelijk de nieuwste X maar te nemen? 4.2.0 i.p.v. 4.0.2?

    Succes!
  • 4.0.2 moet 4.2.0 zijn, heb steeds de 0 en het andere cijfer omgedraaid, zal door de opwinding veroorzaakt zijn :P
  • [quote:4f23490240="plors"]Ik geloof dat ze nogal wat problemen hebben met de versies 2 van gtk en glib. Maar we zien wel…[/quote:4f23490240]
    Je kan (en moet denk ik) gtk1 en gtk2 voorlopig allebei installeren. Ze zitten elkaar niet in de weg en er zijn nog heel wat apps die niet naar GTK2 omgezet zijn.
  • klopt, ik heb ze nu beide, netjes gescheiden in een /opt/gnome2 en een /opt/gnome-old en het werkt perfect.

    Uiteindelijk zal alles wel met versies 2 gaan werken, maar dat duurt nog wel ff lijkt me.
  • Nog maar een vraag: hoe kan ik er iets mee? Ik vermoedt dat het als depencie van Xfree of Mozilla is geinstalleerd, Gnome heb ik niet. Kan dit?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.