Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Squid blijft niet draaien

Anoniem
Gerbrand
10 antwoorden
  • Hoi,

    Nu ik weer terug ben van vakantie kan ik eindelijk het probleem aanpakken waar ik drie weken geleden al tegenaan liep… :)

    Ik heb squid geinstalleerd om mijn isdn aansluiting te delen. Als ik deze opstart, dan runt 'ie voor zo'n 15 a 20 seconden, waarna het proces verdwijnt.

    Heeft iemand een idee waar dit aan ligt? Hij draait onder nobody, en er komt geen enkele melding in de log te staan, deze blijft volledig leeg.
    Kan het te maken hebben met het authorisatie gedeelte dat niet goed staat? Ik ben daar namelijk nog wel mee aan het klooien, omdat me dat nog niet helemaal duidelijk is.

    TIA,
    Rutger
  • Heeft squid misschien nog een of andere dependency met BIND, of is het niet noodzakelijk dat deze ook geinstalleerd is? (Heb hem namelijk niet draaien)
  • Het is volgens mij zo dat Squid om een bepaalde tijd checkt of ie nog een verbinding kan maken d.m.v. contact te maken met wat sites (die je overigens zelf op kunt geven), als het contact maken mislukt dan sterft Squid af (ja, echt waar :D)

    Aangezien jij een ISDN verbinding hebt en die niet de hele tijd open hebt staan, neem ik aan, zou dit wel eens het probleem kunnen zijn.

    Je hebt dan een zogenaamde off-line proxy nodig.
  • Ooh… dan moeten we maar wat anders op gaan zoeken. Weet je nog goeie offline proxy's?

    De enige proxy waar ik namelijk altijd wat over hoor is squid, en als die afvalt… tja.

    Bedankt in elk geval voor je reactie
  • kijk hier eens:

    http://www.linux-nl.cx/html/wwofl.html
  • Ik heb squid wel draaien deze blijft ook draaien.
    Bij mij draait hij onder gebruiker squid.
    Ik heb hem geinstalleerd mbv WEBMIN dit is een een system administrator die onder http draait.
    Het is mij hier opgevallen dat de cache geinitialiseerd moet worden. Ik weet nog niet hoe ik dat definitief voor elkaar moet krijgen, want na elke reboot is dit bij mij nog nodig.

    suc6
    Gerbrand.
  • [quote:c43b2b952f="Gerbrand"]Ik heb squid wel draaien deze blijft ook draaien.
    Bij mij draait hij onder gebruiker squid.
    Ik heb hem geinstalleerd mbv WEBMIN dit is een een system administrator die onder http draait.
    Het is mij hier opgevallen dat de cache geinitialiseerd moet worden. Ik weet nog niet hoe ik dat definitief voor elkaar moet krijgen, want na elke reboot is dit bij mij nog nodig.

    suc6
    Gerbrand.[/quote:c43b2b952f]

    Dit hoor je volgens mij te doen door eenmalig de optie "-z" mee te geven:

    [code:1:c43b2b952f]
    squid -z
    [/code:1:c43b2b952f]

    Probeer het eens uit, als je dat nog niet reeds gedaan hebt.

    Succes!
  • [quote:901fc0cd89="Gerbrand"]Ik heb squid wel draaien deze blijft ook draaien.
    [/quote:901fc0cd89]
    En jij gebruikt hem ook onder een inbelverbinding, ISDN of Analoog?
  • Gezien deze site heb je een vaste verbinding nodig.
  • [quote:8da6b6b3ea="rkars"]
    En jij gebruikt hem ook onder een inbelverbinding, ISDN of Analoog?[/quote:8da6b6b3ea]

    IK gebruik een ISDN verbinding mbv. een extern ISDN modem te weten een KPN Smartvox.

    zie ook mijn posting over Kinternet smppd wvdial

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.