Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

AntiVir Milter

MVE
18 antwoorden
  • Wie heeft AntiVir Milter al geprobeerd?
    Het staat op:
    http://www.antivir.de/download/download.htm#AntiVir%20Milter
    Als er iemand is reageer dan even, ik heb nogal wat vragen hierover.
    Groetjes Herbert
  • Ik gebruik antivir mailgate…. is denk ik net wat anders
    ik ben er blij mee, hij werkt erg goed

    de mail wordt opgehaald door mailgated, en plaatst het in een temp directory ergens in var/nogwat/ dan wordt het gescanned en doorgestuurd naar de mailserver dmv avmailforward of zoiets
    mail met viri wordt onderschept en niet doorgestuurd naar de recipient. Sender en geadresseerde krijgen een bericht wanneer er een viri is gevonden in de mail.alsmede de administrator….
  • Hoi Kay Jay,
    Ik had ook antivir mailgate geinstaleerd (helemaal volgens de doc's)
    Nu het volgende:
    De berichten blijven staan in /var/spool/avmailgate en worden niet geforward.
    Ik ben echt al 2 dagen aan het zoeken waar de fout nu ligt?
    Kun jij me de config files sturen van avmailgate ?
    Ze staan in /etc/avmailgate.conf + /etc/avmailgate.acl

    Groetjes Herbert
    P/s hieronder mijn config


    #######################################################################
    ## avmailgate.conf ##
    #######################################################################
    User uucp
    Group uucp
    Postmaster herbert@xxxxxx.myservers.org
    MyHostName xxxxxx.myservers.org
    SpoolDir /var/spool/avmailgate
    AntiVirDir /usr/lib/AntiVir
    TemporaryDir /var/tmp
    MatchMailAddressForLocal RECIPIENT
    SMTPBanner "AntiVir MailGate"
    PidFile_avgated /var
    un/avmailgate_d.pid
    # ListenAddress 0.0.0.0 port 25
    # MaxIncomingConnections 0
    SmtpTimeout 300
    # MaxMessageSize 0
    # MinFreeBlocks 100
    MaxRecipientsPerMessage 100
    # RefuseEmptyMailFrom NO
    # AllowSourceRouting NO
    # hostA!hostB!hostC!user
    #stA,@hostB:user@hostC
    # InEnvelopAddressesBangIs REFUSED
    # user%hostC%hostB@hostA
    # @hostA,@hostB:user@hostC
    # InEnvelopAddressesPercentIs REFUSED
    # AcceptLooseDomainName NO
    PidFile_avgatefwd /var
    un/avmailgate_fwd.pid
    # MaxForwarders 10
    ForwardTo /usr/lib/sendmail -oem -oi
    # ForwardTo SMTP: localhost port 825
    # BlockSuspiciousMime NO
    # ExposeRecipientAlerts LOCAL
    # ExposeSenderAlerts LOCAL
    ExposePostmasterAlerts YES
    VirusAlertsUser herbert
    AddStatusInBody YES
    # ForwardAllEmailAsMIME NO
    ScanInArchive YES
    # MaxFilesizeInArchive 0
    # MaxRecursionDepthInArchive 5
    # BlockSuspiciousArchive NO
    # BlockEncryptedArchive NO
    PollPeriod 60
    BounceMessageUser MAILER-DAEMON
    AddXHeader YES
    AddReceivedByHeader YES
    ScanTimeout 3600
    ExternalProgram /etc/virus
  • ik zal ff kijken…
    ik heb je config niet gelezen (ben lui) maar heb je je mailserver naar een andere poort verplaatst en de forwarder geconfigureerd?
    daar ligt het euvel.. hij scant dus wel neem ik aan , maar hij forward niet..
    klinkt me bekend. dat probleem had ik ook, dan wil de forwarder domweg niet opstarten..

    ik zal ff kijken of ik hem hier kan posten..
  • hier izi dan:
    [quote:e4ba861dba]
    User uucp
    Group uucp

    Postmaster nobody
    MyHostName kayjay.d2g.com

    SpoolDir /var/spool/avmailgate
    AntiVirDir /usr/lib/AntiVir
    TemporaryDir /var/tmp

    MatchMailAddressForLocal RECIPIENT
    SMTPBanner "KayJay.d2g.com MailGate"

    ListenAddress 0.0.0.0 port 25
    SmtpTimeout 300
    MaxMessageSize 0 #geen limiet dus)

    MaxRecipientsPerMessage 10 #zal toch nooit gebeuren

    PidFile_avgatefwd /var
    un/avmailgate_fwd.pid #deze is belangrijk, check dit

    ForwardTo /usr/lib/sendmail -oem -oi #sendmail handelt het verder af
    ForwardTo SMTP: localhost port 825 #hier draait de mailserver nu op ipv 25

    ExposeAlerts YES #willen we wel weten jah.


    ExposeSenderAlerts YES #ook de verstuurder moet het weten als hij geinfecteerd is
    VirusAlertsUser AvMailGate
    AddStatusInBody YES
    ScanInArchive YES
    MaxFilesizeInArchive 0 #alle bestanden doen
    MaxRecursionDepthInArchive 5
    BlockSuspiciousArchive NO #doen we niet zo moeilijk over
    BlockEncryptedArchive NO #idem
    PollPeriod 60
    BounceMessageUser MAILER-DAEMON #ja daar izi weer!
    AddXHeader YES
    AddReceivedByHeader YES
    [/quote:e4ba861dba]

    kijk goed in je logfiles wat de forwarder precies doet.. daar zit het hem in namelijk.
  • [quote:69b9f825ae]PidFile_avgatefwd /var
    un/avmailgate_fwd.pid #deze is belangrijk, check dit
    [/quote:69b9f825ae]
    Hoi van Herbert,
    de mail forward nu wel maar de PidFile staat er niet.
    Ik denk dat daar nu nog de fout zit?
    Vreemd.. waarom forward die wel zonder dat de PidFile aanwezig is.
    Hij geeft ook nog geen melding van een virus (ik test met Eicar)
    Herbert
  • -[erbie"][quote:d87f123a84]PidFile_avgatefwd /var
    un/avmailgate_fwd.pid #deze is belangrijk, check dit
    [/quote:d87f123a84]
    Hoi van Herbert,
    de mail forward nu wel maar de PidFile staat er niet.
    Ik denk dat daar nu nog de fout zit?
    Vreemd.. waarom forward die wel zonder dat de PidFile aanwezig is.
    Hij geeft ook nog geen melding van een virus (ik test met Eicar)
    Herbert

    doe in eerste instantie een locate avmailgate_fwd.pid en kijk of hij bij jouw mogelijkerwijs ergens anders staat.

    dat hij geen melding geeft van een virus kan ik misschien begrijpen.. probeer je virus definitie file te updaten eerst.. en kijk of hij het dan nog doet.. (bijv. /usr/sbin/antivirupdater )
    ik weet niet hoe oud Eicar is. ik ken hem niet.
  • hoi KayJay,
    ik krijg dit nu:

    (holland komt van holland.myservers.org)

    Sep 16 14:10:45 holland sendmail[1892]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: server SMTP socket wedged: exiting
    Sep 16 14:16:16 holland avgated[5338]: bind() failed (Address already in use), no retry
    Sep 16 14:18:02 holland avgatefwd[5980]: connect() failed (Connection refused)
    Sep 16 14:18:02 holland avgatefwd[5980]: connection to host "localhost", port 825 failed

    ————————————————————

    Sep 16 13:29:27 holland avgated[1589]: version: AvMailGate-2.0.1.4
    Sep 16 13:29:27 holland avgated[1589]: configuration file: /etc/avmailgate.conf
    Sep 16 13:29:27 holland avgated[1589]: library directory: /usr/lib/AntiVir
    Sep 16 13:29:27 holland avgated[1590]: ready to accept connections on port 25
    Sep 16 13:29:27 holland avgatefwd[1599]: version: AvMailGate-2.0.1.4
    Sep 16 13:29:27 holland avgatefwd[1599]: configuration file: /etc/avmailgate.conf
    Sep 16 13:29:27 holland avgatefwd[1599]: library directory: /usr/lib/AntiVir
    Sep 16 13:29:28 holland avgatefwd[1599]: engine version: 6.15.0.1
    Sep 16 13:29:28 holland avgatefwd[1599]: vdf version: 6.15.0.7
    Sep 16 13:29:28 holland avgatefwd[1599]: no valid license found - running in nonregistered demo mode
    Sep 16 13:29:28 holland avgatefwd[1605]: Current directory is '/var/spool/avmailgate'.
    ———————————————————-
    Zo te zien ben ik op de goede weg, maar de domain naam klopt niet volgens mij.

    Ik wordt er gek van :( wie weet er nog meer raad?
  • Hmm..ik zie dat
    >Sep 16 14:16:16 holland avgated[5338]: bind() failed (Address already in use), no retry
    Sep 16 14:18:02 holland avgatefwd[5980]: connect() failed (Connection refused)
    Sep 16 14:18:02 holland avgatefwd[5980]: connection to host "localhost", port 825 failed

    Blijkbaar mag die avmailgate niet opgestart worden..heb je /etc/services al aan gepast en je sendmail.cf ?
    Ik heb meteen vandaag ook die avmailgate geprobeerd maar vond het flink je systeem vertragen met sendmail.
    Ik ben meteen weer omgeswitched naar Postfix icm Amavis…dat gaat echt lekker snel :)
    Dat is echt een aanrader!

    M.
  • posfix met antivir gaat uitstekend en vertraagt niet echt.
  • Dan zal het wel aan Sendmail liggen ..want met een cyris 233 Mhz en 256 mB en sendmail met avmailgate was het niet te houden..ging erg traag en het duurde voor een 1 KN mailtje wel soms meer dan 1 minuut om hem te senden.
    Je kan me een mierenneuker vinden maar als je dus emailtjes met attachements gaat senden die groter zijn dan 1 MB..dan kan je wel raden hoe sendmail dat gaat vinden :wink:
    Op 1 of andere manier is amavis erg snel in wat ie doet..ik vind imho amavis sneller de file scannen ism Antivir dan avmailgate..

    M.
  • Ik ben er mee gestopt :(
    Nu heb ik de mailscanner van Redhat op Mandrake geinstaleerd + fprot en met enkele aanpassingen loopt dat als een trein.
    Iedereen bedankt voor de moeitje en de antwoorden,
    groetjes Herbert
  • Ff omhoog bumpen.
    Het valt me op dat Avmailgate onder Postfix perfect draait maar onder Sendmail zwaar vertraagd :-(
    Dus weer komt Postfix uit de betere hoek..iig vind ik de setup Postfix avmailgate erg lekker werken en makkelijk om op te zetten.

    M.
  • [quote:cde4ac875d]Het valt me op dat Avmailgate onder Postfix perfect draait maar onder Sendmail zwaar vertraagd [/quote:cde4ac875d]
    Ik mag het mischien verkeerd hebben maar de mailscanner van Redhat neemt sendmail helemaal over, de orginele sendmail staat uitgescakeld, wel wordt de sendmail.cf gebruikt.
    Ik merk geen vertraging hier, de berichten worden binnen 1 sec gescand.
    Herbert
  • Dan heb je het zeker fout want in /etc/services zet je op een hogere poort en laat je de avmailgate server op poort 25 werken.
    Die loopt het dan na scanning naar sendmail die het dan weer uitspuugt.
    Misschien is het die milter waar je het over hebt maar die avmailgate was erg traag ism sendmail.
    Ik weet niet wat jij traag of snel vind maar Postfix heeft een plain text mailtje in 1 a 2 seconden met avmailgate op een pentium 1 zo bij Yahoo afgeleverd.
    Dat lukt dus echt niet met een Sendmail box ism Avmailgate op een pentium 1..
    Vandaar dat voor echt grote systemen toch vaak Postfix wordt gebruikt of Qmail..beiden zijn erg snel en licht.
    Sendmail vind ik een ok MTA maar Postfix net ietsje beter..
    :wink:

    M.
  • Hoi MVE,
    je hebt het over AVMAILGATE die gebruik ik niet eens, ik gebruik de mailscanner van redhat.
    Avmailgate werkt via een smtp-backdoor op poort 825
    De mailscanner die ik gebruik werkt niet via een backdoor maar die neemt sendmail over dat is het verschil tissen avmailgate en mailscanner van redhat.
    Groetjes Herbert
  • Ah..kijk:
    a) deze topic gaat over antivit milter en avmailgate
    b) redhat heeft geen mailscanner

    Waarschijnlijk bedoel jij Amavis.
    Want ik ken geen out-of-the-box scanner van redHat.
    Of je bedoelt de Fprot virusscanner die je hebt geinstalleerd (volgens jouw setup hier boven.)

    M.
  • Hallo MVE
    je hebt gelijk, het is een redhat RPM package..
    http://www.sng.ecs.soton.ac.uk/mailscanner/downloads.shtml
    Groetjes Herbert

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.