Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

updaten KDE basaspackages en Suse 8.0

Anoniem
Middelburg
4 antwoorden
  • updaten KDE base packages en Suse 8.0

    Ik probeer de KDE base packages te updaten van:
    http://www.suse.com/us/private/download/linuks/i386/update_for_8_0/base.html
    Vooral kdebase lijkt me van belang

    De volgende dependencies maken dit onmogelijk
    qt3=3.0.3 is needed by qt3-non-mt-3.0.3.14
    qt3>=3.05 is needed by kdelibs3-3-0.3-70
    kdelibs3>=3.03 is needed by kdebase3-3.0.3-44

    qt3-non-mt-3.0.3.14 is dus de bottleneck.

    Hoe los ik dit op? Of heeft het niet veel zin een dergelijke update te maken?
  • dan moet je dus ook de needed by….. packages updaten
  • Volgens mij staat hier hetzelfde probleem met de oplossing.
  • Het probleem in de andere thread hoeft niet te maken te hebben met deze thread, de kans dat SuSE onjuiste rpm-bestanden heeft gemaakt lijkt me onwaarschijnlijker.
    Ga even na of je de gewenste pakketten wel hebt geinstalleerd.

    Onthoud het volgende met kde, je hebt te maken met verschillende lagen.
    Als je bijv. kdebase wilt upgraden, dan zul je ook de onderliggende laag (kdelibs, qt, etc..) moeten upgraden.
    Bij KDE kun je wel oudere pakketten draaien op een nieuwere onderliggende laag (uitgaande dat ze hetzelfde major versienummer hebben, dus 3.x) maar andersom niet.

    Als je zeker weet dat je de falende pakketten in de juiste versie hebt (dus meegedownload met de pakketten die je wilt bijwerken..), dan kun je overwegen om te werken met –force –nodeps bij de installatie.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.