Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

foutmeldingen bij APT

Bint
7 antwoorden
  • Ik ben met de Advanced Package Tool (voor updaten en installeren programma's) aan het experimenteren in Suse 8.0 en kom nadat het even goed gelopen heeft bij de opdracht apt-get update tot de volgende meldingen:

    Get:1 ftp://ftp.gwdg.de SuSE/8.0-i386/update pkglist
    3% [Logging in]

    bzip2: Compressed file ends unexpectedly;
    perhaps it is corrupted? *Possible* reason follows.
    bzip2: Inappropriate ioctl for device
    Input file = (stdin), output file = (stdout)
    It is possible that the compressed file(s) have become corrupted.
    You can use the -tvv option to test integrity of such files.
    You can use the `bzip2recover' program to attempt to recover
    data from undamaged sections of corrupted files.
    Err ftp://ftp.gwdg.de SuSE/8.0-i386/update pkglist
    Sub-process bzip2 returned an error code (2)

    De grafische schil synaptic heb ik reeds eerder verwijderd. Ook die draaide even goed doch gaf na een nieuwe start de meldingen:
    Could not open file /ect/apt/preferences open no such file or directory
    could not open RPM datebase.

    Ik heb om het draaiende te krijgen alles zelfs nieuw geinstalleerd doch krijg APT niet goed aan de praat. Ook de handleidingen heb ik nauwgezt gevolgd. Wie heeft er misschien een oplossing voor de problemen?
  • ehm… debian gebruiken ipv suse? :wink:
  • Of Gentoo? :wink:

    (sorry, ik kan je niet helpen)
  • Mij lijkt het wel een erg makkelijke manier om je systeem te upgraden. Vooral dat geklooi met dependencies ben je voor een groot deel kwijt.
    Voor nadere info:http://linux01.gwdg.de/apt4rpm/home.html.
    Verder toen ik het draaiende had werkte het perfect. Het probleem m.b.t het programma zelf heb ik intussen zelf kunnen oplossen.Ik heb het programma dus in elk geval draaiende.
    Wat is er overigens mis met Debian? Als beginneling (ben nu ruim een maand met linux bezig) houd ik zelf wel van gebruikersvriendelijke programma's.
  • He leuk dat je apt4rpm gebruikt!! Wordt oa ontwikkeld door Richard Bos, die ook meewerkt met de Friese en Nederlandse vertaling van KDE. De bedoeling van apt4rpm is overigens dat het in de toekomst ook met andere systemen werkt, zoals rh en mandrake…
    Misschien een idee om jezelf als tester van dit systeem aan te melden, dan heb je meteen een hoop expertise ondr handbereik als je weer tegen een probleem aanloopt ;)


    Max
  • Apt-get is afkomstig van Debian. Gentoo heeft een doorontwikkelde versie, dus vandaar de adviezen. :wink:
  • [quote:4d8256fe7e="Middelburg"]Mij lijkt het wel een erg makkelijke manier om je systeem te upgraden. Vooral dat geklooi met dependencies ben je voor een groot deel kwijt.

    [/quote:4d8256fe7e]

    Het is de meest ideale manier om je systeem up-to-date te houden. Het geklier met de dependencies ben je idd helemaal kwijt.

    [quote:4d8256fe7e="Middelburg"]
    Wat is er overigens mis met Debian? Als beginneling (ben nu ruim een maand met linux bezig) houd ik zelf wel van gebruikersvriendelijke programma's.[/quote:4d8256fe7e]

    Met Debian is helemaal niets mis, misschien is het voor de beginner in het begin even wat moeilijker omdat ie moet lezen wat hij gaat doen. Maar daarna (als je hebt geleerd dat je wat meer moet lezen) is het een stuk makkelijker en eenvoudiger bij te houden.

    Voor mij persoonlijk is Debian de ideale distro. En idd.: APT is super!

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.