Vraag & Antwoord

OS Linux

Hellup... grub pikt mijn nieuwe kernel niet....

20 antwoorden
  • Ik heb bzImage van kernel-2.4.11 gecompileerd. Onder CalderaOpenLinux3.1.1 en die gebruikt grub. En met grub heb ik niet veel ervaring. Mijn menu.lst ziet er zo uit: ------------------- # # /boot/grub/menu.lst - generated by Lizard # # options timeout = 30 splashscreen = (hd0,0)/boot/message.col31 default = 0 title = CalderaLinux 2.4.13 root = (hd0,0) kernel = /boot/vmlinuz-2.4.13-modular vga=274 quiet root=/dev/hda1 title = CalderaLinux 2.4.11 root = (hd0,0) kernel = /boot/bzImage2 vga=274 quiet root=/dev/hda1 ------------------------------ Mijn kernel met bzImage2 wil niet booten. Grub zegt niet "loading kernel" maar doet gewoon niks. Pc uit en aan, vmlinuz boot wel. Het is een vrij nieuwe pc. Zou mijn kernel niet goed zijn gebakken met menuconfig? Of doe ik iets fout met grub?
  • Kijk [url=http://forums.gentoo.org/viewforum.php?f=14]hier[/url] maar eens rond voor problemen met grub. Je bent iig niet de enige. :wink:
  • Ik flikker grub eraf.... lilo werkt ook.... hij gaat 1 stapje verder... hij zegt loading kernel..... maar dan stopt ie weer...
  • Doe ik ook nog steeds, grub bevalt me gewoon (nog) niet... :D
  • Met lilo nu dus..... hij zegt loading kernel, maar er komt niet meer te staan booting kernel... zal mun kernel wel fout weze.... heb zo'n nieuwe asus met p-celeron1,6Ghz. Moet ik toch een celeron als cpu kiezen? Of werkt 486 of pentium-classic ook?
  • Je hebt dus zo'n Pentium 4 Celeron? Je zou dan eventueel zelfs voor de Pentium 4 kunnen kiezen volgens mij, enige verschil tussen de Pentium 4 en zijn Celeron broertje is dat de Celeron wat minder cache heeft, voor de rest is alles hetzelfde. Natuurlijk zou Pentium-classic, i486 of nog lager ook goed moeten werken! Succes!
  • >Natuurlijk zou Pentium-classic, i486 of nog lager ook goed moeten werken! En dat doet ie dus niet...
  • Je doet verder niets bijzonders met compilen, bijv. gebruikmaken van GCC 3.2? Volgens mij is kernel 2.4.11 daar niet voor gemaakt... Misschien is het door al dat geprobeer een beetje een rotzooi geworden, probeer eens "make clean" en "make proper", heb je misschien al gedaan.... Waarom wil je eigenlijk per se versie 2.4.11, heeft dat ook met die module te maken? Ik wil eventueel wel wat voor je compilen. Zeg maar wat. Nogmaals veel succes! :wink:
  • >Waarom wil je eigenlijk per se versie 2.4.11 We draaien hier een kleine runtime-kernel voor novell-imaging. Die kernel is 2.4.11. Ik kan wel modules laden, maar niet compileren. >Ik wil eventueel wel wat voor je compilen. Zeg maar wat. Dat zou fantastisch zijn... ik wil een e100.o-module hebben van een nieuwe intel-netwerkkaart . De sources hiervan staan op http://downloadfinder.intel.com/scripts-df/proc/T8Clearance.asp?url=/2896/eng/e100-2.1.15.tar.gz Als je kernel2.4.11 hebt is het echt maar een minuutje werk dat compilen zelf. En ik hoef dan alleen die e100.o te hebben ( mailto: linux@raayland.nl). Als je dat zou willen doen, zou dat heel mooi zijn.
  • Ik zal vanavond 2.4.11 downloaden en die module voor je compilen. Moet nu werken, ja echt, en dat na een toetsweek :evil:
  • He Knopper.... gaaaaf.... ik kan het wel pas maandag of dinsdag testen... maar heel bedankt!!
  • Dus ik moet kernel 2.4.11 draaien en dan die module compilen? Of moet ik de kernel patchen met die module. Moet ik dan alsnog de kernel draaien? Voor wat voor een type processor moet ie worden gecompiled? edit: ok, heb net de README gelezen, patchen is dus niet de bedoeling. Maar moet ik nu wel 2.4.11 echt draaien?
  • Ik compile hem trouwens wel met GCC 3.2 weet niet of dat problemen oplevert, komen we vanzelf wel achter :D
  • Ok, ik zal eerlijk tegen je zijn :D Het zit zo, als ik tenminste kernel 2.4.11 moet draaien, ik gebruik het XFS filesystem, helaas ondersteunt deze kernel dit niet standaard en de kernelpatch vereist minimaal 2.4.18. Mijn bootpartitie is ext2 maar te klein om alles op te zetten. Mijn server offer ik er liever niet voor op, heb deze net naar mijn zin. Dus het gaat denk ik niet lukken, tenzij ik 2.4.11 niet hoef te draaien.
  • [quote:74985f8b6d="knopper"]Ok, ik zal eerlijk tegen je zijn :D Het zit zo, als ik tenminste kernel 2.4.11 moet draaien, ik gebruik het XFS filesystem, helaas ondersteunt deze kernel dit niet standaard en de kernelpatch vereist minimaal 2.4.18. Mijn bootpartitie is ext2 maar te klein om alles op te zetten. Mijn server offer ik er liever niet voor op, heb deze net naar mijn zin. Dus het gaat denk ik niet lukken, tenzij ik 2.4.11 niet hoef te draaien.[/quote:74985f8b6d] om een kernel te maken hoef je hem niet te draaien hoor :D Maar stop bij make modules en zoek dan de gewnste module ff op die kun je dan mailen naar Leon :D hoop wel dat dat gaat lukken met gcc 3.2 ??
  • Een module bedoel je.... :wink:
  • Denk trouwens dat het wel nodig is, er worden namelijk wat dingen "geinclude" van de draaiende kernel. Modversions bijvoorbeeld. Is dit erg?
  • Met 2.4.18 had ik die e100.o al gebakken... die werkte prima.... maar die zei onder kernel2.4.11 dat ie niet de goede kernelversie was. Dus.... moet ik die e100.o echt onder 2.4.11 bakken.... Helaas... ik denk dat ik of Novell ga vragen die module te bakken; zij leveren immers een runtime-versie van 2.4.11 zonder compiler... of ik ga een beta runtime-versie van Novell gebruiken die toevallig 2.4.18 draait.... Maar he Knopper.... echt tof dat je me zo geholpen hebt.... thanx man...
  • Ach, ik heb wat moeite gedaan. Ik heb je er niet echt mee geholpen :D Hoe dan ook, graag gedaan!
  • Oplossing... http://support.novell.com/cgi-bin/search/searchtid.cgi?/10057994.htm Daar worden nieuwe disks geleverd en een nieuwe e100.o

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.