Vraag & Antwoord

OS Linux

X error tijdens installeren wacom tablet

Anoniem
Mithrandir
6 antwoorden
  • HElp, tijden shet installeren van mijn wacom tablet stuit ik op de bolgende X-error.

    X Error of failed request: BadDevice, invalid or uninitialized input device
    Major opcode of failed request: 146 (XInputExtension)
    Minor opcode of failed request: 3 (X_OpenDevice)
    Serial number of failed request: 11
    Current serial number in output stream: 11

    Wie weet hier raad mee?

    O ja mij XFconfig ziet er zo uit
    # File generated by XFdrake.

    # **********************************************************************
    # Refer to the XF86Config man page for details about the format of
    # this file.
    # **********************************************************************

    Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
    EndSection

    Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    EndSection

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
    Load "wacom" # tabletdriver
    Load "xf86Wacom.so"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us_intl"
    Option "XkbOptions" ""
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "MouseManPlusPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "stylus"
    Driver "wacom"
    Option "Type" "stylus"
    Option "Device" "/dev/ttyS2"
    EndSection

    Section "InputDevice"
    Identifier "eraser"
    Driver "wacom"
    Option "Type" "eraser"
    Option "Device" "/dev/ttyS2"
    EndSection

    Section "InputDevice"
    Identifier "cursor"
    Driver "wacom"
    Option "Type" "cursor"
    Option "Device" "/dev/ttyS2"
    EndSection

    Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "Iiyama S700JT1"
    HorizSync 30-70
    VertRefresh 50-130

    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
    EndSection

    Section "Device"
    Identifier "device1"
    BoardName "ATI Rage 128"
    Driver "r128"
    Option "DPMS"
    Option "AGPMode" "true"
    Option "UseCCEFor2D" "true"
    EndSection

    Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
    Depth 8
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection

    Subsection "Display"
    Depth 15
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection

    Subsection "Display"
    Depth 16
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection

    Subsection "Display"
    Depth 24
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubsection
    EndSection

    #Section "ServerLayout"
    # Identifier "layout1"
    # InputDevice "Keyboard1" "CoreKeyboard"
    # InputDevice "Mouse1" "CorePointer"
    # Screen "screen1"
    #EndSection

    Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"

    InputDevice "stylus" "AlwaysCore"
    InputDevice "eraser" "AlwaysCore"
    InputDevice "cursor" "AlwaysCore"

    InputDevice "Keyboard1" "CoreKeyboard"
    EndSection

    Heb ik hierboven iets verkeerds gedaan? Het tablet heeft wel gewerkt, maar na een upgrade van mdk 8 => 9 niet meer.
  • zo te zien gebruikte mandrake 8 XFree86 3.x en heb je nu XFree86 4.2 (Mandrake 9)

    de config files zijn niet uitwisselbaar
  • Hievoor had ik ook XF86 4.x
  • mmm, ok dan ;)

    heb je zelf een kernel gemaakt, of heb je die van mandrake nog altijd?

    heb je dan de modules voor je wacom erin/erbij zitten?
    zijn dat wellicht modules die voor usb bedoeld zijn (dus niet serial)?


    start x helemaal niet, of doet alleen de wacom het niet?

    overigens kun je meer informatie vinden in iirc /var/log/XFree86.0.log
  • De modules in de kernel zijn, volgens mij alleen voor de USNB versie. Ik heb de serieele. Nu doet X het gelukkig wel, met een gewonde muis als pointer.
    En in de log staan een heleboel wacom readwrite i/o errors. hmmmmm kan mijn serielen poort dan niet actief zijn?
  • Yes opgelost, in had gewoon de verkeerde poort. :-?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.