Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

probleem bij installeren

Anoniem
Cyphus
11 antwoorden
  • ik wil graag gmudix installeren, maar daar gaat het nie om geloof ik, ik runde de configure en hier bleef ie bij hangen:

    checking for gtk+-2.0 >= 2.0.0… Package gtk+-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gtk+-2.0' found

    configure: error: Library requirements (gtk+-2.0 >= 2.0.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

    waar haal ik gtk+-2.0 vandaan?

    alvast bedankt,
  • Hier!
    8)
  • keej bedankt, maar ik ga voor windows
    ik word gek van al die dependencies en alles wat je moet compileren en natuurlijk krijg ik niks gecompileerd.
  • [quote:73eb52d0dd="Cyphus"]keej bedankt, maar ik ga voor windows
    ik word gek van al die dependencies en alles wat je moet compileren en natuurlijk krijg ik niks gecompileerd.[/quote:73eb52d0dd]

    [edit]
    ik doe toch nog een poging:
    -hoe compile je: libpng
    -in de install staat dat zlib er ook bij zit. die zie ik nergens staat.
    alvast bedankt,
    [/edit]
  • probeer dit eens:
    ./configure
    make
    install (als root)

    wat zegt configure eigenlijk?


    oh ja..dependencies…heb je dat onder windows ook niet? alleen daar worden deze standaard met het pakket meegeleverd, en geinstalleerd zonder dat je het weet, waardoor applicatie x versie 1.2 en applicatie y versie 1.3 nodig heeft terwijl door applicatie z 1.4 geinstalleerd is, waardoor de hele boel op zijn bek gaat??
  • valt wel mee. bij windows is het eigenlijk altijd zo dat nieuwe versies compatible zijn met oudere versies. en dat alles automatisch wordt geinstalleerd zorgt dat je meteen aan de slag kunt. sorry maar het systeem van windows heeft zo z'n voordelen. sowieso als je een n00b bent.

    ik heb het progje (gmudix) aan de praat gekregen. best wel stom dat ik het niet wist, bedenk ik me nu, maar je moet het gewoon 1 keer gedaan hebben. ik moest dus alles van gtk installeren en natuurlijk staat dat op cd. dus dat heb ik geinstalleerd. daarnaast had ik pango en atk nodig dus die heb ik gedownload en gecompileerd. daarna was het geen probleem meer.

    misschien is het wel makkelijk om in de faq te zetten dat je bij het zelf compileren van programma's libraries (zoals gtk) nodig hebt. dit is natuurlijk ontzettend logisch, maar niet voor mensen die windows gewend zijn.
    deze libraries zitten dus vaak wel bij je distributie, maar zijn niet standaard geinstalleerd (bij mandrake 9 iig niet).
  • [quote:3a880f8ae4="Cyphus"]valt wel mee. bij windows is het eigenlijk altijd zo dat nieuwe versies compatible zijn met oudere versies. en dat alles automatisch wordt geinstalleerd zorgt dat je meteen aan de slag kunt. sorry maar het systeem van windows heeft zo z'n voordelen. sowieso als je een n00b bent.

    [/quote:3a880f8ae4]

    ik ken genoeg pakketten waarbij dit niet zo is..
    voorbeeld: Visual Basic + Cognos E-Applications installeren..
    één van die twee gaat dan gehaaid niet werken, resulteerd in error in huppeldepup_nogwat.DLL

    oudere versies kennen nieuwe dll's niet goed
  • nee idd oudere versies kunnen niet werken met de verbeteringen in de nieuwe versie, maar je noemt nu ook een paar programma's die je gebruikt als je er al meer vanaf weet dus dan ben je echt geen n00b meer en weet je wat je nodig hebt, zodat het wel werkt
  • Ach, compileren onder Linux is nog altijd eenvoudiger dan onder Windows.

    Max
  • compileren onder windows en onder linux is nie te vergelijken. compileren onder windows doe je alleen bij je eigen programma's
  • Met andere woorden, als je voor Windows software schrijft maak je de broncode bij voorbaat niet beschikbaar voor anderen ;)

    Maar dat wil niet zeggen dat er niks valt te compileren onder Windows.
    Veel OSS-programma's zijn ook geschikt voor Windows, en zul je ook zelf moeten compileren..




    Max

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.