Vraag & Antwoord

OS Linux

Inloggen op de server???

40 antwoorden
  • Goed, een een nieuw topic aangezien het onderwerp nogal veranderd is. Ik had problemen met webmin installeren dit is inmiddels opgelost. Webmin is geinstalleerd en het volgende kwam op het scherm: Webmin install complete you can now login to http://home:10000/ as root with your rooot password Als ik dit letterlijk overtik in mn browser op een andere (windows 98se) pc krijg ik echer een foutmelding (kan server niet vinden, de pagina kan niet weergeven worden) als ik ipv home het ip adres invoer : 192.168.0.1 kan ik alsnog niet inloggen. (zelfde foutmelding) Ik ben weer een stapje verder maar toch nog een heel stuk weg van huis :s Please help!!!
  • Heb je poort 10000 open gezet in de firewall? Om dit open te zetten kun je het bestand '/etc/sysconfig/iptables' aanpassen. Daar moet een regel bij als [code:1:e4f5bf8708]-A INPUT -p tcp -i eth0 --sport 10000 -j ACCEPT[/code:1:e4f5bf8708]. Als er een regel is die er ongeveer hetzelfde uitziet (INPUT komt overeen en ACCEPT komt overeen) dan moet hij daar achter. Overigens ga ik ervanuit dat eth0 de netwerkkaart is voor het interne netwerk. Als webmin het doet kun je je firewall overigens vanuit dat programma instellen.
  • Ik heb geen firewall geinstalleerd, die optie heb ik bij de installatie uitgeschakeld Toch zal ik even uitproberen wat je zojuist zei
  • Als ik die code uitvoer krijg ik terug that there is no such file or directory. Ik heb gelezen dat netscape beter werkt met webmin dan IE. Ik heb dus ook netscape gedownload en geinstalleerd. Als ik nogmaals probeer te connecten met: https://192.168.0.1:10000/ Krijg ik dit terug: The connection was refused when attempting to contact 192.168.0.1:10000/ Betekend dit dat ik root en het rootpassowrd hier al ergens in moet verwerken? En zo jah hoe? K wordt gek! :p Please help!!! :oops:
  • Beetje open deur, maar voor de zekerheid: ik neem aan dat je wel het IP-nr van je server, en niet van je Win98-compu invult?
  • [quote:1a30dfd99b="wateengedoe2"]Beetje open deur, maar voor de zekerheid: ik neem aan dat je wel het IP-nr van je server, en niet van je Win98-compu invult?[/quote:1a30dfd99b] als ik naar dit ip krijg is het gewoon het gateway nummer, de server dus.. https://192.168.0.1:10000 zou moeten werken
  • Zou die laatste / weg moeten? Anders denk ik toch dat er een firewall is of dat er iets in webmin fout is geinstalleerd....
  • als ik htp[b:a7e03e1842]s[/b:a7e03e1842] gebruik doet hij het ook niet hoor :D ram simpel http://192.168.0.1:10000 in en hij zal het wel doen of laat gewoon het hele http verhaal eraf dus => 192.168.0.1:10000 Wellicht doet hij het dan wel :D
  • Ik snap er niks meer van, ik blijf de zelfde foutmelding krijgen (connection refused) Het ip adres klopt zeker (ifconfig) de 10000 is standaard dus daar kan het niet aan liggen. Na mijn weten heb ik geen firewall geinstalleerd. En als ik die code gebruik die in een aantal posts hierboven beschreven is krijg ik een foutmelding. Is er geen andere manier om te controleren of er een firewall is geinstalleerd respectievelijk ingeschakeld? En als het niet aan die firewall ligt waar kan het dan nog meer aan liggen? De utp kabels zitten in dezelfde hub dus er moet een verbinding mogelijk zijn. Ik snap het niet echt :s Baal hier van :s
  • Hoe probeer je in te loggen? als root? kijk dan eens in /etc/securetty. Daar staat waar je als root mag inloggen. Kijk ook eens of 192.168.0.1 wel het ip van je server is.
  • uhh misschien een beetje dom hoor maar draait webmin wel ?? als hij geinstalleerd is moet je hem nog wel starten nml. dus op die linux bak ps -ax | greb webmin
  • das helemaal geen domme vraag geloof ik :s hij is geinstalleerd en daar stond automatisch achter (zie boven in de topic) dat de server beschikbaar was op http://home:10000/ maar ik heb daarna niks meer gedaan. Kan dit betekenen dat hij niet is geactiveerd? en zo ja hoe activeer ik hem dan? (sorry op linux gebied ben ik echt een halve zool) J.G
  • [quote:7e68c5b9fe="cHiLlaH"]... (sorry op linux gebied ben ik echt een halve zool) J.G[/quote:7e68c5b9fe] Netter gezegd heet dat beginner. Het duurt niet zolang voordat je een gevorderd gebruiker bent. Wel duurt het heel erg lang voordat je jezelf guru kan noemen. Echte guru's zijn heel erg zeldzaam, zo niet onvindbaar.
  • Je kan zien of hij geactiveerd door de code die wstolk opschreef uit te voeren. Als webmin draait krijg je[code:1:3f93574d3a] 875 ? S 0:00 /usr/bin/perl /usr/libexec/webmin/miniserv.pl /etc/we[/code:1:3f93574d3a] of iets dergelijks terug. Als hij niet draait krijg je helemaal niets terug. Je kan webmin aanzetten door als root naar de directorie '/etc/init.d' te gaan, en vervolgens './webmin start' uit te voeren. Dan wordt webmin eenmalig gestart. Vervolgens hoop ik dat je kunt inloggen en in de init-editor van webmin het programma structureel kunt laten uitvoeren.
  • Ik heb het startcommando uitgevoerd. Hij leek even te laden en toen knipperde de cursor weer op de volgende regel. Geen foutmelding maar ook geen bevestiging... Maar nogsteeds als ik probeer in te loggen op 192.168.0.1:10000 krijg ik terug dat de connection was refused. Kan het niet aan deze windows pc liggen? Dat ik hier iets uit moet schakelen of juist iets in moet schakelen ofzo? K baal echt, jullie geven allemaal klasse antwoorden maar niks lijkt te helpen. Net alsof ik echt een totale ramdebiel ben :-? J.G
  • Probeer eens: http[color=red:c5cfb0ac7b]s[/color:c5cfb0ac7b]://192.168.x.x:1000 en dan is de x.x van je linux machine of misschien: http[color=red:c5cfb0ac7b]s[/color:c5cfb0ac7b]://localhost:1000
  • Probeer eens: http[color=red:3f95c9de96]s[/color:3f95c9de96]://192.168.x.x:10000 en dan is de x.x van je linux machine of misschien: http[color=red:3f95c9de96]s[/color:3f95c9de96]://localhost:10000
  • die 's' is wel nodig omdat webmin standaard zichzelf over de ssl plaatst. je kan kiezen om dat niet te doen.. is uiteraard niet bevordelijk natuurlijk.. maar mits je geen vuurmuur heb, je ip van je server ook daadwerkelijk 192.168.0.1 is (lijkt mij van wel, is een typisch ip nummer voor een gateway) dan zou het gewoon moeten werken.
  • Precies zoals je het zegt het ZOU inderdaad moeten werken. Localhost werkt ook niet. Ik snap het niet alles wat hier staat heb ik zo ingevuld. Via ifconfig heb ik het ip adres gecontroleerd. Dit klopt. Ik heb webmin gestart. Het is na mijn weten goed geinstalleerd. Ik heb geen foutmeldingen :-?. Verder heb ik de nieuwste versie van netscape geinstalleerd en heb ik zowel http https als direct het ip adres gebruikt. Nog ideen?
  • [quote:c6caa88a47="cHiLlaH"] Ik heb het startcommando uitgevoerd. Hij leek even te laden en toen knipperde de cursor weer op de volgende regel. Geen foutmelding maar ook geen bevestiging... [/quote:c6caa88a47] Na het uitvoeren van het startcommando moet je een reactie "Starting Webmin server in /usr/libexec/webmin". Wat is de uitvoer van het commando (als root) [code:1:c6caa88a47]cd /etc/init.d && ./webmin status[/code:1:c6caa88a47] En van het commando [code:1:c6caa88a47]cd /etc/init.d && ll -h webmin[/code:1:c6caa88a47] (m.a.w. hoe groot is het opstartscript) Bij mij is het opstartscript 944 bytes groot. Als het veel afwijkt is webmin niet goed geinstalleerd.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.