Vraag & Antwoord

OS Linux

Inloggen op de server???

Anoniem
cHiLlaH
40 antwoorden
  • Stomme vraag misschien, maar wordt er niets gelogd op die server? Dan zou je misschien de pogingen tot inloggen in je logfiles terug kunnen zien, met eventuele meldingen.
  • Lol dat zou ik best willen bekijken maar ik denk dat je me daar dan toch maar even de codes bij moet geven 8) (to water)

    M kelder :

    cd /etc/init.d && ./webmin status

    geeft weer:

    webmin (pid 785) is running

    cd /etc/init.d && ll -h webmin

    geeft weer:

    -rwxr -xr -x 1 root root 1.1k nov 2 09.08 webmin (laatste webmin in groene letters)

    Ik hoop dat je hier iets mee kunt?

    Ps: Ik krijg niet dat startcommando wat je daar weergeeft. er gebeurd gewoon even niks en dan komt …root] er weer te staan met een knipperende cursos. Er komt geen tekst nadat ik dat commando geef

    Dat is niet goed neem ik aan?
  • Ik zit me nog iets af te vragen. Hoop dat ik gelijk heb maar eigenlijk ook niet. Heb ik nu namelijk gelijk dan heb ik jullie veel moeite gekost

    Bij ifconfig staat er wel Up and Running maar ik heb nooit mn netwerk kaart geinstalleerd of geconfigureerd. Ik heb alleen bij de installatie van linux een ip adres 3 dns servers en een subnetmasker ingesteld (handmatig niet via DHCP) Kan hier de fout ergens liggen? En zo ja hoe los ik dat op :s


    J.G

    (starting to get desperate!!!)
  • De uitvoer van de commando's klopt. Dat duidt erop dat webmin goed is geinstalleerd.
    In de uitvoer moet een gedeelte voorkomen die lijkt op die hieronder staat.
    [code:1:acf7fab7c7]
    eth0 Link encap:Ethernet HWaddr 00:48:54:7A:15:3B
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:0 (0.0 b) TX bytes:168 (168.0 b)
    Interrupt:11
    [/code:1:acf7fab7c7]
    Indien je twee netwertkkaarten hebt, heet er een eth0 en de andere eth1. Je kunt controleren of de netwerkkaart het doet door vanaf de Windows 98 computer de linux-computer te pingen. Ook kun je proberen vanaf de linux-computer jezelf te pingen (via 192.168.0.1, niet via 127.0.0.1)

    Netwerkkaarten worden vaak automatisch herkent, en vaak hoef je daar niets voor in te stellen. Ook maakt het niet uit of je met een statisch of dynamisch adres instelt: in beide gevallen moet het werken.
  • webmin zou ook op de loopback moeten draaien.
    dus op localhost.
    m.a.w. https://localhost:10000 zou ook moeten werken alsmede https://127.0.0.1:10000
  • De code klopt.

    Pingen op de linux pc gaat ok ik weet niet hoe vaak die dat welniet doet maar daar hebben we het nu even niet over (tikte in ping 192.168.0.1) en inmiddels heeft ie al meer dan 150 keer gepinged :S) maar het lijkt dat ik op de linux pc een verbinding heb. Hij verstuurd 64 byte en dan komt erachter te staan hoeveel tiende van een miliseconde hij erover doet dus dit moet kloppen

    Als ik uit dos naar linux probeer te pingen (uitvoeren–>command–>ping 192.168.0.1) heb ik echter 4 maal een timeoput en dus 100% packetloss

    J.G
  • [quote:c6c86f63fb="cHiLlaH"]De code klopt.

    Pingen op de linux pc gaat ok ik weet niet hoe vaak die dat welniet doet maar daar hebben we het nu even niet over (tikte in ping 192.168.0.1) en inmiddels heeft ie al meer dan 150 keer gepinged :S) maar het lijkt dat ik op de linux pc een verbinding heb. Hij verstuurd 64 byte en dan komt erachter te staan hoeveel tiende van een miliseconde hij erover doet dus dit moet kloppen

    Als ik uit dos naar linux probeer te pingen (uitvoeren–>command–>ping 192.168.0.1) heb ik echter 4 maal een timeoput en dus 100% packetloss

    J.G[/quote:c6c86f63fb]

    dan werkt je LAN dus niet… 192.168.0.1 is het ip van de eth1 van je server. die zal hij wel vinden… ifconfig eth1 zou ook dit ip nummer aangeven.. dus daar zit het hem niet in…

    maar dit staat los van webmin, zoals ik al zei kan deze prima lokaal draaien.. een netwerk is niet eens nodig.. probeer eens op de server webmin te openen in een browser (mits gui beschikbaar anders moet je lynx opstarten) en kijk offie het daar doet. als ie het daar doet, is gewoon je LAN niet goed geconfureerd..
    pingen zou hij altijd moeten doen…. controleer je switch/hub/router aansluitingen
  • De linux-versie van ping gaat door tot je op CTRL-C gedrukt hebt.
  • Wow dit gaat allemaal beetje snel :s

    Even voor de duidelijkheid ik heb bij de installatie voor custom gekozen en alleen de delen voor windows file server netwerk support en print software geintsalleerd (en k geloof xwindow maar dat werkt niet)

    Kay Jay ik heb geen eth1 geloof ik alleen een eth0 (1 netwerk kaart)

    [quote:27cd412abd="Kay Hay"]maar dit staat los van webmin, zoals ik al zei kan deze prima lokaal draaien.. een netwerk is niet eens nodig.. probeer eens op de server webmin te openen in een browser (mits gui beschikbaar anders moet je lynx opstarten) en kijk offie het daar doet. als ie het daar doet, is gewoon je LAN niet goed geconfureerd..
    pingen zou hij altijd moeten doen…. controleer je switch/hub/router aansluitingen[/quote:27cd412abd]

    Ik zou echt niet weten hoe ik een browser moet openen op de server (waarschijnlijk heb ik niet eens een browser geinstalleerd) Wat is gui en wat is lynx? mn hub is ok en de aansluitingen na mijn weten ook maar dat zal ik nog even checken

    J.G
  • Als je dus niet [b:9d6671e062]NAAR[/b:9d6671e062] je linux bak kan pingen en je wel je netwerkkaart goed hebt ingesteld (ifconfig) dan duidt dit dus op een fisiek probleem.

    oftewel:
    ping eens van linuxbak naar je win-pc
    check het IP van je winPC en de gateway
    check je kabels eens :D

    succes
  • gui = graphic user interface
    Lynx = browser voor als je geen gui hebt.

    Hoe maak je contact met de buitenwereld? ADSL met usb? Of staat je server los van de buitenwereld?

    Aangaande log-messages: even zoeken in /var/log. Kijk eens naar iptables, eth0, net, of wat maar ook in de buurt komt.
  • Ik gebruik niks geen crosscables ofzo. Het is gewoon een hub met 2 pc's, 2 netwerkkaarten. 1 Uplink utp kabel (van het kabelmodem) en 2 utp kabels naar de verschillende pc's. Binnenkort komt hier een 3e pc bij.

    De instellingen van de windows pc zijn de standaard @home instellingen (213.51.196.x ipadres, 255.255.254.0 subnetmasker, 213.51.196.1 standaard gateway)

    Ik zal linux opnieuw installeren (en nu kiezen voor de server installatie modus) ik kan voor het vinden van een ip adres dhcp dus aangefinkt laten staan? En vervolgens de rest later in linux handmatig installeren?

    Zo ja hoe doe ik dit dan precies en wat zijn de beste instellingen die ik kan gebruiken?

    Die linux bak wordt eigenlijk alleen voor WEBmin gebruikt. Ik wil er graag een printer en bestandsserver van maken. (kortom inloggen via internet) en wel gewoon van uit word printopdrachten kunnen geven naar de printer die is aangesloten op de linux bak etc etc

    Tnks

    J.G
  • Contact met de buitenwereld weet ik niet zeker of hij dat wel maakt. Deze (windows) pc is aangesloten op de hub (daar komt de kabel op binnen (@home)) Hij maakt dus via de hub verbinding met het internet. De server pc (linux) is ook verbonden met de hub dmv een utp kabel (en dus ook zo met de kabel van @home)


    Ik zie niks van dat alles daarbij staan.

    J.G
  • Ik was zojuist blij. Een geluk bij een ongeluk dacht ik. Ik heb mn hele systeem richting mn utp aansluiting op de server verhuist. Ik die utp kabel in mn nic gepropt en gekeken of ik kon internetten. Wat scherst mijn verbazing NIET dus. De utp kabel is kapot (net nieuw uit de winkel maar allah) Ik dus helemaal blij want ik denk ok nieuw utp kabeltje ertussen en voila. Ik dus een nieuwe utp kabel uit de kast halen. Aangesloten en ook nog even op dit systeem getest. De utp kabel werkt zeker weten. Als ik hem in de hub plug en dan in deze pc kan ik gewoon internetten.

    Goed systeem weer verplaatst beide weer aangesloten op de kabel en ik denk dus. Ok probleem opgelost. viel dat even tegen

    Ik kan nog steeds niet connecten


    Edit: Als ik vanaf de linux pc ping kan ik pingen naar zowel 127.0.01 als naar 192.168.0.1 naar het ip adres van mijn windows pc krijg ik echter de melding: network unreachable

    Als ik vanaf mijn windows pc ping kan ik wel naar 127.0.0.1 pingen maar als ik naar 192.168.0.1 ping krijg ik 4 keer een timeout

    J.G
    niet naar 192.169.0.1 niet naar 127.0.0.1 en niet naar localhost

    Ik snap er helemaal niks meer van aan de fysieke verbindingen kan het niet meer liggen.

    Wat kan het zijn??? HELLLLUPPP!!!
  • Installeer de boel opnieuw!! En kijk eens rustig wat je installeert.
    Zo komen we er toch niet uit.
    En honderd keer opnieuw installeren brengt een hoop ervaring.

    Succes!
  • Lol ik heb het al 4 keer geintstalleerd maar ik zal het nog een keertje doen en dan maak ik er wel een server pc van (onder het installatie menu Red Hat 8.0) Als ik het installeer kan ik handmatig het ip adres invoeren (dat moet denk ik ook via dchp werkt volgens mij niet)

    Wat kan ik hier het beste invoeren dan

    Bij iP?
    Bij Dns server 1,2 en 3?
    Bij gateway?
    By subnetmasker etc etc etc?

    Grtz

    J.G
  • [quote:0300d9dc8f="cHiLlaH"]Lol ik heb het al 4 keer geintstalleerd maar ik zal het nog een keertje doen en dan maak ik er wel een server pc van (onder het installatie menu Red Hat 8.0) Als ik het installeer kan ik handmatig het ip adres invoeren (dat moet denk ik ook via dchp werkt volgens mij niet)

    Wat kan ik hier het beste invoeren dan

    Bij iP?
    Bij Dns server 1,2 en 3?
    Bij gateway?
    By subnetmasker etc etc etc?

    Grtz

    J.G[/quote:0300d9dc8f]

    Niet nodig :evil:

    Linux instaleer je 1 keer en daarna ga je de boel op orde brengen :D

    ff lijstje aflopen
    op je linux bak:
    #ifconfig => moet output geven voor eth0 en evt. voor lo (lo = locaal >> 127.0.0.1 )
    >>pingen op je linux bak naar de adressen die voor eth0 en lo zijn ingevuld geeft alleen maar aan of netwerk ook ondersteund wordt.
    #route -n => geeft output over je netwerk instellingen ed
    bijv.
    [code:1:0300d9dc8f]
    route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.229.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    0.0.0.0 192.168.229.151 0.0.0.0 UG 0 0 0 eth0
    [/code:1:0300d9dc8f]
    regel met:
    192.168.229.0 >>broadcast adres van mijn etho
    0.0.0.0 >> hier staat als tweede mijn gateway

    als dit dus in orde is ga je kijken of fisiek je netwerk in orde is:
    dwz. pingen naar adres van een andere machine in je netwerk
    als dit niet lukt check dan of je niet je kabels in een verkeerde aansluiting op je hub hebt.

    Gebruik dus [b:0300d9dc8f]niet [/b:0300d9dc8f] de line_up aansluiting want dat gaat mis !!
    Check ook ff of je niet perabuis een crosslink kabel gebruik.

    Laat het internet verhaal er ff buiten dat komt later wel.

    Kom anders eens met al je instellingen dus ook vn je andere pc's
  • Weet je zeker dat het mogelijk is om de modem in het netwerk te pluggen? Meestal ben je voor een kabelmodem een (software) router nodig. Die router bekijkt dan de IP-adressen en als ze niet aan het interne netwerk toebehoren, stuurt hij ze naar buiten. In dit geval heb je je windows computer ingesteld om gebruik te maken van het externe netwerk. Dan is het interne netwerk niet te bereiken. Om webmin te gebruiken moet je het IP-adres op de windows-computer instellen op 192.168.0.2, de submaskset op 255.255.0.0 en geen gateway. Waarschijnlijk kun je dan webmin gebruiken en de server pingen. Je kan dan echter niet meer het internet op. Om tegelijk het interne als het externe netwerk te bereiken moet je in je linux-computer een netwerkkaart toevoegen. Vervolgens moet je je linux-computer instellen voor NAT. Hoe je je windows-computer hier precies op aanpast heb ik ergens anders in dit forum gelezen.

    Veel succes.
  • Een netwerkkaartje is niet het grootste probleem. Maar zoals het in computer totaal wordt beschreven moet het mogelijk zijn. Temminste volgens hun…

    (Computer totaal nummer 10 oktober 2002 blz 46-48)

    Enneh wat bedoel je met NAT?

    Tnks

    JG
  • [quote:fdbeb99f11="cHiLlaH"]…Deze (windows) pc is aangesloten op de hub (daar komt de kabel op binnen (@home)) Hij maakt dus via de hub verbinding met het internet. De server pc (linux) is ook verbonden met de hub dmv een utp kabel (en dus ook zo met de kabel van @home)

    …[/quote:fdbeb99f11]

    Zo moet het dus niet! (Of je moet bij essent@home voor meerdere ip-adressen betalen, en die service wordt meen ik niet meer geleverd!) Je netwerk is fysiek niet zoals het hoort. Wat je moet doen is het volgende:

    In je server zet je twee netwerkkaarten. In de ene netwerkkaart steek je de kabel van essent, de andere netwerkkaart verbind je met de hub dmv een utp-kabel. Alle andere pc's worden met een utp-kabel op de hub aangesloten.

    Tijdens de installatie laat je de essentkaart instellen via dhcp, de andere stel je na de installatie handmatig in met een vast ip-adres. Misschien dat je hier nog zelf de dns-server-adressen van essent moet instellen.

    Op de pc's die op de hub zijn aangesloten stel je de netwerkverbinding in en geef je adressen van de dns-servers van essent in.

    Als je de server hebt geinstalleerd en de eerste pc hebt ingesteld kijk je (vanaf je server omdat vanaf de pc internet nog niet werkt) even op http://www.nedlinux.nl/~bart voor een leuke masquerading firewall. Neem voor het gemak heel even het makkelijke script, pas dit aan aan je eigen situatie en draai het een keer.

    Als je dat gedaan hebt he je nog geen firewall, maar zit je wel al relatief veilig, omdat je netwerk achter je server onzichtbaar is voor de buitenwereld.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.