Vraag & Antwoord

OS Linux

SuSE 8.1 Prof USB probleem op Dual Pentium III

3 antwoorden
  • Wegens de problemen met Partition Magic 8.0 in topic http://forum.computertotaal.nl/phpBB2/viewtopic.php?t=75312 is mijn Athlon XP 1700+ niet langer mijn hoofd computer, maar mijn Dual Pentium III 1000 Mhz met 512 MB RAM. In plaats van die 28,5 GB harddisk, heb ik een nieuwe 80 GB harddisk geïnstalleerd. Nu heb ik op deze Dual Pentium III geïnstalleerd: WinXP Prof, SuSE 8.0 Prof, SuSE 8.1 Prof, Redhat 8.0, Mandrake 9.0 en Slackware 8.1 Het merkwaardige is dat SuSE 8.1 Prof tijdens het installeren, de USB muis goed werkt, maar nadat de packages geïnstalleerd zijn, en de PC gereboot moet worden, werkt USB niet meer. Zowel de USB muis en de USB zip drive werken niet. :( Mijn dmesg | grep usb output in SuSE 8.1 Prof: [code:1:17a19c715d] jolo@node1048e:~> dmesg | grep usb usb.c: registered new driver usbdevfs usb.c: registered new driver hub usb-uhci.c: $Revision: 1.275 $ time 14:31:44 Sep 13 2002 usb-uhci.c: High bandwidth mode enabled usb-uhci.c: USB UHCI at I/O 0xb400, IRQ 5 usb-uhci.c: Detected 2 ports usb.c: new USB bus registered, assigned bus number 1 usb-uhci.c: USB UHCI at I/O 0xb000, IRQ 5 usb-uhci.c: Detected 2 ports usb.c: new USB bus registered, assigned bus number 2 usb-uhci.c: v1.275:USB Universal Host Controller Interface driver usb_control/bulk_msg: timeout usb.c: USB device not accepting new address=2 (error=-110) usb_control/bulk_msg: timeout usb.c: USB device not accepting new address=3 (error=-110) usb_control/bulk_msg: timeout usb.c: USB device not accepting new address=4 (error=-110) usb_control/bulk_msg: timeout usb.c: USB device not accepting new address=5 (error=-110) jolo@node1048e:~> [/code:1:17a19c715d] Daarentegen in SuSE 8.0 Prof werken zowel de USB muis en de USB zip drive wel goed. De dmesg | grep usb output van SuSE 8.0 Prof ziet er dan ook heel anders uit: [code:1:17a19c715d] jolo@linux:~> dmesg | grep usb usb.c: registered new driver usbdevfs usb.c: registered new driver hub usb-uhci.c: $Revision: 1.275 $ time 14:22:59 Mar 27 2002 usb-uhci.c: High bandwidth mode enabled usb-uhci.c: USB UHCI at I/O 0xb400, IRQ 5 usb-uhci.c: Detected 2 ports usb.c: new USB bus registered, assigned bus number 1 usb-uhci.c: USB UHCI at I/O 0xb000, IRQ 5 usb-uhci.c: Detected 2 ports usb.c: new USB bus registered, assigned bus number 2 usb-uhci.c: v1.275:USB Universal Host Controller Interface driver usb.c: USB device 2 (vend/prod 0x59b/0x32) is not claimed by any active driver. usb.c: registered new driver usb-storage usb-uhci.c: interrupt, status 3, frame# 1656 usb.c: USB device 4 (vend/prod 0x46d/0xc207) is not claimed by any active driver . usb.c: registered new driver hiddev usb.c: registered new driver hid usb_control/bulk_msg: timeout input0: USB HID v1.00 Joystick [Logitech Inc. WingMan Extreme Digital 3D] on usb 1:4.0 usb-uhci.c: interrupt, status 3, frame# 993 input1: USB HID v1.10 Mouse [Microsoft Microsoft Wireless Intellimouse Explorer® 1.0A] on usb1:5.0 usb-uhci.c: ENXIO 84000480, flags 0, urb dfe3f440, burb dfe3f140 usb-uhci.c: ENXIO 84000480, flags 0, urb dfe3f440, burb dfe3f140 usb-uhci.c: ENXIO 84000580, flags 0, urb dfe3f140, burb dfe3f440 usbdevfs: USBDEVFS_CONTROL failed dev 5 rqt 128 rq 6 len 9 ret -6 usb-uhci.c: ENXIO 84000480, flags 0, urb dfe3f940, burb dfe3f440 usb-uhci.c: ENXIO 84000480, flags 0, urb dfe3f940, burb dfe3f440 jolo@linux:~> [/code:1:17a19c715d] :roll:
  • Er zijn 3 HCI controllerdriver varianten, nl UHCI, OHCI en UHCI_ALT. Misschien dat je nu de verkeerde hebt geladen? Probeer eens rmmod usb_uhci (wil dit niet, unload dan eerst de modules die dit gebruiken, maar onthoud welke dit zijn want hierna moet je ze weer loaden), en dan modprobe usb_uhci_alt, of als die niet werkt modprobe usb_ohci. Dit is een wilde gok, het kan ook zijn dat er gewoon een module niet geladen is voor je USB. Werkt het niet, post dan even een dump van lsmod.
  • Dit is mijn lsmod | grep usb in SuSE 8.1 Prof [code:1:4c74b64e0f] jolo@node1048e:~> /sbin/lsmod | grep usb usb-uhci 24428 0 (unused) usbcore 64800 1 [snd usb-uhci] jolo@node1048e:~> [/code:1:4c74b64e0f] Dit is mijn lsmod | grep usb in SuSE 8.0 Prof [code:1:4c74b64e0f] jolo@linux:~> /sbin/lsmod | grep usb usb-storage 48416 0 usb-uhci 21988 0 (unused) usbcore 57184 1 [usb-storage usb-uhci] jolo@linux:~> [/code:1:4c74b64e0f] Ik ga er vanuit dat usb-uhci wel de goede is, want het werkt tenslotte in SuSE 8.0 Prof. Het moederbord in die Dual Pentium III is een Asus CUV4X-D

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.