Vraag & Antwoord

OS Linux

yast online update geeft verkeerde versies kdelibs3 aan

3 antwoorden
  • Ik wil enkele programma's updaten/installeren maar loop daarbij aan tegen een dependencies kwestie van kdelibs3 en qt3. Het wonderlijke daarbij is dat ik onlangs de security update heb uitgevoerd via yast die enkele kde bestanden op 3.05 bracht. Nu geeft Yast online udate aan dat ik kdellibs 3.0.5-0 heb geinstalleerd doch dat er een nieuwere versie 3.0.4-5 is. Hoe kan dit? Ook via apt-get lukt het me niet e.e.a te corrigeren. Wat nu te doen?
  • Bekend probleem met YOU, SuSE gooit de boel telkens door elkaar. Wat je moet doen? Tja, wat wil je doen? KDE 3.045 hoef je niet te installeren, aangezien je KDE 3.05 al hebt. Als je andere KDE-programma's wilt installeren, dan kun je waarschuwingen over versieconflicten/dependencie-problemen inzake kdelibs en qt negeren. Onthoud daarbij dat de hele kde 3.0x-reeks binair compatible met elkaar zijn. Max
  • Max, Bedankt voor je reactie. Via apt-get kun je dependencies repareren doch dit gaat wat al te drastisch: linux:/home/ben # apt-get -f install Reading Package Lists... Done Building Dependency Tree... Done Correcting dependencies... Done The following packages will be REMOVED: k3b kde kde2-compat kdeaddons3 kdeadmin3 kdeartwork3 kdebase3 kdebase3-SuSE kdebase3-nsplugin kdegames3 kdegraphics3 kdegraphics3-kooka kdelibs3 kdemultimedia3 kdenetwork3 kdepim3 kdetoys3 kdeutils3 kdirstat kinternet koffice koncd liquid pixieplus-kde susehelp susehelp_en susehelpcenter 0 packages upgraded, 0 newly installed, 27 removed and 376 not upgraded. Need to get 0B of archives. After unpacking 213MB will be freed. Do you want to continue? [Y/n) Heffen de problemen met de dependencies met het verschijnen en installeren over enkele weken van kde 3.1 zichzelf op of moet ik er mee leren leven? Toch wel erg lastig als je bij iedere installatie van een programma ermee geconfronteerd wordt.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.