Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Slackware Current

Marcel de Reus
40 antwoorden
  • Hallo,

    ik had me voorgenomen Slackware 8.1 te installeren en dan KDE 3.1 RC te installeren, maar nu zie ik dat de current deze al bevat.
    Nu is de vraag hoe installeer ik Slackware current, ik kan dat anmelijk nergens vinden :(
    Wie kan mij ff helpen? Thnx
  • ISO's van -current zijn hier te vinden: ftp://ftp.kpn.be/pub/linux/slackware/current-iso/

    Zelf heb ik ook probleemloos current gedraait, met gcc 3.2.x er sweet, daarom denk ik dat ik binnenkort weer naar -current over ga.
  • Overigens bevatten deze ISO's geen KDE & Gnome, dus het handigst is de nieuwste ISO te gebruiken en daarna de RC KDE packages downloaden uit -current en die met installpkg/upgradepkg installeren.
  • Idd vooral GCC 3.x en KDE 3.1 boeien me erg in de current.
    Maar er is een prob BTW, KDE 3.1 staat niet in de current FTP tree.
    En www.slackware.org is hier onbereikbaar :(
    Dus ik pak ftp.nluug.net en daar staat ie iig nog niet.
  • kijk op ftp.kpn.be eens in
    /pub/linux/slackware/slackware-current/extra/kde-3.1rc5
  • Bamboe en danieldk beide bedankt voor jullie snelle antwoorden.
    Ik ga hem vandaag of anders morgen installeren.

    Zat BTW te denken aan of het niet mogelijk was om Slackware voor i686 te optimaliseren.
    Het moet natuurlijk wel kunnen, maar hoe maak je Slack binaries die de install gebruikt?
    Kun je die niet gewoon compilen met CFLAFS en CXXFLAFS en vervolgens op de CD zetten?
    Verder wil ik iig mijn eigen gebakken 2.4.20 kernel erin zetten, maar die kan ik pas pakken in Slack zelf vanwege GCC 3.x
    Nu weet ik wel hoe ik een kernel bak enz, maar hoe zit dat met de dingen die ik als module meeneem? Waar blijven die?
    En hoe haal ik de dan overbodige Slack 2.4.18 modules eruit? die uit de rc.d file?
  • [quote:f3b99c1c96="Marcel de Reus"]
    Zat BTW te denken aan of het niet mogelijk was om Slackware voor i686 te optimaliseren.
    [/quote:f3b99c1c96]

    Dat lijkt me zinloos. De snelheidswinst is met normale software verwaarloosbaar, alleen voor decoders als Xine en MPlayer en misschien KDE is het zinvol.

    Nu weet ik wel hoe ik een kernel bak enz, maar hoe zit dat met de dingen die ik als module meeneem? Waar blijven die?


    /lib/modules/x.y.z waarin x.y.z de kernel versie is. Op zich kun je oude modules gewoon laten staan, ze nemen weinig ruimte in en worden niet gebruikt (de directory met de huidige kernelversie wordt automatisch gebruikt).
  • Misschien zinloos maar het gaat om het idee (ik moet toch wat doen :D ).
    Ik weet BTW dat het wel degelijk verschil maakt tov i386, zeker omdat je ook nog eens een optimalisatie gebruikt. Ik wil gewoon graag het max uit het systeem trekken en het lijkt me ook wel leuk en niet moeilijk om te doen.

    Dat de modules in /lib/modules/2.4.20 komen te staan wist ik wel want dat staat netjes in de kernel documentatie, maar ik snap dus niet hoe ik dan ervoor zorg dat mijn rc.modules netjes leeg wordt met alleen mijn modules erin.
  • [quote:dd401b5de1="Marcel de Reus"]Misschien zinloos maar het gaat om het idee (ik moet toch wat doen :D ).
    [/quote:dd401b5de1]

    Dan weet ik wel wat beters, Slackware docu voor NedSlack schrijven ;).

    [code:1:dd401b5de1]
    Ik weet BTW dat het wel degelijk verschil maakt tov i386, zeker omdat je ook nog eens een optimalisatie gebruikt.
    [/code:1:dd401b5de1]

    Nee, er is laatst een onderzoek naar gedaan. Bij normale applicaties is de snelheidswinst marginaal (ik geloof 1 a 2%), terwijl je met optimalisatie de kans op instabiliteit van applicaties wel vergroot.

    [quote:dd401b5de1]
    Dat de modules in /lib/modules/2.4.20 komen te staan wist ik wel want dat staat netjes in de kernel documentatie, maar ik snap dus niet hoe ik dan ervoor zorg dat mijn rc.modules netjes leeg wordt met alleen mijn modules erin.[/quote:dd401b5de1]

    Voor vrijwel alle modules staat een commentaarteken en worden dus standaard niet geladen. Je kunt modules te laden door het '#' teken voor de desbetreffende regel weg te halen. Normaliter wordt alleen 'ide-scsi' geladen (voor als je de ide-scsi parameter meegeeft voor een IDE drive) en de module voor de netwerkkaart die tijdens de installatie gedetecteerd is.
  • OK, ik wil best Nederlandse docu schrijven als ik wat vertrouwder ben met Slackware ben. De distro spreekt me bijzonder aan moet ik zeggen.
    Heb je BTW een link naar dat onderzoek? Altijd interessant natuuurlijk :D
    Als dat dus zo is is het idd verspilde moeite al schijnen dingen als KDE toch echt aanmerkelijk sneller te gaan en is ook een geoptimaliseerde kernel toch behoorlijk sneller (dat is mij verteld dan hè).

    Idd modules worden standaard niet geladen (gelukkig niet zeg), maar ik bedoel dus dat ik mijn 2.4.20 modules daar wil hebben en niet de 2.4.18 Slackware modules.

    BTW goed dat je op die netwerkaart terugkomt, ik heb namelijk een Sitecom PCI Fast Ethernet Card en nu heb ik Slackware 8.0 en 8.1 wel eens eerder geïnstalleerd, maar hij zegt tijdens de etho config dan dat ie een heel weirde module gebruikt: 1.002bab oid. Ik dacht dat kan niet kloppen dus heb die autoconfig afgeknalt en zelf gewoon de goede Realtek RTL module gepakt, maar dan werkt mijn netwerk niet :(
    Of moet je nog meer veranderen om de module na? De rest heb ik wel gewoon ingesteld met die autoconfig:
    DHCP
    hostname: css
    geen speciefieke DHCP hostname
    en als FQDN: www.chimeraprojects.org al snap ik het nut daarvan niet echt aangezien ik helemaal geen domein naam hen en zeker niet host op deze PC??????

    eth0 is gewoon mijn kaart naar mijn kabelmodem en krijgt zijn IP dus altijd via DHCP.
    Waarom BTW staan de modules etc niet gewoon in modules.conf en de eth0 opties ed niet in ifconfig maar staat alles in rc.d?
    Daar snap ik het nut namelijk niet helemaal van.

    BTW bedankt voor al je snelle en bruikbare hulp. Slackware ISO-current is net klaar met downloaden en ook de KDE en KDEi map zijn binnen dus ik kan morgen het zooitje installeren en configgen.
  • [quote:6a80367d3d="Marcel de Reus"]Heb je BTW een link naar dat onderzoek? Altijd interessant natuuurlijk :D
    [/quote:6a80367d3d]

    Nope, het stond tijdens de opkomst en enthousiastme rondom Gentoo op een aantal nieuwssites.

    [quote:6a80367d3d]
    Idd modules worden standaard niet geladen (gelukkig niet zeg), maar ik bedoel dus dat ik mijn 2.4.20 modules daar wil hebben en niet de 2.4.18 Slackware modules.
    [/quote:6a80367d3d]

    Maak je maar geen zorgen, gaat automatisch ;).

    BTW goed dat je op die netwerkaart terugkomt, ik heb namelijk een Sitecom PCI Fast Ethernet Card en nu heb ik Slackware 8.0 en 8.1 wel eens eerder geïnstalleerd, maar hij zegt tijdens de etho config dan dat ie een heel weirde module gebruikt: 1.002bab oid. Ik dacht dat kan niet kloppen dus heb die autoconfig afgeknalt en zelf gewoon de goede Realtek RTL module gepakt, maar dan werkt mijn netwerk niet :(
    …snip…


    Daar moet maar even een netwerkkaartenexpert op reageren ;).

    [quote:6a80367d3d]
    en als FQDN: www.chimeraprojects.org al snap ik het nut daarvan niet echt aangezien ik helemaal geen domein naam hen en zeker niet host op deze PC??????
    [/quote:6a80367d3d]

    Tsja, klopt, maar veel software (o.a. apache) vinden het prettig een hostnaam te hebben, ik zou me er niet teveel zorgen over maken.

    [quote:6a80367d3d]
    Waarom BTW staan de modules etc niet gewoon in modules.conf en de eth0 opties ed niet in ifconfig maar staat alles in rc.d?
    Daar snap ik het nut namelijk niet helemaal van.
    [/quote:6a80367d3d]

    Slackware heeft een compleet andere manier van initialiseren. Het gebruikt namelijk geen SysV init scripts, maar BSD Style init scripts. Peter Kaagman (Bilbo) heeft er een aardig document over geschreven: http://www.nedlinux.nl/~bilbo/slack_init/index.html De manier waarop Slackware modules configureerd komt (denk ik) uit twee zaken voort: ten eerste omdat het BSD style is, ten tweede omdat het geen automatische module lader gebruikt. De Slackware methode is gewoon recht toe recht aan modules proben, zonder allerlei ingewikkelde constructies. Veel long-time Linux gebruikers zweren bij de BSD-Style init scripts van Slack, ondanks het feit dat ze soms een andere distro gebruiken.
  • Ik ben nu het doc van Bilbo aan het lezen, thnx voor de link.

    Nu dus wachten op de netwerkexpert :D

    // BTW
    Als dat automatisch gaat hoe zie je dat dan? Ik had namelijk de 2.4.20 gecompiled, maar er stonden nog steeds 2.4.18 modules in rc.modules.
    Worden daar dan automatich nieuwe modules toegevoegd en andere automatisch naar de nieuwe modules gelinkt?
  • Een "make clean" zou alle oude zooi op moeten ruimen, dacht ik.
  • [quote:97de8c1929="water"]Een "make clean" zou alle oude zooi op moeten ruimen, dacht ik.[/quote:97de8c1929]

    Ah, thnx voor de tip ik ga het dadelijk gelijk ff proberen op mijn 8.1 install voordat ik de current ga installeren, als het dan misgaat maakt het niet uit :D
  • Nu alles draait fijn en wel, dwz KDE draait.
    Het si echt veel sneller dan SuSE, maar ik heb ook nog een zee van vragen te beginnen met deze:

    1. Waar vind ik de logfile van alle output bij het opstarten? Ik kan het namelijk niet lezen, want het gaat te snel.

    2. Mijn geluid doet het niet, KDE geeft zoiezo al de error dat /dev/dsp niet geopend kan worden maar ook modprobe emu10k1 geeft een error teruh terwijl dat wel de juiste module is.

    3. Mijn beeld staat wel op 1280x1024 maar aan de linkerkant is er een zwart stuk van ongeveer een centimeter in X.

    4. De lettertypes zien er heel slecht uit, anti-aliasing staat wel aan volgens KDE en ik heb ook de 100dpi fonts meegenomen.

    5. De klok staat een uur te ver, terwijl de config wel klopt.

    Als iemand me hier mee kan helpen, thnx.
    Verder werkt er nog niks maar daar moet ik nog mee aan de slag. Ik heb helaas een tijdgebrek, want de 29ste moet alles vlekkeloos werken en ik ben de 20ste t/m de 27ste op vakantie.
    Alles moet dus vandaag, morgen en de 28ste zo ongeveer.
  • 6. Waar haal ik KDE 3.1 current dan vandaan, want bij ftp.kpn.be hebben ze hem niet, hij draaid nu dus 3.05 uit de current tree

    7. Waarom is www.slackware.org nu al twee dagen down?

    #2: Ik heb nu de drie alsa pakketten gecompiled, maar zo'n beetje alle modules ook die met slackware meegeleverd werden geven een insmod terug, grote bug in current misschien?
    Iig alleen modprobe snd-emu10k1 geeft geen error, maar geeft helemaal geen output, hoort dat?
    In de Alsa howto staat dat ik snd-card-emu10k1 nodig heb maar die geeft wederom een insmod terug.

    5#: Ik kan in Slackware alleen /etc/hardwareclock en /etc/localtime vinden en beide staan goed. Snap er niks van
  • 1. De belangrijkste logfiles staan in /var/log

    2. Als modprobe emu10k1 geen output geeft, maar lsmod 'm wel toont, dan is het in orde.

    3. Kan dat dan niet via de monitor ingesteld worden? Hoeveel inch is je monitor?

    4. Hier vind ik dat het er wel mee door kan. Op een oude 15 inch monitor (1995)

    5. Bij mij staat die klok current time zone op CET en in Slackware 8.1 geeft deze de zelfde tijd aan als in de BIOS. En dus ook de zelfde tijd als in WinXP. :)

    [update] vervolg 2. Maar als je dan dmesg | grep emu10k1 typt, behoort er wel info over je soundcard worden getoont.
    [code:1:c6739fd2da]
    root@linux:~# dmesg | grep emu10k1
    emu10k1: Audigy rev 3 model 0x0051 found, IO at 0xd800-0xd81f, IRQ 10
    root@linux:~#
    [/code:1:c6739fd2da]
  • [quote:8de621a2c1="Marcel de Reus"]6. Waar haal ik KDE 3.1 current dan vandaan, want bij ftp.kpn.be hebben ze hem niet, hij draaid nu dus 3.05 uit de current tree[/quote:8de621a2c1]

    ftp.slackware.com

    [quote:8de621a2c1]
    7. Waarom is www.slackware.org nu al twee dagen down?
    [/quote:8de621a2c1]

    www.slackware.com is het doelwit geworden van een DoS aanval, er wordt aangewerkt de site zo snel mogelijk weer draaiende te krijgen.
  • 1. Idd maar welke is voor het complete boot overzicht, die kan ik namelijk niet vinden.

    2. Hier ga ik mee aan de slag, maar waarom geven alle modules dan een insmod, ook de meegeleverde?

    3. Tuurlijk kan dat maar dan loopt mijn console het venster uit. Philips 109S 19inch.

    4. Het kan er absoluut niet mee door, bij SuSE is het wel goed dus er moet een oplossing voor zijn.

    5. Wat WinXP aangeeft weet ik niet, want dat gebruik ik niet, maar SuSE geeft het wel goed aan, met dezelfde config.

    6. ik ga hem nu ff halen

    7. rotstreek

    Ik wordt dus een beetje gek van dat geklooi met die module errors vooral omdat de tijd echt begint te dringen. Het moet toch een bekend probleem zijn?
  • 2#: module geeft geen info over souncard en werkt dus niet

    3#: fixed

    5#: BIOS staat dus op local time, dus /etc/hardwareclock moet wat bevatten? Er staat nu UTC?

    6#: ftp.slackware.com heeft ook gewoon KDE 3.05 in de current map hoor, is KDE 3.1 er al wel in een Slackware current-tree?
    [edit]found it[/edit]

    Ik ga vanavond ff reïnstallen met KDE 3.1RC5 en dan hoop ik dat er wat problemen verdwijnen.
    Dit heb ik iig gevonden: http://www.alsa-project.org/alsa-doc/doc-php/template.php3?company=Creative+Labs&card=Soundblaster+Audigy+Platinum&chip=Audigy&module=emu10k1
    Ik heb de 3 0.90RC6 packages gedownload en die ga ik dus installeren, maar ze gaan iets aanmaken in /etc/modules.conf en dat kan niet goed gaan denk ik?
    Wat moet ik doen om dit onder Slackware te draaien?

    Heb ik hier nog wat aan: http://www.opensound.com/linux-x86.html ???
    Of gebruik ik geen OSS?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.