Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[Mandrake 9.0] libc 6.2 en Ati-drivers installeren

None
28 antwoorden
  • Hoi, net voor het eerst Linux geinstalleerd en nu al een probleem :

    Om de juiste videokaart driver geinstalleerd te krijgen moet ik mn libc (weet nie wat het is maar goed) updaten naar versie 6.2, heb echter geen idee hoe. Gezocht op meerdere sites en Google maar heb de juiste info niet kunnen vinden.

    Ik gebruik dus Mandrake 9.0.

    T.i.a
  • [quote:e789a2f1a4="Linux Noobie"]Hoi, net voor het eerst Linux geinstalleerd en nu al een probleem :[/quote:e789a2f1a4]
    problemen kennen we hier niet, alleen uitdagingen ;)
    [quote:e789a2f1a4]
    Om de juiste videokaart driver geinstalleerd te krijgen moet ik mn libc (weet nie wat het is maar goed) updaten naar versie 6.2, heb echter geen idee hoe. Gezocht op meerdere sites en Google maar heb de juiste info niet kunnen vinden.

    Ik gebruik dus Mandrake 9.0.
    [/quote:e789a2f1a4]

    Hmm, raar probleem (ahum, rare uitdaging ;) )
    Dat je geen info kunt vinden over libc6 klopt, deze heet nmlk glibc2. Gezien het feit dat je een vrij recente distro gebruikt zou je zeggen dat je libc-versie recent genoeg moet zijn.
    Waar haal je die ati-driver vandaan?
    hoe meldt deze driver dat hij niet de juiste libc-versie kan vinden?

    Max
  • http://mirror.ati.com/support/drivers/linux
    adeon-linux.html?cboOS=LinuxXFree86&cboProducts=RADEON+9700+PRO&eula=&choice=agree&cmdNext=Next

    Da's de link dus, als ik dus die Check.sh run die op die pagina staat krijg ik een melding dat ik een lib niet heb zal ff rebooten in Linux en de exacte foutmelding opzoeken.
  • Die link is idd de goede.


    Ik heb in Mandrake 9 met een Radeon 9000 van Connect3d (powered by ATI) getest met ATI drivers in deze topic. :roll:
  • Zo ben ik weer duurde ff want in Linux kan ik hier nie inloggen ???

    fout melding: (heel verhaal)

    Checking which OS you're running uname reports 'Linux' version '2.4.19-16mdk', architecture 'i686'
    Object format is 'ELF'.
    Check.sh: line1: strings: command not found

    XFree86 Version 4.2.1 is installed.
    No Linux/ix86 binaries for this libc version

    Heeft het te maken met het feit dat de drivers for i586 zijn en ik volgens dit een i686 ?

    p.s. ff mn specs er maar bij misschien handig :

    AMD XP2400+@ Asus A7V-266
    2x 256 mb Dane Elec 256mb PC2100
  • [quote:04ea1ee6f3="Linux Noobie"]Zo ben ik weer duurde ff want in Linux kan ik hier nie inloggen ???[/quote:04ea1ee6f3]
    Dat zou niet best zijn, want dan kan niemand hier posten :P
    Met welke browser surf je?
    [quote:04ea1ee6f3]

    fout melding: (heel verhaal)

    Checking which OS you're running uname reports 'Linux' version '2.4.19-16mdk', architecture 'i686'
    Object format is 'ELF'.
    Check.sh: line1: strings: command not found

    XFree86 Version 4.2.1 is installed.
    No Linux/ix86 binaries for this libc version
    [/quote:04ea1ee6f3]
    Even de site gecheckt, en wat ik begrijp is dat je een apart progje hebt gebruik om je systeem te checken.
    Dat progje is abuis, je hebt zeer zeker glibc2 geinstalleerd, zoals de site aangeeft. Installeer dus gewoon de driver zonder de check.
    [quote:04ea1ee6f3]

    Heeft het te maken met het feit dat de drivers for i586 zijn en ik volgens dit een i686 ?
    [/quote:04ea1ee6f3]
    nee, dat staat er los van. als jouw pc een i686 is, dan kun je software gebruiken bedoeld voor i386, i486, i586, en i686. Kies altijd de hoogste die wordt aangeboden, deze zijn nmlk sneller..


    Ik ga er van uit dat het controleprogramma niet grondig werkt, waardoor hij geen libc6 kan vinden op je systeem. Geloof me, die heb je wel, zonder libc6 werkt je linux-installatie nmlk helemaal niet :)

    Max
  • Als ik de drivers wil installeren krijg ik de volgende foutmelding :

    file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-glc22-4[1].2.0-2.5.1.i586.rpm conflicts with file from package Xfree86-libs-4.2.1-3mdk

    En ik gebruik Mozilla als browser, echter als ik op login wil klikken krijg ik geen reactie.

    (Voel me net als iemand die voor het eerst achter een pc zit)
  • [quote:13afc348ad="maximilaan"]
    Even de site gecheckt, en wat ik begrijp is dat je een apart progje hebt gebruik om je systeem te checken.
    Dat progje is abuis, je hebt zeer zeker glibc2 geinstalleerd, zoals de site aangeeft. Installeer dus gewoon de driver zonder de check.
    [/quote:13afc348ad]
    Tja, eigenlijk is de melding van Check.sh wel belangrijk.
    Dit behoort Check.sh te tonen:
    [code:1:13afc348ad]
    [jolo@localhost linux]$ sh Check.sh
    =====================================================================
    ATI Technologies
    =====================================================================
    Checking which OS you're running…
    uname reports 'Linux' version '2.4.19-16mdk', architecture 'i686'.
    Object format is 'ELF'.
    libc version is '6.2'.

    XFree86 Version 4.2.1 is installed.

    Binary package name is 'fglrx-glibc22.tgz'

    [jolo@localhost linux]$
    [/code:1:13afc348ad]
    Hier volgt installatie procedure ATI Linux drivers 2.5.1

    Installeer de kernel-source via rpmdrake
    rpmdrake kun je starten via Configuratie > Pakketen > Install Software. Als je niet als root ingelogt bent wordt hier je wachtwoord gevraagd.
    In het kader naast zoeken type kernel en zoeken. Vink kernel-source en klik op Installeren, als hier een dialoog Extra pakketten benodigd. verschijnt, klik dan op OK. Er wordt om de benodigede Installation CD's gevraagd. Bij mij was dat CD-2, CD-3 en CD-1. Als de kernel-source geïnstalleerd is kun je Check.sh weer laten testen. Als deze test OK is, reboot dan de PC en typ achter de boot:
    [code:1:13afc348ad]
    linux init 3
    [/code:1:13afc348ad]
    Enter
    Log in als root

    Ga naar de map waar je ATI Linux driver staat, en typ
    [code:1:13afc348ad]
    rpm -ivh –force naam van de rpm
    [/code:1:13afc348ad]
    Enter
    Het installeren begint, waaschijnlijk zie je hier wel een warning en een failed voorbij flitsen, deze hoef je niet op te letten.
    Dan verschijnt: Module fglrx loaded with warnings
    ATI display drivers succesfully installed
    please run fglrxconfig now

    Deze fglrxconfig is tekst gebaseerd.
    Let op dat je de gegevens van je monitor niet boven de specificaties invult. :roll:
  • Ja hoor en dan heb ik natuurlijk alleen weer Gnome geinstalleerd, probeer ik KDE te installeren geeft ie aan dat er extra pakketten geinstalleerd moeten worden…. En dan zijn er natuurlijk weer bij die niet gevonden worden…..Al die moeite om een driver te installeren.. Ben het een beetje zat nu, misschien morgen weer.

    1 toevoeging : De mensen hier zijn erg behulpzaam, ben dit anders gewend. Klasse !! ( Blijf denk ik wel proberen hoor ik geef niet zo snel op ;) ).
  • [quote:e48d3cfe62="Linux Noobie"]Ja hoor en dan heb ik natuurlijk alleen weer Gnome geinstalleerd, probeer ik KDE te installeren geeft ie aan dat er extra pakketten geinstalleerd moeten worden…. En dan zijn er natuurlijk weer bij die niet gevonden worden…..Al die moeite om een driver te installeren.. Ben het een beetje zat nu, misschien morgen weer.

    1 toevoeging : De mensen hier zijn erg behulpzaam, ben dit anders gewend. Klasse !! ( Blijf denk ik wel proberen hoor ik geef niet zo snel op ;) ).[/quote:e48d3cfe62]

    Je hoef tkde niet te installeren want ook vanuit Gnome kun je kernel sources installeren.
    Mandrake zal er vast een proggie/onderdeel voor hebben waarmee je software kunt toevoegen :D

    wat je dus moet doen is zorgen dat de kernel-sources en de daarbij behorende pakketten (gaat vanzelf) geinstalleerd worden en dan de uitleg van jolo verder volgen

    Succes

    BTW.
    is het niet logisch dat je elkaar op een forum gewoon helpt zo goed je kunt ??
    Anders heb je toch niets op een forum te zoeken ??
  • [quote:4a21a6c9f3="wstolk"]
    Je hoef tkde niet te installeren want ook vanuit Gnome kun je kernel sources installeren.
    Mandrake zal er vast een proggie/onderdeel voor hebben waarmee je software kunt toevoegen :D
    [/quote:4a21a6c9f3]
    Idd KDE3 heb ik er alleen bij gezet, omdat het mijn favoriet is! Voor Gnome kan de kernel-source op de zelfde manier geïnstalleerd worden. :roll:
  • [quote:a745a3db1f="jolo"][quote:a745a3db1f="wstolk"]
    Je hoef tkde niet te installeren want ook vanuit Gnome kun je kernel sources installeren.
    Mandrake zal er vast een proggie/onderdeel voor hebben waarmee je software kunt toevoegen :D
    [/quote:a745a3db1f]
    Idd KDE3 heb ik er alleen bij gezet, omdat het mijn favoriet is! Voor Gnome kan de kernel-source op de zelfde manier geïnstalleerd worden. :roll:[/quote:a745a3db1f]

    Je had dan ook beter het installatie proggie voor Mandrake (helaas ken ik het niet terwijl mijn dochtertjes wel met mandrake werken/spelen)
    Nu breng je een nieuweling wellicht in verwarring ;)

    dus leg het nog ff uit (met de juiste proggies) dan kan die zo in de howto :D

    installatie ATI drivers onder linux :D
  • Wstolk, je hebt gelijk. Installatie procedure ATI Linux drivers 2.5.1 gewijzigd.
  • Door jullie heb ik er weer zin in :).

    Als ik in rpmdrake echter zoek op kernel krijg ik 3 opties :

    - kernel-enterprise-2.4.19.16mdk-1-1mdk

    - kernel-secure-2.4.19.16mdk-1-1mdk

    - kernel-smp-2.4.19.16mdk-1-1mdk


    Welke moet ik nemen ??
  • [quote:1d0e4a4d1f="Linux Noobie"]
    Welke moet ik nemen ??[/quote:1d0e4a4d1f]
    Geen van drieen.
    Het is: kernel-source
    Als deze er niet bij staat, typ dan eens in een Konsole:
    [code:1:1d0e4a4d1f]
    rpm -qa | grep kernel
    [/code:1:1d0e4a4d1f]
    En post hier de output er van.
  • kernel-headers-2.4.18-41mdk
    kernel-2.4.19.16mdk-1-1mdk

    Dees bedoel je ?
  • Dan is de kernel-source niet geïnstalleerd. En je bent er zeker van dat rpmdrake geen kernel-source toonde?

    Hoe dan ook, het is idd het beste deze uitdaging naar morgen te verplaatsen. :wink:
  • Dit wordt allemaal wel erg ingewikkeld!!
    Moet hij voor het gebruiken van de ATI-driver de boel hercompileren?
    Kan hij niet beter het eerdergenoemde conflict oplossen door xfree 4.1 te verwijderen van zijn pc en de ati-driver te installeren??

    max
  • Goede vraag, de kernel hoeft niet hercompileerd te worden, maar ik kon de ATI driver pas installeren na de kernel-source te hebben geïnstalleerd. Echter er werden ook nog Extra pakketten benodigd geïnstalleerd: binutils-2.12 libbinutils-2.12 libc-devel 2.2.5 en gcc-3.2

    Ik kom hier later op de dag nog wel op terug. De installatie procedure ATI Linux drivers 2.5.1 is nog onder construktie.


    Wordt vervolgd….. :roll:
  • Vervolg….over de installatie procedure ATI Linux drivers 2.5.1 8)

    Indien de kernel-source niet wordt geïnstalleerd, maar gcc-3.2 wel geïnstalleerd wordt met rpmdrake, dan is de test met Check.sh OK.
    De ATI driver kan dan wel geïnstalleerd worden, maar tijdens het installeren van de ATI driver verschijnt:
    [code:1:a966a4dc12]
    [root@localhost jolo]# rpm -ivh –force fglrx-glc22-4.2.0-2.5.1.i586.rpm
    Preparing… ########################################### [100%]
    1:fglrx-glc22 ########################################### [100%]
    *** Trying to install a precompiled kernel module.
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)

    As of now you can still run your XServer in 2D, but hardware acclerated
    OpenGL will not work and 2D grafics will lack performance.

    failed.
    *** Error: no kernel module build environment - please consult readme.
    ===
    ATI display drivers successfully installed
    please run 'fglrxconfig' now
    ===
    [root@localhost jolo]#

    [/code:1:a966a4dc12]
    De ATI video kaart zal dan wel werken in 2D met matige prestaties. OpenGL zal dan niet werken.
    Indien de kernel-source wel geïnstalleerd is, dan verschijnt:
    [code:1:a966a4dc12]
    [root@localhost jolo]# rpm -ivh –force fglrx-glc22-4.2.0-2.5.1.i586.rpm
    Preparing… ########################################### [100%]
    1:fglrx-glc22 ########################################### [100%]
    *** Trying to install a precompiled kernel module.
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)

    As of now you can still run your XServer in 2D, but hardware acclerated
    OpenGL will not work and 2D grafics will lack performance.

    failed.
    *** Found kernel module build environment, generating kernel module now.
    ATI module generator V 2.0
    ==========================
    probing for VMA API version…
    cleaning…
    patching 'highmem.h'…
    patching 'drmP.h'…
    make.sh: line 776: patch: command not found
    compiling 'agpgart_be.c'…
    compiling 'agp3.c'…
    compiling 'i7505-agp.c'…
    compiling 'firegl_public.c'…
    linking of fglrx kernel module…
    duplicating results into driver repository…
    done.
    ==============================
    - creating symlink
    - recreating module dependency list
    - trying a sample load of the kernel module
    Warning: loading /lib/modules/2.4.19-16mdk/kernel/drivers/char/drm/fglrx.o will
    taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
    See http://www.tux.org/lkml/#export-tainted for information about tainted modules
    Module fglrx loaded, with warnings
    done.
    ===
    ATI display drivers successfully installed
    please run 'fglrxconfig' now
    ===
    [root@localhost jolo]#

    [/code:1:a966a4dc12]
    Met deze output is de ATI driver installatie gelukt. Laat je daarbij niet op het verkeerde been zetten door het bovenste deel van deze output.

    Zijn er suggesties of vragen? :roll:

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.