Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

LPR / Samba - Raw printer

Inferno
6 antwoorden
  • Ik heb een Debian 3 server (kernel 2.2.20) met samba en lpr en een canon i550. Ik heb alleen maar Windows clients en was van plan om op deze clients de Windows drivers te installeren en met Linux een raw printer te maken. Mijn configuratiebestanden zien er als volgt uit:

    [size=9:0802ef7593][b:0802ef7593]/etc/printcap[/b:0802ef7593]

    raw:\
    :sd=/var/spool/lpd
    aw:\
    :mx#0:\
    :sh:\
    :lp=/dev/lp0:

    [b:0802ef7593]/etc/samba/smb.conf[/b:0802ef7593]

    [global]
    workgroup = Klarenbeek
    server string = Samba Server
    load printers = yes
    printcap name = /etc/printcap
    printing = bsd
    invalid users = root
    max log size = 1000
    syslog = 0
    security = share
    encrypt passwords = true
    socket options = TCP_NODELAY
    dns proxy = no
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n
    *Retype\snew\sUNIX\spassword:* %n
    .
    obey pam restrictions = yes

    [printers]
    comment = All Printers
    path = /var/spool/lpd/lp
    browseable = no
    printable = yes
    public = yes
    writable = no
    create mode = 0700

    [canoni550]
    path = /var/spool/lpd
    aw
    printer name = raw
    writable = yes
    public = yes
    printable = yes
    print command = lpr -b -Praw %s[/size:0802ef7593]

    Als ik dit onder Windows test krijg ik de volgende melding:

    Fout bij het schrijven naar \\ROBBERT\canoni550
    Er was een probleem bij het afdrukken als gevolg van een onbekende systeemfout.

    Wat doe ik verkeerd?

    Bedankt,
    Inferno



  • Ik had hetzelfde en dat werdt verholpen door lp1 te verbinden met de sambaspooler
  • Hoe doe ik dat?
  • in windows =>
    printers=>eigenschappen van je sambaprinter => tabblad [details] => printerpoort toewijzen
  • Werkt niet. Die foutmelding heb ik er nu uit. Nu gebeurt er gewoon niets als ik een printopdracht geef (tenminste, in windows lijkt het alsof het gelukt is, maar in linux gebeurt niets). In mijn logbestandjes ook niks te vinden. Nog suggesties?
  • Heb je al geprobeerd om de regel "print command = " weg te halen? Meestal is het voldoende om de regel "Printing = " correct in te stellen.

    Succes

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.