Vraag & Antwoord

OS Linux

[XFree] ACPI /APM en toetsenbord

11 antwoorden
  • Even twee stukjes uit de log van XFree: [code:1:c712c1e5e3] (WW) Open APM failed (/dev/apm_bios) (No such file or directory) [/code:1:c712c1e5e3] en [code:1:c712c1e5e3](**) XKB: rules: "xfree86" (**) XKB: model: "pc105" (**) XKB: layout: "en_US" (**) XKB: options: "grp:lwin_switch,lv3:switch,caps:internal,altwin:menu" Couldn't load XKB keymap, falling back to pre-XKB keymap [/code:1:c712c1e5e3] De problemen zijn dat het powermanagement niet werkt als X draait en mijn dode toetsen doen het niet. Kan het zijn dat XFree niet overweg kan met ACPI en dat ik dus moet switchen naar APM? En hoe krijg ik mijn toetsenbord fatsoenlijk werkende? Het betreft een compaq internet-toetsenbord met een ps/2 kabeltje.
  • Hier in Mandrake 9.0 gebruik ik US Internationaal toetsenbord indeling. [code:1:ac6ba03b2c] (**) |-->Input Device "Keyboard1" (**) Option "XkbModel" "pc105" (**) XKB: model: "pc105" (**) Option "XkbLayout" "us_intl" (**) XKB: layout: "us_intl" (WW) Option "XkbOptions" requires an string value (==) Keyboard: CustomKeycode disabled [/code:1:ac6ba03b2c] Wat voor een toetsenbord indeling heb je dan opgegeven in Configuratiecentrum > Invoerappaten > Toetsenbord? En wat toont bij jouw dmesg | grep apm [code:1:ac6ba03b2c] [jolo@node1048e jolo]$ dmesg | grep apm apm: BIOS version 1.2 Flags 0x0b (Driver version 1.16) [jolo@node1048e jolo]$ [/code:1:ac6ba03b2c] Dit is uit /var/log/XFree86.0.log [code:1:ac6ba03b2c] (II) Open APM successful [/code:1:ac6ba03b2c] Wat is het probleem? Gaat (na enige tijd je toetsenbord of muis niet te hebbeb gebruikt) jouw monitor in Linux niet naar de spaarstand? :roll:
  • Ik heb ACPI in de kernel zitten en geen APM en mijn monitor gaat idd niet in de spaarstand. In console overigens wel. In KDE heb ik voor het toetsenbord VS/Engels met dode toetsen opgegeven. Ik vraag mij alleen af of de instellingen van XFree dan overruled worden. Maar ik kan dus geen e met puntjes typen.
  • Dit heb ik even getest, deze keer in SuSE 8.1 De instellingen in /etc/X11/XF86Config worden idd overruled door de toetsenbord indeling in KDE Configuratiecentrum. Ik kan hier wel een e maken met puntjes ë of é Bij mandrake 9.0 kan de toetsenbord indeling worden opgegeven tijdens de installatie. Deze staat dan in de /etc/X11/XF86Config ACPI wordt bij mij gebruik in SuSE 8.1 Volgens deze output dan: [code:1:e69bbc8eb1] jolo@linux:~> dmesg | grep apm apm: BIOS version 1.2 Flags 0x0b (Driver version 1.16) apm: overridden by ACPI. jolo@linux:~> [/code:1:e69bbc8eb1] :roll:
  • En wat staat er bij jou in de log van XFree?
  • Toetsenbord in SuSe 8.1 [code:1:d7360006b8] (**) |-->Input Device "Keyboard[0]" (**) Option "Protocol" "Standard" (**) Option "XkbRules" "xfree86" (**) XKB: rules: "xfree86" (**) Option "XkbModel" "pc101" (**) XKB: model: "pc101" (**) Option "XkbLayout" "us" (**) XKB: layout: "us" (==) Keyboard: CustomKeycode disabled [/code:1:d7360006b8] APM in SuSE 8.1 [code:1:d7360006b8] (WW) Open APM failed (/dev/apm_bios) (No such device) [/code:1:d7360006b8]
  • Instellingen van het toetsenbord ga ik maar eens aanpassen. Werkt het powermanagement wel bij jou in KDE?
  • In KDE werkt powermanagement wel. Dit staat ingesteld in KDE Configuratiecentrum > Energiebeheer > Energie. Energiebesparing voor de monitor inschakelen In SuSE 8.1 KDE 3.05 In wachtstand na: 10 min In slaapstand na: 20 min Uitschakeling na: 30 min
  • Zelfs een ander toetsenbord helpt niet en als KDE de instellingen van XFree overruled, wordt het waarschijnlijk erg ingewikkeld. Ik ga morgen is even proberen om een app buiten KDE te starten, kijken of dat scheelt. Verder ga ik morgen ook maar APM in mijn kernel bakken ipv ACPI.
  • Ik ben er inmiddels achter dat het niet laden van XKB de fouten veroorzaakt. In Mandrake (stond ook nog altijd op mijn pc) werkt het wel allemaal keurig. Omdat ik geen XKB heb, worden de instellingen geladen voor een standaard VS-102 toetsenbord. Ik ga de instellingen van Mandrake maar eens overnemen en kijken of dat helpt. Aan gaande ACPI: dat is blijkbaar een kernel-patch en geen standaard, dus waarschijnlijk kan XFree er gewoon niet mee overweg.
  • äëéöòï OK dat werkt, er stond gewoon een verkeerd toetsenbord in XF86Config. :oops: En dan helpt geen lieve KDE-instelling meer. Nu nog mijn powermanagement. Met windowmaker werkt het wel, waarschijnlijk gewoon via het bios. Ik heb hem in KDE uitgeschakeld dus eventjes wachten of die op zwart gaat.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.