Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

netwerk probleem, 2 netwerkkaarten.

None
5 antwoorden
  • Ik heb een linuxserver die ik gebruik voor filesharing (samba) Dit werkte altijd perfect
    maar sinds ik de server ook gebruik als gateway (ik heb eidelijk ADSL!! 8) ) loopt de
    netwerk verbinding met horten en stoten. Als ik bijv een divx filmpje vanaf de server bekijk
    dan komt de stream niet in een comstante stroom binnen waardoor mijn pc steeds op data
    moet wachten. Dit is ZEER frustrerend zodat ik nu eerst de films naar mijn eigen computer
    kopieer. Maar dat is omslachtig en (denk ik) niet nodig.
    Vermoedelijk is de 2e netwerkkaart de oorzaak (die is dus voor de ADSL aansluiting)
    Het gekke is dat de windows machines er vrijwel geen last van hebben.
    Ik heb ook eens de schijf van mijn laptop (winME) gemount en vandaar een filmpje
    bekeken. Toen had ik nergens last van.
    Ik gebruik slackware 8.1 op mijn eigen pc en de server. Mijn pc heeft kernel 2.4.20
    en de server 2.4.19
    Kan iemand mij helpen?

    Alvast bedankt.
  • Gebruikt je Windows-laptop misschien een 10 mb kaart?
    Het kan zijn dat de handshake van de kaarten het probleem oplevert. Als op 1 van de machines de kaart is ingesteld op een vaste snelheid dan is het probleem verholpen.
  • Alle netwerkkaarten bij mij thuis zijn 10/100 mbit.
    Het probleem doet zich alleen voor als ik met mijn linux machine
    gebruik maak van de linux server.
    Als ik met mijn linux machine een gedeelde windows map mount
    (dat is ook gewoon samba) dan heb ik nergens last van. En als
    windows machines van de linux server gebruik maken dan hebben
    die ook nergens last van.
    Dus nogmaals, ik heb het alleen als ik met linux (op mijn eigen pc)
    schijven v/d linux server mount.
    Dat mounten doe ik als volgt:
    mount -t smbfs -o username=mijn_username //Computer_op_afstand/Gedeelde_map /mountpoint_op_mijn_pc
  • bizar,
    heb je de kabel al vervangen? misschien is die wat brak.
  • Om er achter te komen of de tweede netwerkkaart de problemen veroorzaakt, zou je die uit kunnen schakelen. Verder zou ik het eens proberen met een 2.4.19 kernel op je linux-machine, en kijk dan eens goed wat jeallemaal in die kernel hebt gestopt. Met name zake als pre-emtive (of hoe het ook mag heten). Verder kun je met "top'' eens bekijken of bepaalde processen veel resources opvreten.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.