Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[SuSE 8.1] Installatie 3D grafische kaart

c.j.krul
6 antwoorden
  • Voor mijn net geinstalleerde SuSE 8.1 profesional pc moeten de 3D drivers handmatig worden geïnstalleerd.
    Na deze gedownload te hebben op www.nvidia.com en te hebben uitgepakt, volgens de instructies in de readme opnieuw opgestart in runlevel 3 (zonder X).

    Vanuit de direcory NVIDIA_kernel….. het commando make gegeven wat stopt na de volgende error-output:
    [quote:ede80b93cd]cc1: code model `kernel' not supported in the 32 bit mode
    In file included from nv-linux.h:83,
    from nv.c:14:
    /lib/modules/2.4.19-4GB/build/include/linux/highmem.h: In function `bh_kmap':
    /lib/modules/2.4.19-4GB/build/include/linux/highmem.h:22: warning: pointer of type `void *' used in arithmetic
    nv.c: In function `nv_agp_translate_address':
    nv.c:2756: warning: cast from pointer to integer of different size
    make: *** [nv.o] Fout 1[/quote:ede80b93cd]

    Iemand enig idee?
    Dit is de gewone output:
    [quote:ede80b93cd]cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -mcmodel=kernel -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=4180 -DNV_UNIX -DNV_LINUX -DNV_INT64_OK -DNV_64_BITS -DNVCPU_X86_64 -I. -I/lib/modules/2.4.19-4GB/build/include -Wno-cast-qual nv.c
    [/quote:ede80b93cd]

    Ik kan er niet echt veel uithalen :-?
  • Heb je de goede versie gedownload? Er zijn een drietal versies, dacht ik.
  • Hmm, het zou gewoon moeten werken. Download anders gewoon de RPM files van SuSE 8.1
  • [quote:9dcd69b463="Mgompie"]Heb je de goede versie gedownload? Er zijn een drietal versies, dacht ik.[/quote:9dcd69b463]
    Er zijn idd drie versies:
    Linux IA32
    Linux AMD64
    Linux IA64

    Omdat het om een Athlon 1800+ processor gaat, heb ik de 'AMD64' versie download. Is dit niet de goede dan?

    [quote:9dcd69b463="Marcel de Reus"]Hmm, het zou gewoon moeten werken. Download anders gewoon de RPM files van SuSE 8.1[/quote:9dcd69b463]
    RPM files heb ik niet gevonden:
    http://www.nvidia.com/content/drivers/drivers.asp
    Graphics Driver > GeForce and TNT > Linux AMD64
    http://www.nvidia.com/view.asp?IO=linux_display_amd64_1.0-4180

    Of moet ik dan ergens anders zoeken?
  • [quote:030e809c63="c.j.krul"][quote:030e809c63="Mgompie"]Heb je de goede versie gedownload? Er zijn een drietal versies, dacht ik.[/quote:030e809c63]
    Er zijn idd drie versies:
    Linux IA32
    Linux AMD64
    Linux IA64

    Omdat het om een Athlon 1800+ processor gaat, heb ik de 'AMD64' versie download. Is dit niet de goede dan?[/quote:030e809c63]
    IA32 zijn alle 32 bit processoren;
    AMD64 zijn voor de 64 bit processoren van AMD;
    IA64 zijn voor de 64 bit processoren van Intel.

    Probeer de IA32 (i386) versie eens.
  • Je moet idd de i386 hebben, daar staan dus ook SuSE rpm files bij.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.