Vraag & Antwoord

OS Linux

Suse 8.1 en nieuwe progjes

14 antwoorden
  • Ik leef me nu al een aantal weken uit op Suse 8.1 (leuk), maar ik loop toch tegen een aantal zaken aan die ik niet even op kan lossen. Een van die dingen is het installeren van nieuwe progjes. Van alle programma's die ik tot nu toe heb getracht te installeren, werken er twee(!!) De rest vertikt het gewoon en ik kan er geen oorzaak van achterhalen. Ook Suse doet hier met de ondersteuning niets aan, want, zo zeggen zij, het zijn programma's van een ander. Fijn, maar hoe moet het nu verder? Een voorbeeld: ik tracht al enkele dagen Krusader te installeren; allereerst mbv de RPM-versie. YAST installeert het, er komt een koppeling in het menu, maar opstarten dus niet. Het opstarticoontje werkt even en dan niets meer. Een andere RPM-versie geprobeerd; zelfde verhaal. Dan maar met de ingepakte versie geprobeerd (TAR-GZ) . Uitgepakt, met de prompt en in de root in de map gaan staan en ./configure , make en make install uitgevoerd. Jammer dus, na de ene foutmelding opgelost te hebben, komt de volgende, etc. En dat heb ik inmiddels met een aantal progjes zo meegemaakt. Kortom, wat doe ik fout? Overigens valt het me op dat diverse progjes uit het opstartmenu ook niet willen opstarten. Help :roll:
  • Vreemd, ik gebruik al een tijdje SuSe 8.1, maar ben nog geen applicaties tegengekomen die wel in het startmenu staan, maar niet werken. Krusader werkt bij mij overigens ook niet, deze wordt onmiddelijk afgesloten met een segfault. Kun je een idee geven welke applicaties zoal niet werken? mogelijk kunnen we dan alhier uitzoeken waarom dit het geval is.... Max
  • Krusader 1.10 en 1.11(alle versies0 Avifile 7-32-20030219 Kcommander 3.3 pinball -0.1-2.1(installeert wel maar kan geen kast laden) Mplayer09-pre10 showimg 0.8-20021228 Kbiff 3.61-397 Pinsuite 002 (opengl foutmelding) Samba (van de Suse CD) en zo kan ik nog wel even doorgaan (behalve Samba is alles gedownload) Progs die niet werken zijn bijv : video4Linuc, Koffice,Samba wat wel lukte was Limewire en Pixieplus
  • Hm, ik heb krusader 1.10 ook maar even geinstalleerd. Dit programma staat op de SuSE 8.1 Prof DVD, en ook op CD2. Bij mij kan ik dit programma gewoon starten. Avifile 0.77 Kcommander 3.0 Mplayer 0.9 Kbiff 3.6.1 Staan ook op de SuSE 8.1 DVD. Kcommander 3.0 en Mplayer 0.9 kan ik ook starten. Of die programma werken weet ik niet, omdat ik deze programma's niet gebruik. :roll:
  • je bent de eerste van wie ik hoor dat die problemen heeft . een mogelijkheid is om na installatie te updaten met yast , en vervolgens aptget te gebruiken , dit werkt goed voor mij en meer suse software aanwezig dan met yast
  • Wat op zich wel leuk is aan SuSe is wanneer je een applicatie probeert op te starten via Alt+F2 en deze is niet aanwezig, dan wordt YaSt gestart om deze te installeren voor je :) Werkt overigens niet bij alle applicaties.. Het probleem met krusader op mijn systeem lijkt te komen door de installatie van kde 3.1, en de bijhorende qt-versie. Bijt mekaar schijnbaar. Blijkbaar heeft SuSe dat niet zo keurig gedaan (maar ik gebruik dan ook eentje die prematuur is uitgebracht :-? ) Max
  • Ik ben geen SuSe expert maar in elke Linux distro kun je software via source installeren. Je pakt dan het bestand programma.tar.gz Dan pak je die uit: [code:1:d732040fd0]tar zxvf programma.tar.gz[/code:1:d732040fd0] En installeer je die met: [code:1:d732040fd0]cd programma ./configure && make && make install[/code:1:d732040fd0] Dit werkt ook in SuSe. ./configure bekijkt of je wel de benodigde vereisten beschikt. Dit is meestal de gebruikelijke manier om software te installeren.
  • Gelukkig reageren jullie massaal. Wat antwoorden: -Marcel Koopman.: wat jij beschrijft doe ik uiteraard ook. Echter, ik word voortdurend geconfronteerd met allerhande foutmeldingen: bijv. QT niet te vinden (heb ik inmiddels opgelost), KDE niet te vinden (heb ik inmiddels opgelost) . En dat waren de fatsoenlijke foutmeldingen. Maar wat moet ik met een melding als "fout1" bij de stap make install !!!???? En bij de flipperkasten krijg ik de meldig dat OpenGl niet aanwezig is (ik heb een Nvidia Geforce 2 mx400 en de drivers van Nvidia geinstalleerd (dat werkte overigens wel met RPM) -Maximilaan : ik werk met KDE 3.0 en ik heb via YAST alles online geupdate van Suse. Bij Krusader krijg ik bij de installatie (vanaf tar-gz) foutmeldingen van QT en KDE (zie boven). Overigens ben ik nog een programma's tegen gekomen, waarbij YAST automatisch installeert. - jolo: ik heb hellas de Personal editie, dus iets minder software. Maar volgens mij moet dat bij de installatie van dei progs niet uitmaken. -builid : de update heb ik ook gedaan, maar wat bedoel je met aptget? We blijven zoeken.
  • Als je dependancies installeerd, doe dan ook even ldconfig. Dan linken de libraries met elkaar. Enne soms komt het voor dat je een fout1 krijgt, maar waar dat aan ligt weet ik ook niet. Soms ik het zo dat je nog meer dependancies moet installeren.
  • [quote:01467a0174="Mgompie"] -Maximilaan : ik werk met KDE 3.0 en ik heb via YAST alles online geupdate van Suse. Bij Krusader krijg ik bij de installatie (vanaf tar-gz) foutmeldingen van QT en KDE (zie boven). Overigens ben ik nog een programma's tegen gekomen, waarbij YAST automatisch installeert.[/quote:01467a0174] YaST installeert alleen applicaties automatisch die hij kent, oftewel die op de SuSE cd-rom's staan. Krusader bijv. staat daar op. Heb je die krusader die je nu gebruikt zelf gecompileerd? Zo neen, dan is dat de oorzaak (8.1 is incompatible met de meeste voorgecompileerde applicaties, waaronder die van 8.0 of ouder). Zo ja, dan weet ik het niet. Waarom gebruik je niet de Krusader die door SuSE wordt aangeboden?? Max
  • Marcel - wat bedoel je nu precies met dependancies. Ik ben nu een maand bezig met Suse en denk wel dat ik weet wat je bedoelt, maar zou graag iets meer details hebben, en niet zomaar lukraak iets op mijn harde schijf kwakken. Maximilaan- krusader staat, voor zover ik gekeken heb, niet op de Personal editie van Suse 8.1. Dus ik heb diverse RPM-versies geprobeerd en enkele zelf gecompileerde. (bij de laatste waren QT en KDE-dirs onvindbaar, doch dat heb ik weten te verhelpen, maar zit nu met iets als Fout 1. En dat zegt me niet zoveel. Maar we blijven proberen.
  • Heb je [url=ftp://ftp.nl.uu.net/pub/linux/suse/i386/8.1/suse/i586/krusader-1.10-82.i586.rpm]deze rpm.[/url] al geprobeerd?
  • Aan jolo : Nee, we proberen het. bedankt
  • Nogmaals aan jolo :Vous etes formidable!!!!! Waar je hem vandaan hebt weet ik niet, maar deze doet het. bedankt. Leuke site, trouwens

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.