Vraag & Antwoord

OS Linux

kleine anektdote

25 antwoorden
  • Hallo allemaal, Ik wou voor de gezelligheid even onderstaande Linux-ervaring met jullie delen ;) Heb gister een heuse HP Scanjet 3500C cadeau gekregen!! Tot mijn spijt blijkt deze niet onder Linux te werken, dus moet ik deze (voorlopig) onder Windows gebruiken. Heb HP al een brief gestuurd waarin ik om opheldering heb gevraagd :P Enfin, mijn Windows-installatie is nogal brak: hij start pas nadat je zo'n 10 x de reset-knop hebt ingedrukt, verder moet je niet al te moeilijke applicaties (zoals OE) willen draaien.. Conclusie: herinstallatie nodig.. Enfin, dat was in een uurtje gepiept, zij het dat Windows mijn netwerkkaart, extern modem en geluidskaart niet herkend, en van laatstgenoemde niet de door mij aangeleverde drivers slikte (en wie zeiden ook alweer dat een Windows-installatie eenvoudig is? Al deze componenten werden automatisch onder SuSE geinstalleerd/geconfigureerd ;) ) Enfin, belangrijkste is dat de scanner werkte. Wat ik echter glad vergeten was is dat Windows natuurlijk het mbr overgeschreven heeft, en dus een Linux-start niet langer mogelijk is :oops: . En toen had ik een probleem, want: geen bootdiskettes en geen installatiedisks van SuSE 8.1 (doe alles via ftp...), en geen internet (windows kent immers de modem niet :cry: ). Maar vond tussen de rotzooi nog wel een oude RH 7.0 Enfin, ik die starten via de optie [b:7b64ce4611]linux rescue[/b:7b64ce4611] Daarna getracht om / te mounten, maar omdat dit reiserfs is weigerde RH dat pertinent!! :cry: Even verder in de rotzooi gedoken vond ik ook nog een oude SuSE 7.3 Deze kent ook een rescueboot, en gelukkig kon die wel reiserfs mounten. Nu zaak om grub terug te zetten in het mbr dit als volgt gedaan: [list:7b64ce4611] [*:7b64ce4611]eerst een mountpoint aangemaakt voor / : [b:7b64ce4611]mkdir suse[/b:7b64ce4611] [*:7b64ce4611]toen / gemount: [b:7b64ce4611]mount -t reiserfs /dev/hda7 suse[/b:7b64ce4611] [*:7b64ce4611]toen / ingesteld als root directorie: [b:7b64ce4611]chroot suse[/b:7b64ce4611] [*:7b64ce4611]vervolgens /boot gemount: [b:7b64ce4611]mount /boot[/b:7b64ce4611] [*:7b64ce4611]en tot slot yast2 gestart: [b:7b64ce4611]yast2[/b:7b64ce4611] [/list:u:7b64ce4611] yast2 heb ik vervolgens de opdracht gegeven om de originele bootrecord terug te zetten. Dat deed Yast zonder morren (mislukte eerder omdat /boot niet gemount was...), maar tot mijn verdriet werd niet grub terug gezet, maar lilo.... Systeem opnieuw gestart, en vervolgens in de grafische YaST gezocht om de mogelijkheid grub terug te zetten, maar die vond ik gek genoeg niet!! :cry: [b:7b64ce4611]info grub[/b:7b64ce4611] gaf ook weinig soelaas, ik kon hier niet snel wegwijs uit worden hoe je snel de bestaande configuratie terug in het mbr zet... Maar gelukkig wist ik nog te herrinneren dat in onze faq een grub-uitleg stond. Helaas, deze werkte niet, /boot/grub/stage1 of /grub/stage1 werd niet gevonden. Gek genoeg is de eerste wel aanwezig. Na verschillende pogingen uiteindelijk /boot/grub/ gekopieerd naar /, en zie daar, grub werkt nu wel. Enfin: eind goed, al goed.. Toch raar dat SuSE standaard grub gebruikt bij de installatie van deze distro, maar vanuit YaST nog steeds met lilo werkt!!! Max
  • Ik heb vorig jaar Gentoo de eerste keer geinstalleerd met een cd-tje, met daarop versie 1.1a. Ik ga die denk maar heel goed bewaren. Om af en toe Linux te kunnen repareren en als relikwie. :)
  • Hoi Max, Leuk om te lezen dat ik niet de enige ben die altijd "ruzie" heeft met windows. Afgelopen weekend ook weer. Wil ik een fax versturen onder windows, lukt de communicatie niet. In plaats van een waarschuwingsbericht of zo gaat de modemdriver 5 minuten later weer bellen. En tja, daar kan windows niet zo goed tegen... Dit had dus een systeemcrash tot gevolg en pas na ettelijke keren rebooten lukte het mij mijn systeem weer aan de praat te krijgen en de fax alsnog te verzenden. O ja, het rebooten lukte pas nadat ik de fax ontkoppeld had van de telefoonaansluiting. De driver begint meteen te bellen, terwijl windows nog geeneens volledig is opgestart... Bijkomend probleem is dat mijn fax onder windows niet goed de telefoon opneemt; ik krijg altijd een communicationserror! Onder linux (met een tweede, wat ouder intern modem) werkt het met hylafax wel goed, maar mijn windows faxsoftware kan niet met dat oude modem overweg. Dus ik heb de krankzinnige situatie dat ik faxen verstuur onder windows (onder Linux kan ook), maar alleen faxen kan ontvangen onder Linux. Dat laatste is trouwens lastig: als mijn fax werkt onder linux, dan werkt mijn modem (wvdial) niet en andersom. Ik moet dus steeds met de hand 1 van de 2 apparaten aanzetten (ja, ik bel onder Linux altijd in met een modem; werkt prima!). Tot zover mijn bijdrage voor vandaag :-) Groet, Philip
  • Modems.. Op mijn oude systeem heb ik daar ook problemen mee gehad. Mij partner moest een nieuw modem, en omdat ze betrouwbaarder schijnen te zijn hebben we toen een extern modem gekocht. Niet op rekenen dat dit modem aan de praat was te krijgen onder Windows!! Enfin, ik de modems van beide pc's verwisselen: ik het externe, en mijn partner een intern 33k6-modempje. Het interne modem deed het meteen goed, maar het externe beestje dat ik had aanvankelijk wel, maar uiteindelijk ook niet. Om een of andere reden kreeg deze onder Windows ruzie met de muis. Dus als de modem inbelde werkte de muis niet meer. Bij een start naar Linux bleef het probleem gek genoeg bestaan, X kon geen muis meer vinden, of raakte deze kwijt zodra het modem begon in te bellen. Bij apparaatbeheer in Windows was dit overigens op te lossen, maar dat was meestal van korte duur: een volgende start van dit os zorgde ervoor dat het hele schouwspel opnieuw begon. Dat Linux hier ook last van had bleek uiteindelijk doordat Windows de bios-instelling van de compoorten had gewijzigd.. Uiteindelijk het probleem opgelost door de modem aan de compoort an de voorzijde van de pc te koppelen. dit was een verbetering, zij het dat het modem regelmatig op tilt sloeg en pas weer met Windows wou samenwerken als de modem zowel van de stroom als de com-poort was afgekoppeld :o Enfin, vorige zomer zelf een nieuwe pc gekocht, en mijn ouwetje aan mijn partner gegeven. Omdat de nieuwe pc een softmodem had en ik hier geen gedonder mee wilde dacht ik 2 vliegen in 1 klap te slaan door opnieuw een modemruil te doen. Immers: de nieuwe pc kan een ps/2 of usb-muis hebben, zodat er geen COM-conflict meer kan optreden.. Helaas. Op mijn pc werkt nu alles naar behoren (tot voor kort dan, Windows wil het externe modem alleen slikken als ik met een driver-cd aankom, die ik sinds de verhuizing niet kan vinden - maf als je bedenkt dat ik in Linux slechts hoef aan te geven welke poort de modem gebruik...) Maar de interne modem bleek op de oude pc een zorgenkindje. Het installeren ervan was een ware hel, en het modem is ongelooflijk traag. Telebankieren voor de postbank en voorheen abn doet hij voorbeeldig, maar internetten kunnen we vergeten. Maar laatste is natuurlijk geen probleem omdat beide pc's via een netwerk met elkaar zijn verbonden (onder linux dan, de win-pc kent de netwerkkaart opeens niet meer - terwijl deze destijds zonder morren werd geaccepteerd :o ) en vervolgens met @home (alhoewel, momenteel ook niet meer, Essent haast zich niet om ons aan te sluiten :cry:) is internet geen probleem.. Max
  • Maar als je eenmaal op @home zit heb je ook een flinke verbinding. In Sint Willebrord haal ik 350KiloByte per seconde! Dat heb ik bij nog maar weinig ADSL-pakketjes gezien :lol:
  • Dan heb ik ook een anektdote: Toen Windows XP aan een herinstallatie toe was, ging er na het kopieren van de bestanden vanaf de Windows XP CD gevolgd door de reboot iets mis. Er verscheen [code:1:e47ff87a50] Invalid partition table [/code:1:e47ff87a50] Dit had ik nog nooit eerder gezien. Wat was er aan de hand? Ik had onlangs Redhat 8.0 geupgraded naar Redhat 9.0 waarvan ik de GRUB bootmenu gebruik (in MBR) Windows XP had deze wel verwijderd, maar wellicht niet goed genoeg. Ik heb toen mijn PC opgestart met de Redhat 9.0 bootdiskette en GRUB via [code:1:e47ff87a50] grub-install /dev/hda [/code:1:e47ff87a50] opnieuw in het MBR geinstalleerd. Toen ik mijn PC opnieuw opstarte en in het GRUB bootmenu Windows XP selecteerde, ging de installatie procedure van Windows XP gewoon verder. :roll:
  • [quote:9170a767dc="my009054"]Maar als je eenmaal op @home zit heb je ook een flinke verbinding. In Sint Willebrord haal ik 350KiloByte per seconde! :[/quote:9170a767dc] Moach, hier in Bolsward haal ik de 1350 kB/sec :) Gemiddelde download is ongeveer 500 kB/sec Volgens ingewijden komt dit doordat @home nog maar pas in Bolsward zit, en de boel nog niet is afgeknepen.. Max
  • Klopt wel, denk ik. Eerst had ik 800 KiloBYTE / sex en nu nog maar 350 KiloByte /sec :cry: Maar het is wel snel zat trouwens :lol: Meer is altijd beter, maar als ik het vergelijk met mijn ISDN verbinding :P
  • [quote:9c93a50926="my009054"]Eerst had ik 800 KiloBYTE / sex[/quote:9c93a50926] dat is wel ERG veel :lol:
  • Best mogelijk hoor, ik haalde vroeger hier met Chello in Rotterdam vaak de 600kb/s (kilobyte!) en had een gemiddelde van zo'n 350kb/s. Nu is dat wat gezakt helaas naar een gemiddelde van 200kb/s en een piek van ongeveer 350~400kb/s. Dat is het nadeel van kabel :(
  • Even goed lezen Marcel, my009054 had een tikfoutje gemaakt. :wink:
  • Als het woord sex er eens in staat :wink: :lol:
  • Hmm, 500 x sex per sec. is wel veel :P Enfin, heb vandaag mijn printer een schop gegeven. Heb ongeveer 2 jaar geleden een heuse LexmarkZ52 gekocht. Dit vanwege de eigen drivers van lexmark die voor een uitmuntende afdrukkwaliteit zorgen.. Na 2 jaar trouwe dienst begon het apparaatje vorig jaar al kuren te geven: foto's printen gebeurde niet bepaald scherp en met halen er in, veel te donker, en tekstafdrukken waren ook niet altijd even scherp. Vorige week sloeg de printer op tilt door de zwarte cartridge, een nieuwe printte slechts 4 pagina's, en gaf daarna geen inkt meer :cry:. De kleurenkop gaf bovendien slechts lichtblauw en iets geel als kleur (terwijl er kortgeleden een nieuwe cartridge in gedaan is - wel erg snel leeg!!), en ook niet bepaald zuiver qua afdruk.. In ieder geval werd ik goed ziek van het apparaat!! Gekke tegenwoordig is dat je voor de prijs van 1 of 2 cartridges een nieuwe printer hebt :o . Dus lexmark aan de kant gezet, en dit keer voor HP gegaan. Waarom HP? HP brengt, in tegenstelling tot lexmark, via een apart project oss-drivers uit. Alhoewel die minder eenvoudig zijn als die van lexmark, en mogelijk niet opties bieden zoals uitlijnen etc.. , vind ik deze oplossing wel iets beter. De lexmark-driver bijv. werkte alleen met lprng en aanverwante afdruksubsystemen, en niet met bijv. CUPS. Gebruik tijdelijk nog even de lprng met de nieuwe printer, en moet zeggen dat de standaard-uitvoer op zich best scherp is -minder scherp dan die van lexmark, maar foto's afdrukken doe ik toch liever bij de fotograaf, en ik verwacht dat CUPS meer mogelijkheden zal bieden voor het afdrukken.. Max
  • Met het probleem dat de cartridges zou duur zijn en vaak niet navulbaar zijn ze nu bezig in de EU. Ze willen het één en ander daarover per wet vastleggen, oa dat chips die navullen voorkomen verboden worden en dat de prijs van de cartridges omlaag moet. De huidige manier is onwijs slecht voor het milieu en voor de hele printerindustrie.
  •  hmmm, als de EU nu ook eens zo over softwarepatenten dacht was het helemaal klaar geweest ;) Max
  • [quote:7ee91f9776="maximilaan"] hmmm, als de EU nu ook eens zo over softwarepatenten dacht was het helemaal klaar geweest ;) Max[/quote:7ee91f9776] ja in feite zijn patenten en closed source ook slecht voor het milleu want iedereen maakt maar kopieen ( of ze het nu willen gebruiken of niet maakt niet uit) welke altijd minder van kwaliteit zijn dan een originele cd of het gebruik van ftp om een proggie te installeren. Dit zou dus jaarlijks tonnen aan foute, bekraste, beschadigde en niet goed werkende cd's kunnen schelen. Daarnaast komt dat de ontwikkleingen niet meer hoeven stil te blijven staan totdat met het huidig produkt weer voldoende verdient is maar gewoon doorgang kunne vinden waardoor processor, geheugen en video capaciteit eens voor de volle mep benut kunnen worden zodat de pc niet nodeloos stroom straat te vreten. Overgebleven processortijd en bandbreedte kunnen dan standaard via beveiligde verbindingen gebruikt worden om aan goede doelen (zoals kanker bestreiding n seti@home) besteedt kunnen worden waardooor de tijd dat bijv. mijn server aan staat zonder iets te doen ook echt gebruikt kan worden. zorg daarnaast dat men een webcam richt op belangrijke verkeerspunten in de buurt (mits er natuuelijk zicht op is) zodat dit weer kan bijdragen aan de verkeers veiligheid. Gevolg is dat er rustiger (dus zuiniger) gereden zal worden waardoor de tijd dat je pc aanstaat er weer op een ander punt aan het sparen van het millieu gewerkt wordt... Of sla ik nu weer helamaal door ?? De wereld zou er iig. een stuk beter uitzien :D zonder patenten op hersenspinsels en closed source software die al is achterhaald voordat hij uitkwam :D
  • seti@home een goed doel? Ik vind het eerder een nutteloos en kansloos project. Kraak liever de Xbox sleutel met die processor kracht :D
  • Seti@home vind ik persoonlijk zonde van de stroom. Een pc die niks doet verbruikt nog altijd minder stroom dan eentje die voor seti aan het rekenen is ;) de kankerbestrijding is een ander verhaal, daarmee red je immers mensenlevens!!! Max
  • seti was ook zo maar een van de vele projecten en zover ik weet ook het eerste dat een aanspraak deed op loze processor kracht. Maar ik zou wleeens willen zien dat bijv. KDE of GNOMEeens een proggie maakte waardoor je dus gewoon een project kon kiezen waarvoor je je pc tendoel wil stellen. Er gaat zoveel proc.tijd verloren nml ...
  • seti vind ik ook zonde van de stroom maar voor een opensource project zou ik graag mijn compus aan laten staan...

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.