Vraag & Antwoord

OS Linux

2de ethernet kaart geïnstalleerd: Redhat 9.0 extreem traag

Anoniem
jolo
9 antwoorden
  • Na de installatie in mijn Dual Pentium III 1000 Mhz met 512 MB RAM van een tweede ethernet kaart is Redhat 9.0 (full install) extreem traag geworden. Na het fysiek plaatsen van de pci ethernet kaart, die direct werd herkent en geconfigureerd. Daarna ging het opstarten erg traag. Zoiets als in dit topic
    Het begint bij sendmail ca 2,5 min. sm-client ca 1 min 15 sec. Cannaserver ook ca 1 min 15 sec. cups ca 45 sec.

    Vanaf het selecteren van Redhat via de grub bootmenu tot aan de login prompt duurt ongeveer 7 min. Als ik daarna X start met [b:67eed9a300] startx [/b:67eed9a300] dan verschijn na 2 minuten een dialoog: “Er kon geen internetadres gevonden worden voor node1046.a2000.nl Gnome kan daardoor niet correct functioneren. Het probleem zou kunnen worden verholpen door node1046.a2000.nl toe te voegen aan /etc/hosts bestand.” Als ik klik op Log toch in, duurt het nog ca 5 en halve minuut voor dat de Gnome Desktop compleet geladen is. Het starten van een terminal duurt dan ongeveer 1 minuut en 20 seconden.
    Dit is mijn dmesg | grep eth0 (internet ethernet kaart)
    [code:1:67eed9a300]divert: allocating divert_blk for eth0
    eth0: Winbond 89C940 found at 0xb800, IRQ 12, 00:40:95:01:11:2C.
    [/code:1:67eed9a300]
    Dit is mijn dmesg | grep eth1 (tweede ethernet kaart)
    [code:1:67eed9a300]
    divert: allocating divert_blk for eth1
    eth1: RealTek RTL8139 Fast Ethernet at 0xe091f000, 00:50:fc:4c:87:02, IRQ 7
    eth1: Identified 8139 chip type 'RTL-8139C'
    eth1: Setting half-duplex based on auto-negotiated partner ability 0000.
    NETDEV WATCHDOG: eth1: transmit timed out
    eth1: Tx queue start entry 4 dirty entry 0.
    eth1: Tx descriptor 0 is 00002000. (queue head)
    eth1: Tx descriptor 1 is 00002000.
    eth1: Tx descriptor 2 is 00002000.
    eth1: Tx descriptor 3 is 00002000.
    eth1: Setting half-duplex based on auto-negotiated partner ability 0000.
    [/code:1:67eed9a300] Ingekort, want dat transmit timed out verhaal stond er wel 32 keer!
    Dit is mijn cat /proc/interrupts
    [code:1:67eed9a300]

    CPU0 CPU1
    0: 2963 81066 IO-APIC-edge timer
    1: 957 1 IO-APIC-edge keyboard
    2: 0 0 XT-PIC cascade
    7: 0 0 IO-APIC-level eth1
    8: 0 1 IO-APIC-edge rtc
    12: 9197 105 IO-APIC-level usb-uhci, usb-uhci, ohci1394, eth0
    14: 4665 1112 IO-APIC-edge ide0
    15: 33 3 IO-APIC-edge ide1
    NMI: 0 0
    LOC: 83953 83952
    ERR: 0
    MIS: 0
    [/code:1:67eed9a300] In de BIOS mijn parallel poort is Disabled, daarom is irq 7 beschikbaar voor eth1
    Dit is mijn /sbin/lsmod
    [code:1:67eed9a300]
    Module Size Used by Not tainted
    parport_pc 19204 0 (autoclean) (unused)
    lp 9188 0 (autoclean)
    parport 39072 0 (autoclean) [parport_pc lp]
    autofs 13684 0 (autoclean) (unused)
    8139too 18856 1
    mii 4124 0 [8139too]
    ne2k-pci 7232 1
    8390 9056 0 [ne2k-pci]
    ipt_REJECT 3928 6 (autoclean)
    iptable_filter 2412 1 (autoclean)
    ip_tables 15864 2 [ipt_REJECT iptable_filter]
    sg 37548 0 (autoclean)
    sr_mod 18168 0 (autoclean)
    microcode 5184 0 (autoclean)
    ide-scsi 12432 0
    scsi_mod 110520 3 [sg sr_mod ide-scsi]
    ide-cd 35772 0
    cdrom 34176 0 [sr_mod ide-cd]
    ohci1394 20904 0 (unused)
    ieee1394 52044 0 [ohci1394]
    printer 9248 0
    keybdev 2976 0 (unused)
    mousedev 5656 1
    hid 22308 0 (unused)
    input 6208 0 [keybdev mousedev hid]
    usb-uhci 27404 0 (unused)
    usbcore 82592 1 [printer hid usb-uhci]
    ext3 73376 1
    jbd 56336 1 [ext3]
    [/code:1:67eed9a300]
    Dit is mijn /etc/modules.conf
    [code:1:67eed9a300]
    alias eth0 ne2k-pci
    alias sound-slot-0 audigy
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
    alias char-major-81 bttv
    alias usb-controller usb-uhci
    alias ieee1394-controller ohci1394

    alias char-major-195 nvidia
    alias eth1 8139too
    [/code:1:67eed9a300]
    Dit is mijn /etc/sysconfig/networking/devices/ifcfg-eth0
    [code:1:67eed9a300]DEVICE=eth0
    ONBOOT=yes
    BOOTPROTO=dhcp
    USERCTL=no
    PEERDNS=no
    TYPE=Ethernet
    [/code:1:67eed9a300]
    Dit is mijn /etc/sysconfig/networking/devices/ifcfg-eth1
    [code:1:67eed9a300]
    DEVICE=eth1
    ONBOOT=yes
    BOOTPROTO=none
    IPADDR=192.168.0.1
    NETMASK=255.255.255.0
    GATEWAY=192.168.0.254
    TYPE=Ethernet
    USERCTL=no
    PEERDNS=no
    NETWORK=192.168.0.0
    BROADCAST=192.168.0.255
    [/code:1:67eed9a300]

    De Internet verbinding in Redhat 9.0 werkt trouwens niet meer na het plaatsen van die tweede ethernet kaart. Zijn er wellicht netwerk experts op dit forum met nuttige tips?

    Trouwens op deze PC zijn ook nog geinstalleerd: Slackware 9.0 Mandrake 9.1 Debian 3.0 SuSE 8.2 en Windows XP Prof. Deze besturingssystemen hebben geen last van de tweede ethernet kaart. Internet delen werkt op dit moment alleen via Windows XP. Het is de bedoeling dat het ook gaat werken onder Linux. :roll:
  • Raar dat Gnome over het externe netwerk gaat zoeken..

    Wat zegt [b:1de0d0d38d]ifconfig[/b:1de0d0d38d] van je configuratie?

    Max
  • ifconfig in Redhat 9.0
    [code:1:8b97709239]
    eth0 Link encap:Ethernet HWaddr 00:40:95:01:11:2C
    inet addr: (ip adres) Bcast:24.132.5.255 Mask:255.255.254.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:10072 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:608367 (594.1 Kb) TX bytes:487 (487.0 b)
    Interrupt:12 Base address:0xb800

    eth1 Link encap:Ethernet HWaddr 00:50:FC:4C:87:02
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:7 Base address:0xb000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:137 errors:0 dropped:0 overruns:0 frame:0
    TX packets:137 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:12944 (12.6 Kb) TX bytes:12944 (12.6 Kb)
    [/code:1:8b97709239]
  • Is het mogelijk je ip-adres op eth0 statisch in te stellen (dus niet met dhcp) of kan dat niet in combinatie met je isp?
    Probeer ook eens je kernel opnieuw te compileren en en compileer dan alletwee je netwerkkaarten in de kernel (niet als modules)

    succes!
  • ben benieuwd naar de route tabel.. klinkt also gnome iets van de loopback niet echt snapt..
  • //Paranoid Android
    Alleen dhpc is mogelijk bij mijn isp. De kernel compileren in Redhat is nogal lastig, zo geeft make modules nog wel eens een foutmelding.

    //KayJay
    Hier is [b:f7313aa13e] route [/b:f7313aa13e] in Redhat 9.0
    [code:1:f7313aa13e]
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth1
    24.132.4.0 * 255.255.254.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
    127.0.0.0 * 255.0.0.0 U 0 0 0 lo
    default 192.168.0.254 0.0.0.0 UG 0 0 0 eth1
    [/code:1:f7313aa13e] Opmerking: die default regel verschijnt pas na 20 seconden.

    Ter vergelijking dit is [b:f7313aa13e] route [/b:f7313aa13e] in Mandrake 9.1 (op dezelfde PC uiteraard.)
    [code:1:f7313aa13e]
    [root@node1048e jolo]# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
    24.132.4.0 * 255.255.254.0 U 0 0 0 eth0
    127.0.0.0 * 255.0.0.0 U 0 0 0 lo
    default h6rtr1.a2000.nl 0.0.0.0 UG 0 0 0 eth0
    [root@node1048e jolo]#
    [/code:1:f7313aa13e] :roll:
  • om eoa. reden krijgt je eth1 dus twee ip's
    Dit zal het gevolg zijn van een tweede dhcp server in je netwerk ?? of anders krijgt hij die via je eth0 (inet) toegewezen.

    Probeer eth1 een volledig te verwijderen (dus ook je if-up ed.
    en hem na een reboot opnieuw in te stellen.
  • Hm, in de papieren handleiding staat wel iets over installeren van een netwerkkaart, maar deinstalleren niet. De enige manier die ik zelf weet om een netwerkkaart te deinstalleren is in Gnome > System Settings > Network. Als er iemand weet hoe ik een netwerkkaart kan verwijderen in tekst mode, dan hoef ik die trage Gnome niet meer op te starten. :roll:
  • vlgs mij hoef je alleen in /etc/sysconfig/network/
    het ip-up-eth1 script weg te halen
    en kijk ook even of je /etc/route.conf wel klopt

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.