Vraag & Antwoord

OS Linux

Samba .... het lukt me maar niet....

7 antwoorden
  • Dag allemaal, Ik ben een beetje ten einde raad.... Ik ben samba aan het installeren (laatste versie) en alles gaat goed, dwz: (ik heb dus gebruikers aangemaakt en overgezet) testparm --> ok [root@intranet bin]# ./smbclient -L intranet -U rachel added interface ip=10.10.15.6 bcast=10.10.255.255 nmask=255.255.0.0 Password: ****** Domain=[JACOBA] OS=[Unix] Server=[Samba 2.2.8a] Sharename Type Comment --------- ---- ------- public Disk Public Stuff rachel Disk Rachel's ervice myshare Disk Rachel's and Sascha's stuff IPC$ IPC IPC Service (Samba 2.2.8a on) ADMIN$ Disk IPC Service (Samba 2.2.8a on) rachel Disk Home Directories Server Comment --------- ------- INTRANET Samba 2.2.8a on Workgroup Master --------- ------- JACOBA LANGINTRANET Lokaal gaat dat dus goed voorzover ik kan zien. Als ik onder winXP (ingelogd als rachel dus) onder mijn netwerk kijk is de samba server idd aanwezig in de werkgroup maar ik mag er alleen niet in =( Afmelden en opnieuw aanmelden helpt ook niets Kk heb m'n IPTABLES aangepast (port 139:TCP en port 445:TCP) ook niets Ik weet het niet meer.......... Kan iemang mij alsjeblieft helpen ??? Heel veel dank alvast. Rachel smb.conf: [global] workgroup = JACOBA server string = Samba %v hosts allow = 10.10.15 127. printcap name = /etc/printcap load printers = no printing = cups log file = /var/log/samba/%m.log max log size = 0 security = USER encrypt passwords = yes smb passwd file = /etc/samba/smbpasswd ey allow the Unix password unix password sync = Yes passwd program = /usr/bin/passwd %u passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully* pam password change = yes obey pam restrictions = yes socket options = TCP_NODELAY IPTOS_LOWDELAY os level = 64 preferred master = yes domain logons = yes add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false -M %u logon script = %U.bat logon path = \\%N\Profiles\%U logon drive= Z: message command=csh -c'xedit %s;rm %s'& invalid users = mail,deamon,adt admin users = root dns proxy = no [homes] comment = Home Directories browseable = no writable = yes valid users = %S create mode = 0664 directory mode = 0775 [printers] comment = All Printers path = /var/spool/samba browseable = no guest ok = no writable = no printable = yes [public] comment = Public Stuff path = /home/public public = yes writable = yes printable = no write list = @staff [rachel] comment = rachel's ervice path = /home/rachel valid users = rachel public = no writable = yes printable = no [myshare] comment = rachel's and Sascha's stuff path = /home/public valid users = rachel sascha public = no writable = yes printable = no create mask = 0765
  • wat je kan doen is eens kijken of het wel werkt als je de XP patch erover gooi ftp://ftp.easynet.be/samba/docs/Registry [code:1:9f1e383d0b] Windows Registry Editor Version 5.00 ; ; This registry key is needed for a Windows XP Client to join ; and logon to a Samba domain. Note: Samba 2.2.3a contained ; this key in a broken format which did nothing to the registry - ; however XP reported "registry key imported". If in doubt ; check the key by hand with regedit. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters] "requiresignorseal"=dword:00000000 [/code:1:9f1e383d0b]
  • Nu ik die registry update er over heen gehaald heb zie ik in m'n netwerk omgeving helemaal de samba server niet meer :cry:
  • Ik heb opnieuw geboot en ik zie de samba server weer in m'n netwerk locaties onder m'n workgroup in XP helaas kom ik er nog steeds niet bij :cry: Iemand suggesties ??? Pleaz !!
  • OK, je samba-share wordt zichtbaar onder XP, maar je hebt er geen toegang toe? Wat ik gedaan heb is het volgende Ik heb gebruiker [b:d447870449]max[/b:d447870449] aangemaakt op de Linuxbox, incl linux-wachtwoord. Vervolgens via [b:d447870449]smbadduser max[/b:d447870449] deze gebruiker bekend gemaakt bij samba, en een nieuw (evt ander) wachtwoord voor samba opgegeven. Vervolgens op de Windows-machine de gebruiker max met bijhorend samba-wachtwoord aangemaakt, en hiermee ingelogd. Nu is de share wel te openen door max.
  • [code:1:0aaf7f8699] hosts allow = 10.10.15 127. [/code:1:0aaf7f8699] ik hoop dat dit een typovoutje is .... stel anders eens je smb.conf in mbv. swat in xp browsertjestarten http://ip.linux.bak:901 inkloppen en de boel eens rustig nalopen
  • Ben nu al reeds weer een paar uur bezig en het wil me nog steeds niet lukken :cry: :cry: die hosts allow = 10.10.15 127. heb ik aangepast naar hosts allow = 10.10.15.1/24 127.0.0.1 nog niets.... (zie 'm wel maar mag er niet in) swat lukt me ook niet om draaiend te krijgen :-( hiervoor heb ik m'n xinetd.conf aangepast die ziet er nu zo uit: # Simple configuration file for xinetd # # Some defaults, and include /etc/xinetd.d/ defaults { instances = 60 log_type = SYSLOG authpriv log_on_success = HOST PID log_on_failure = HOST cps = 25 30 } ## /etc/xinetd.d/swat service swat { port = 901 socket_type = stream wait = no only_from = localhost user = root server = /usr/local/samba/bin/swat log_on_failure += USERID disable = No } includedir /etc/xinetd.d In /etc/services heb ik toegevoegd: swat 901/tcp in m'n firewall heb ik de poort ook opengezet maar er gebeurt niet als ik localhost:901 doe in me browser. telnet localhost 901 weigert het ook (connection failed) Nog wat lopen zoeken op ineternet en de volgende page gevonden: [URL]http://hr.uoregon.edu/davidrl/samba/samba-diagnose.html[/URL] Stap 1&2 gecheck en aangepast (gereboot) zelfde probleem nog steeds Stap 3: M'n smbd log geeft het volgende weer: [2003/05/19 11:17:40, 0] smbd/oplock_linux.c:linux_init_kernel_oplocks(287) Failed to setup RT_SIGNAL_LEASE handler [2003/05/19 14:10:43, 0] smbd/oplock_linux.c:linux_init_kernel_oplocks(287) Failed to setup RT_SIGNAL_LEASE handler Stap 4:NetBIOS Name Resolution : [root@intranet]# nmblookup -B intranet __SAMBA__ querying __SAMBA__ on 127.0.0.1 10.10.15.6 __SAMBA__<00> [root@intranet]# nmblookup -B example-client '*' querying * on 0.0.0.0 10.10.15.6 *<00> nmblookup -M JACOBA en NET VIEW \\example-server vanuit Windows gaan niet goed Ik wordt er een beetje gaar van. Deze documentatie geeft alleen aan welke testen je kan doen maar geen oplossingen ! Zelf denk ik als ik dit alles zie dat het met m'n nmbd te maken heeft.... Rachel [root@intranet]# nmblookup -d 2 '*' added interface ip=10.10.15.6 bcast=10.10.255.255 nmask=255.255.0.0 querying * on 10.10.255.255 name_query failed to find name * gaat dus fout [url][/url]

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.