Vraag & Antwoord

OS Linux

SuSE 8.2 Konqueror en Mozilla trage internet via HW router

30 antwoorden
  • Ik heb onlangs een hardware router gekocht. Zonder deze router kan er snel worden gesurft in SuSE 8.2. Maar met hardware router gaat het surfen tergend traag. Het volledig laden van www.chello.nl duurt ongeveer 3,5 minuten. Daar en tegen het downloaden en pingen gaat wel snel. Ik heb overigens wel in Yast2 bij Hostnaam en domeinaam, het vinkje Wijzig hostnaam via DHCP moeten verwijderen. Omdat anders Yast2 niet meer wilde starten en KDE menu > Systeem > Shells > root bash geen computernaam meer kon vinden. [code:1:8707db6ae0] hostname: Fout bij opzoeken computernaam Password: hostname: Fout bij opzoeken computernaam xauth: creating new authority file /root/.Xauthority xauth: (argv):1: bad display name "/unix:0.0" in "extract" command xauth: (argv):1: bad display name "/unix:0.0" in "extract" command xauth: (argv):1: bad display name ":0.0" in "extract" command No matches found, authority file "/dev/fd/62" not written xauth: (argv):1: unable to read any entries from file "(stdin)" :/home/jolo # [/code:1:8707db6ae0] Op dezelfde PC met meerdere besturingssystemen hebben onder andere Slackware 9.0 en Debian 3.0 geen probleem met die hardware router. Er kan dan snel gesurft en gedownload worden. Ik heb een verschil kunnen vaststellen tussen de route output van SuSE 8.2 en Debian 3.0 SuSE 8.2 route output [code:1:8707db6ae0] linux:/home/jolo # route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface . * 255.255.255.0 U 0 0 0 eth0 default my.router 0.0.0.0 UG 0 0 0 eth0 linux:/home/jolo # [/code:1:8707db6ae0] Debian 3 route output [code:1:8707db6ae0] debian:/home/jolo# route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.1.0 * 255.255.255.0 U 0 0 0 eth0 default my.router 0.0.0.0 UG 0 0 0 eth0 debian:/home/jolo# [/code:1:8707db6ae0] De destination bij route van SuSE 8.2 ontbreekt dus. Wat zou er fout geconfigureerd kunnen zijn?
  • En als je die destination nu braaf overneemt van Debian ?
  • In Yast2 Hostnaam en naamserver configuration lijkt alles in orde, want bij Naamservers en domein zoeklijst, staat bij zowel Naamserver 1 en – 2 [b:2516746bbf] 192.168.1.0 [/b:2516746bbf] Deze heb ik niet zelf getypt, maar staan daar omdat Update naamservers en zoek de lijst via DHCP is gevinked. Zonder dat vinkje werkt de Internet verbindig helemaal niet. :roll:
  • Wat heb je in YaST bij 'routing' ingevuld? Max
  • [quote:82f842154b="maximilaan"]Wat heb je in YaST bij 'routing' ingevuld?[/quote:82f842154b] Niets, trouwens in Debian en Slackware heb ik niets hoeven wijzigen, na het aansluiten van de hardware router. (Draytek Vigor2200E) In SuSE 8.2 gaat het surfen zowel in Mozilla en Konqueror traag. Het ophalen van email met Kmail duurt wel 40 seconden. Ik heb de email data gekopieerd naar de Slackware partitie. Deze haalt met Kmail de email wel snel binnen. Behalve SuSE 8.2 heeft eveneens Redhat 9.0 een probleem, na het aansluiten van de hardware router. Maar omdat dat een ander probleem is, heb ik deze gereserveerd voor een ander topic. 8) Op mijn tweede PC geld het zelfde verhaal. :roll:
  • En als je nu het ip van de router aldaar opgeeft als standaard gateway?? Max
  • [quote:12a754ffb2="maximilaan"]En als je nu het ip van de router aldaar opgeeft als standaard gateway??[/quote:12a754ffb2] Helaas, SuSE surft dan nog steeds traag. (Ook na een reboot) Bovendien blijft de route output ongewijzigd. Net als ifconfig. Tijdens het opstarten van SuSE krijgt de ethernetkaart wel vrijwel onmiddelijk een DHCP ip adres van de hardware router.
  • Heb je misschien SuSEFirewall draaien en zoja, is deze dan goed geconfigureerd ?
  • [quote:560d4588a9="marcelk"]Heb je misschien SuSEFirewall draaien en zoja, is deze dan goed geconfigureerd ?[/quote:560d4588a9] Nee, de SuSE firewall draait niet. In die hardware router zit al een firewall. Volgens Shield UP Port Probe op grc.com staan de poorten die ze testen allemaal op Stealth. De firewall van de hardware router staat nog zoals deze was bij aankoop. Ik heb de hardware router enkel geconfigureerd in Basic Setup en Quik Setup. In Advanced Setup en System Management heb ik niets gewijzigd. :roll:
  • Wat geeft [code:1:9e8605a5e3] cat /var/log/messages [/code:1:9e8605a5e3] voor een output ?
  • [quote:c6e9e0c8b9="marcelk"]cat /var/log/messages [/quote:c6e9e0c8b9] Die output is te lang, als het om de errors gaat, die ingekorte waslijst errors gaat uitsluitend over mijn USB zip drive. [code:1:c6e9e0c8b9] linux:/home/jolo # cat /var/log/messages | grep error May 29 12:14:44 linux kernel: sda: I/O error: dev 08:00, sector 0 May 29 12:14:44 linux kernel: lost async page write due to I/O error on 08:00 <knip> [/code:1:c6e9e0c8b9] Ik heb inmiddels Opera 6.03 geinstalleerd, wat blijkt deze browser heeft geen last van dat traag surf probleem, en surft zo als dat hoort, snel. De oplossing moet dus gezocht worden in Mozilla en Konqueror en Kmail. En voordat ik het vergeet: Galeon, die surft ook traag. :roll:
  • Hmm, ik heb de Topic titel ietwat aangepast. Dan nog even resumeren. Mozilla, Konqueror en Galeon surfen traag en KMail haalt de mail traag op, na het plaatsen van de hardware router in SuSE 8.2, maar werken wel goed in andere Linux distro's. Ik heb Mozilla ook nog even getest in SuSE 8.2 Gnome en TWM, maar dat maakt niets uit. Het ligt dus niet aan KDE. Opera 6.03 surft om de een of andere reden nog wel snel in SuSE 8.2 Dus de vraag is, kan iemand hier nog een touw aan vastknopen? :P En heeft iemand nog een goede suggestie? :roll:
  • Topic titel maar weer eens aangepast. Ik heb inmiddels SuSE 8.1 weer opnieuw geïnstalleerd. Het blijkt dat Mozilla 1.0.1 en Konqueror 3.0.3 met de hardware router, in tegenstelling tot SuSE 8.2 nog wel snel kan surfen. Dat het surfen met Mozilla, Konqueror veel trager geworden is in SuSE 8.2 dan in SuSE 8.1 na het toevoegen van een hardware router, moet toch een verklaring voor zijn. Ik heb de instellingen van SuSE 8.1 en SuSE 8.2 in Yast2 bij Host en naamserver configuratie al met elkaar vergeleken. Deze zijn van beide SuSE versies gelijk. Ik hoop dat iemand hierover alsnog een goede suggestie kan doen. :)
  • Interessant probeem Jolo. Waarom leg je het niet even voor aan de helpdesk van Suse? Ik heb goede ervaringen met Suse en reageren behoorlijk snel als je dit soort problemen aan ze voor legt.
  • Kijk eens naar alle opties aangaande protocollen. Misschien dat hier een verschil in zit. BTW: kun je niet online zien wat je router aan het doen is?
  • [quote:babc1bb2e6="ancum"]Waarom leg je het niet even voor aan de helpdesk van Suse?[/quote:babc1bb2e6] Traag surfen met Mozilla en Konquereror valt vast niet onder de [url=http://www.suse.com/us/private/support/inst_support/support_overview.html]Installatie support[/url] [quote:babc1bb2e6="water"]Kijk eens naar alle opties aangaande protocollen.[/quote:babc1bb2e6] Van beide SuSE's is het protocol DHCP. [quote:babc1bb2e6="water"]BTW: kun je niet online zien wat je router aan het doen is?[/quote:babc1bb2e6] Hoe? Bij SuSE 8.2 zit dan wel in KDE menu > Internet > Tools > Ethernet (The Ether Network Analyzer) maar dat is voor mij een onbekent programma. Ik zal het trage surfen nogmaals proberen uit te leggen. Als ik met bijvoorbeeld Mozilla in SuSE 8.2 naar een willekeurige website surf, dan verschijnt eerst: [b:babc1bb2e6] Resolving host.. [/b:babc1bb2e6] deze tekst blijft zo een 50 seconden staan, dan pas begint de site te laden [b:babc1bb2e6] Tranfering data from.. [/b:babc1bb2e6] wat ook nog wel even kan duren. Maar is zo een site eenmaal geladen in Mozilla, bijvoorbeeld forum.computertotaal.nl dan gaat het surfen van de ene naar de andere topic wel goed. Surf ik daarna weer naar een andere site, dan verschijnt eerst weer [b:babc1bb2e6] Resolving host.. [/b:babc1bb2e6] enz. dus weer traag. Sluit ik Mozilla af. En start 'm daarna weer, dan verschijnt er weer na het surfen van elke willekeurige site, weer dat trage [b:babc1bb2e6] Resolving host.. [/b:babc1bb2e6] gedoe. :-?
  • Resolving host = contact maken met DNS-server? Blijkbaar remt het hardware-modem bepaalde pakketten om de DNS-server te kunnen bereiken, of om het eerste contact met de host te maken. Ik ben geen TCP/IP expert, maar een aantal zaken lopen via UDP en ICMP pakketten. Mogelijk worden die beperkt door de modem doorgelaten (in de tijd gezien) en verstuurd Mozilla er te veel per tijdseenheid. Normaal wordt dit van buiten naar binnen geremd, om Denial of Services aanvallen te voorkomen.
  • [quote:97d6af7d84="water"]Mogelijk worden die beperkt door de modem doorgelaten (in de tijd gezien) en verstuurd Mozilla er te veel per tijdseenheid. [/quote:97d6af7d84] Maar is dit dan distro (versie) afhankelijk? Ik zou niet weten waar dit mee te controleren.
  • Je kan er natuurlijk ook eens voor kiezen gewoon in SuSE een IP-adres te geven (dus niet via DHCP) die in dezelfde range zit als die van de router; vervolgens als vaste gateway de router opgeven; en tenslotten vaste DNS-waarden invullen. Ook even de firewall op de router uitschakelen. Dan ben je in 1 keer van een heleboel stroingsfactoren af. Je hebt toch niet perongeluk op de router een hostname ingevuld die je ook op een van je computers gebruikt?
  • Bestaan er geen programma's die de bv de packetloss van een ander programma (Mozilla, Konqeror) kunnen meten?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.