Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[Samba] (Rechten?)-Probleem PDC

Japaveh
5 antwoorden
  • Ik ben bezig met het opzetten van een PDC onder Debian (Woody) in combi met

    Samba. Version 2.2.8a-0.9woody1 for Debian

    Het aanmaken van de accounts voor de PC's gaat goed, en ik heb ook 3 verschillende gebruikersaccounts. Ik heb hiervoor deze howto gebruikt. Enig verschil is dan mijn clients beide XP prof SP 1 zijn. Daarom heb ik ook in de beveiligingsinstellingen de optie "gegevens in beveiligd kanaal…ondertekenen (altijd) uitgeschakeld.

    Het is mij ook gelukt om de biede client pc's lid te maken van het domein, maar wanneer ik probeer op het domein in te loggen krijg ik de foutmelding dat de opgegeven netwerknaam niet geldig is en dat er dus een lokaal profiel aangemaakt wordt.

    Maar goed, ik kan dus wel inloggen. maar nu komt het rare. Wanneer ik probeer een directory te maken, krijg ik de foutmelding dat de directory niet gemaakt kan worden omdat de naam al bestaat, maar er worden er dus wel 2 tegelijk aangemaakt.

    Probeer ik een file te maken, krijg ik de foutmelding dat de opgegeven netwerknaam niet beschikbaar is maar ook nu worden er 2 aangemaakt. Probeer ik een file vanaf het internet te saven dan begint de pc oneindig veel .tmp files te maken die allemaal leeg is. ik snap er niets meer van.

    Ik heb het vermoeden dat er fouten zijn in de rechten van de directories. en heb dus tijdelijk alles op 777 gezet. Ook kan het zijn dat in de smb.conf file fouten zitten in de create mode & directory mode maar ook hier heb ik al veel aan geprobeerd en helaas.

    Sorry voor de lange openingspost maar ik heb geprobeerd het verhaal zo duidelijk mogelijk op te schrijven. Zie ik iets over het hoofd? In de Logfiles kom ik geen bijzonderheden tegen, maar op verzoek wil ik die gerust posten.
    Voor de volledigheid alleen nog de smb.conf file

    smb.conf:
    [code:1:2c6bd17336]
    [global]
    smb passwd file = /etc/samba/private/smbpasswd
    domain master = yes
    preferred master = yes
    encrypt passwords = yes
    max log size = 250
    interfaces = eth0
    read raw = yes
    security = user
    loglevel = 2
    local master = yes
    socket address = 10.0.0.10
    serverstring = Samba on %L
    hosts allow = 10.0.0. localhost
    update encrypted = yes
    debug timestamp = yes
    logon path = \\muse\profiles\%U
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
    logon script = \\muse
    etlogon\%U.bat
    domain logons = yes
    workgroup = MUSICA
    netbios name = muse
    log file = /var/log/samba/log.%m
    os level = 65
    wins support = yes


    [netlogon]
    allow hosts = 10.0.0. localhost
    max connections = 8
    comment = The domain logon service
    path = /etc/samba/scripts/
    browseable = no
    public = no

    [profiles]
    path = /etc/samba/profiles
    create mode = 0600
    directory mode = 0700
    read only = no

    [homes]
    comment = Home Directory
    browsable = yes
    writable = yes
    read only = no
    create mode = 0664
    directory mode = 0775

    [/code:1:2c6bd17336]
  • valid users = root administrator @administrator
    admin users = root administrator @administrator
    force group = endanhierdegroupnaamvanXP

    Als je deze regels even toevoegd in je SMB.conf bestand bij alle shares, dus ook den netlogon-share zit je in elk geval in dezelfde reeks als die van XP qua gebruikers, rechten en groepnamen. Ik heb destijds diezelfde HOWTO gebruikt voor mijn netwerkje thuis, dat ging goed; de 4 win2000 machnies konden op het domein, maar de ene XP machine niet.

    Heb je ook in /etc/hosts en /etc/hosts.cond vermeld welke IPs bij welke computers horen bij mij:

    [code:1:3379c44e94]
    # Host configuration file
    10.0.0.150, 192.168.1.100 Dekkers-SRV
    192.168.1.111 Dekkers-WS1
    192.168.1.112 Dekkers-WS2
    192.168.1.113 Dekkers-WS3
    192.168.1.101 Dekkers-NB1
    10.0.0.138 Dekkers-Firewall
    [/code:1:3379c44e94]

    Succes……:P
  • /etc/hosts is goed geconfigureerd (zie hieronder) maar ik heb geen file die hosts.cond heet… hoe ziet die eruit, is die hetzelfde?
    [code:1:beb9f6f1b4]
    muse:~# less /etc/hosts
    127.0.0.1 localhost
    10.0.0.10 muse.japaveh.nl muse
    10.0.0.8 spinvis.japaveh.nl spinvis
    10.0.0.7 coldplay.japaveh.nl coldplay
    10.0.0.11 moonspell.japaveh.nl moonspell
    [/code:1:beb9f6f1b4]

    Het veranderen van de user groups geeft eigenlijk hetzelfde resultaat als hiervoor. Ik kan dus wel bij de shares komen, maar het lukt op zich dus ook wel om een directory aan te maken maar ik krijg nog steeds de foutmelding dat het niet lukt (omdat de naam al bestaat) maar vervolgens krijg ik dus 2 directories


    Ik hab het vermoedden dat het aan XP lag en heb dus w98 geinstalleerd, maar die geeft dus dezelfde foutmelding. Dus misschien dat het toch aan samba of de conf-file ligt. Ik ga rustig door…. :roll:
  • Nee, ik bedoel hosts.conf Typefoutje van mij :oops:

    Dat is inderdaad een erg vreemd probleem. Je hebt wel net zoals in de howto alle machineaccounts aangemaakt? Ook met smbpasswd -a username die bekendgemaakt bij samba?

    Wat je dan nog zou kunnen proberen is het volgende:

    Kijk eens of de firewall misschien in de weg zit:
    [code:1:e82416d93a]
    iptables -L
    [/code:1:e82416d93a]
    Zou moeten krijgen:
    Dekkers-WS1:/etc/samba # iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination


    Dan kan je nog even kijken os samba wel degelijk draait:
    [code:1:e82416d93a]
    /etc
    c.d/init.d/smb status
    /etc
    c.d/init.d/nmb status
    [/code:1:e82416d93a]

    Ook kan je eens proberen vanaf de prompt het volgende te doen om te kijken of je smb.conf geen fouten bevat:
    [code:1:e82416d93a]
    smbclient '\\jouwservernaam\eengeshardedirectory' -U eengeldigeuser
    dus bijvoorbeeld:
    smbclient '\\debianpc
    etlogon' -U user
    [/code:1:e82416d93a]

    Als het goed is hoor je nu een hele lijst met gegevens te krijgen, en geen foutmeldingen; anders is er iets in smb.conf fout!

    Nogmaals succes……:P
  • Nu gebeuren er toch wel opmerkelijke dingen (voor zover dat nog niet aan de hand was)

    Een firewall heb ik nog niet geinstalleerd, omdat alles achter de router zit. Ik weet dat dat niet echt heel verstandig is, maar in principe zijn alle inkomende poorten vanaf het grote boze internet geblocked. Anyway m'n firewall geeft de volgende output.

    [quote:d0c6e7bef5]
    muse:/home/japaveh# iptables -L
    modprobe: Can't locate module ip_tables
    iptables v1.2.6a: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.
    [/quote:d0c6e7bef5]

    Da's dus niet helemaal OK. Maar goed, ik kan wel bij alle poorten komen. FTP etc werkt wel gewoon.

    Verder naar de status van de samba/nmb Deamons…

    [code:1:d0c6e7bef5]
    muse:/home/japaveh# ps -aux | grep 'mbd'
    Bad syntax, perhaps a bogus '-'?
    root 20270 0.0 1.0 2784 1328 ? S 10:41 0:00 /usr/sbin/nmbd -D
    root 20272 0.0 1.1 3796 1440 ? S 10:41 0:00 /usr/sbin/smbd -D
    root 20273 0.0 0.8 2728 1064 ? S 10:41 0:00 /usr/sbin/nmbd -D
    root 20291 0.0 0.3 1332 432 pts/1 S 10:45 0:00 grep mbd
    [/code:1:d0c6e7bef5]

    Die lopen dus. Maar wel 2 keer. Er zijn clients ingelogd dus dat kan de oorzaak zijn.


    Nu komt het opmerkelijke, en hopelijk de oorzaak.


    [quote:d0c6e7bef5]muse:/home/japaveh# smbclient
    bash: smbclient: command not found
    muse:/home/japaveh#
    [/quote:d0c6e7bef5]

    Dus dat is wel raar. Ik ga maar eens kijken of samba goed geinstalleerd is. Misschien dat daar deze rare fouten vandaan komen. Ik houd jullie op de hoogte.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.