Vraag & Antwoord

OS Linux

RH9-Broadcom-NIC

11 antwoorden
  • Vorige week heb ik Red Hat 9 geinstalleerd naast WinXP op een 2e harde schijf. Helaas werd mijn Broadcom onboard NIC niet herkend (het gaat om een Asus a7v333-x moederbord.) Op cd-rom van moederbord een linux-driver gevonden: bcm5700-2.2.27.tar.gz Bij de opdracht: tar xvzf bcm5700-2.2.27.tar.gz kreeg ik de foutmelding: read-only bestandssysteem. Ik heb bestand uitgepakt met fileroller naar een temp-directory. In bijgaande tekst-file staat vervolgens: Build the driver bcm5700.o as a loadable module for the running kernel: cd src make ik heb dit geprobeerd maar kreeg foutmelding. Met deze 2 opdrachten zou installatie voltooid moeten worden. insmod bcm5700.0 make install Helaas ben ik na lang proberen blijven steken: heeft iemand advies?? Bij voorbaat dank
  • waar blijf je precies steken? heb je de kernel source ook op je systeem staan (in /urs/src )? Max
  • log in als user, open een console en mount de cdrom: [code:1:4b7623fc2d]mount /dev/cdrom[/code:1:4b7623fc2d] kopieer het bestand van de cdrom naar je home-directory: [code:1:4b7623fc2d]cp /mnt/cdrom/naamenlocatiebestand /home/naamuser[/code:1:4b7623fc2d] dowload de kernel-source: [code:1:4b7623fc2d]wget ftp://ftp.nluug.nl/pub/os/Linux/distr/RedHat/ftp/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/kernel-source-2.4.20-8.i386.rpm[/code:1:4b7623fc2d] installeer de kernel-source: [code:1:4b7623fc2d] rpm -i naamrpm[/code:1:4b7623fc2d] pak het bestand uit: [code:1:4b7623fc2d]tar -xzvf naambestand.tar.gz[/code:1:4b7623fc2d] ga de uitgepakte directory in: [code:1:4b7623fc2d]cd naamdirectory[/code:1:4b7623fc2d] ga de src-directory in: [code:1:4b7623fc2d]cd src[/code:1:4b7623fc2d] bouw de module: [code:1:4b7623fc2d]make[/code:1:4b7623fc2d] laad de module: [code:1:4b7623fc2d]insmod naammodule[/code:1:4b7623fc2d] installeer de module: [code:1:4b7623fc2d]make install[/code:1:4b7623fc2d] zorg ervoor dat de module tijdens de boot wordt geladen: [code:1:4b7623fc2d]cd /etc && mcedit modules.conf[/code:1:4b7623fc2d] [b:4b7623fc2d]voeg de regel 'modprobe naammodule' toe aan het einde van het bestand[/b:4b7623fc2d]
  • Bedankt alvast voor de hulp. Bij het installeren van de kernel-source krijg ik een foutmelding: Warning :kernel-source-2.4.20-8.i386.rpm : V3 DSA signature NO KEY, key ID db42a60e error : Failed dependencies gcc>=2.96-98 is needed bij kernel-source-2.4.20-8 :o :o
  • Als je een 10/100 NIC van Broadcom hebt: Stop maar, want dat is een Broadcom 4400 model. De 5700 driver is voor een Gigabit NIC. Ik heb het ook op mijn Asus Mobo gezien. Er zijn wel drivers te vinden, maar ik krijg ze bij mij ook niet zonder foutmeldingen. Op de site van Asus is een Linuxdriver voor de BCM4400 10/100 NIC te downloaden. Probeer die maar aan het werk te krijgen, hij is in ieder geval voor de juiste hardware. Die 5700 driver werkt echt niet op de 4400.
  • Ik heb een 10/100 NIC van Broadcom ,die 4400 driver die jij noemt heb ik op cd. Ik heb een gcc-compiler geinstalleerd van de installatie-cd van RH9;daarna de kernel-source geinstalleerd en daarna met MAKE-commando de module gemaakt. Als ik de driver probeer te laden met: insmode filenaam krijg de melding insmode: command not found
  • Probeer eens [b:51acf35aa1]insmod[/b:51acf35aa1] of evt modprobe.
  • Ik krijg zowel bij [u:0a41cbb817]insmod [/u:0a41cbb817]als bij [u:0a41cbb817]modprobe [/u:0a41cbb817] de foutmelding:command not found. Dit geldt ook voor de door hveene aangeraden bcm4400-driver. Moet ik voor deze commando's een pakket installeren? Ps: insmode was typefoutje,Linux staat op andere pc en heb de instructies van Marcel uitgeprint en ook nauwkeurig ingevoerd; toen ik echter de posting maakte had ik de instructie niet bij de hand ,vandaar!! :oops:
  • [quote:0faa39a19c="thoomasz"]Ik krijg zowel bij insmod als bij modprobe de foutmelding:command not found.[/quote:0faa39a19c] Was je ingelogd als superuser? [code:1:0faa39a19c] su password: [/code:1:0faa39a19c] Zo ja, probeer dan eens [code:1:0faa39a19c] /sbin/modprobe [/code:1:0faa39a19c] of [code:1:0faa39a19c] /sbin/insmod [/code:1:0faa39a19c]
  • Het is gelukt,dwz de driver wordt geladen maar netwerk-kaart werkt niet. In netwerk-configuratie staat bij de hardware-tap: Broadcom Tigon3 eth0 bcm4400 eth1 In modules.config staat het volgende: alias eth0 tg3 alias eth1 bcm4400 tg3 is volgens mij de oude driver meegeleverd met RH9,kan ik deze nog verwijderen? Het vreemde is echter dat ik wel kan pingen van windows-pc naar linux-pc :o :o
  • dan werkt de kaart dus wel het probleem zit hem er waarschijnlijk in dat je eth0 als externe interface hebt ingesteld, verwijder in modules.config de eerste regel en maak van eth1; eth0 dan moet ie tijdens het booten de goede module+kaart eth0 maken en deze moet dan werken

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.