Vraag & Antwoord

OS Linux

vmware installeren

24 antwoorden
  • Suse 8.2 dual AMD 2400+ Ik probeer vmware te installeren, 4.0 Ik krijg van suse de aanwijzing dat ik in de konsole vmware-config.pl moet starten Dan krijg ik eerst uitgebreid de licentie-overeenkomst te zien. Op het eind daarvan ZOU een knop moeten zitten om OK of accept of zoiets te kunnen geven. Probleem is dat ik die knop niet kan vinden. Op het eind van de tekst is niks te vinden. Weet iemand hoe ik verder kom ?
  • Je moet geloof ik op "q" drukken (zonder aanhalingstekens) om uit de licentie text te komen (waarschijnlijk wordt less gebruikt om de tekst scrollbaar te maken) en vervolgens kan je "yes" intypen (ook zonder aanhalingstekens) Succes!
  • ja, q klopt. maar dan.... " Thank you. Trying to find a suitable vmmon module for your running kernel. None of VMware Workstation's pre-built vmmon modules is suitable for your running kernel. Do you want this program to try to build the vmmon module for your system (you need to have a C compiler installed on your system)? [yes] Using compiler "/usr/bin/gcc". Use environment variable CC to override. What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include] The path "/usr/src/linux/include" is not an existing directory. What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include][size=7:73733a9434][/size:73733a9434][i:73733a9434] gaat mijn ervaring te boven[/i:73733a9434]
  • Ik heb even rond zitten neuzen en om VMWare draaiende te krijgen heb je inderdaad een zogeheten vmmon module nodig. Deze module zorgt ervoor dat hij bepaalde dingen aan kan spreken en kan gebruiken. De truc voor linux is natuurlijk dat er verschilende kernels in omloop zijn en (je raadt het nu al) elke kernel vereist een andere vmmon module. Op de site van vmware ( http://www.vmware.com/support/ws4/doc/intro_hostreq_ws.html#1032234 ) stond dat VMWorkstation 4 nog niet SuSe 8.2 out of the box ondersteunt. Wel SuSe 7.3, 8.0 en 8.1 Geen ramp overigens, wat hij nu probeert is een vmmon module compileren voor jouw specifieke SuSe 8.2 kernel. Daarvoor heeft hij echter wel de kernel-source nodig en die heb jij niet geinstalleerd. Die directory waar hij naar zoekt is ook de source directory van de kernel, die bij jou niet bestaat. Je hebt nu een aantal mogelijkheden: 1. Installeer de kernel source van de SuSe cd en probeer opnieuw VMWare te installeren. Nadat je de kernel source hebt geinstalleerd zal VMWare de directory herkennen, de module gaan compileren en het installatieproces weer van je overnemen. 2. Download de juiste vmmon module van de vmware website. ( www.vmware.com ) Op deze site staan nieuwe vmmon modules die nog niet op de release versie (cd's die in de winkel liggen) staan. Je kunt het ook kan en klaar via deze weg proberen. Ik zag wel een download link staan, maar ik heb de modules verder nog niet terug kunnen vinden, site is een beetje vaag daarin. Misschien kun je het nog via de "support" links vinden, ik heb daarin nog niet gekeken. 3. Je kunt proberen een oudere SuSe versie te installeren, die de VMWare versie wel out of the box ondersteunt.
  • Ik heb een hele tijd lopen zoeken bij vmware, en op diverse andere fora. Suse linux 8.2 staat gewoon nog niet in het rijtje. Ik denk dat het wachten is op vmware.
  • Nee hoor, gewoon de kernelsource halen en installeren. Is een flink pakket, maar verder geen probleem. Staat ook wel op je CD.
  • Ik heb laatste een rpm-versie van vmware geinstalleerd op RedHat.... geen probleem...
  • Ik ben vandaag ook met de trein geweest. Geen probleem! :-?
  • Huh?
  • Ik heb, van de cd's de kernel-source geinstalleerd. vervolgens weer geprobeerd vmware te configureren. Met deze gedachtenwisseling als resultaat: dual:/home/willem # vmware-config.pl Making sure VMware Workstation's services are stopped. Stopping VMware services: Virtual machine monitor done Trying to find a suitable vmmon module for your running kernel. None of VMware Workstation's pre-built vmmon modules is suitable for your running kernel. Do you want this program to try to build the vmmon module for your system (you need to have a C compiler installed on your system)? [yes] Using compiler "/usr/bin/gcc". Use environment variable CC to override. What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include] The directory of kernel headers (version 2.4.20-4GB) does not match your running kernel (version 2.4.20-64GB-SMP). Even if the module were to compile successfully, it would not load into the running kernel. What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]
  • Zo te zien draai je de multiprocessor kernel van suse. Maar heb je de standard suse kernel source geinstalleerd. Dat werkt niet. Of je kiest de standaard kernel (als je geen multiprocessor systeem hebt) of je moet de kernelsource installeren voor de SMP. Bij mij werkt vmware wel op suse 8.2. Inderdaad na isntallatie van de kernelsource. Bart
  • nou, bemoedigend dat het dus inderdaad kan. ja, de computer heeft twee processoren, dus suse heeft keurig de multiprocessor-kernel geinstalleeerd. Inmiddels heb ik de source voor de foute eenprocessor-kernel weer gedeinstalleerd. Maar ik kan de source voor de multi-processorkernel niet vinden op de cdroms. (ik installeer via yast2)
  • [quote:a7c354dea0="willem43"] Maar ik kan de source voor de multi-processorkernel niet vinden op de cdroms. [/quote:a7c354dea0] Ik heb hier ook een PC met 2 cpu's [code:1:a7c354dea0] uname -a Linux dual 2.4.20-64GB-SMP #1 SMP Mon Mar 17 17:56:03 UTC 2003 i686 unknown unknown GNU/Linux [/code:1:a7c354dea0] De kernel-source die je nodig hebt is deze [code:1:a7c354dea0] jolo@dual:~> rpm -qa | grep kernel kernel-source-2.4.20.SuSE-30 [/code:1:a7c354dea0] En vmware-config.pl [code:1:a7c354dea0] Trying to find a suitable vmmon module for your running kernel. The module smpPAE-2.4.20-SuSE-8.2 loads perfectly in the running kernel. Trying to find a suitable vmnet module for your running kernel. The module smpPAE-2.4.20-SuSE-8.2 loads perfectly in the running kernel. [/code:1:a7c354dea0]
  • goed, ik volg het voorbeeld: willem@dual:~> uname -a Linux dual 2.4.20-64GB-SMP #1 SMP Wed Jun 18 07:44:41 UTC 2003 i686 unknown unknown GNU/Linux Tot zover alles OK willem@dual:~> rpm -qa |grep kernel (het teken voor grep is een verticaal streepje ?) willem@dual:~> en dan niks. Ik ga er vanuit dat er geen rpm package met deze source op mijn computer staat. Hoe kom ik eraan ?
  • Als je SuSE 8.2 Prof hebt staat de kernel-source op DVD 1 en op één van de CD's Als je SuSE 8.2 Personal hebt, kun je de kernel-source downloaden. Voor Nederland ftp://ftp.nl.uu.net/pub/linux/suse/i386/8.2/suse/i586/kernel-source-2.4.20.SuSE-62.i586.rpm Voor België ftp://ftp.belnet.be/linux/SuSE/i386/8.2/suse/i586/kernel-source-2.4.20.SuSE-62.i586.rpm
  • Ik heb het genoemde rpm-pakket gedownload en met konqueror geinstalleerd. Daarna gebeurde er dit: willem@dual:~> uname -a Linux dual 2.4.20-64GB-SMP #1 SMP Wed Jun 18 07:44:41 UTC 2003 i686 unknown unknown GNU/Linux willem@dual:~> rpm -qa | grep kernel kernel-source-2.4.20.SuSE-62 willem@dual:~> su Password: dual:/home/willem # vmware-config.pl Making sure VMware Workstation's services are stopped. Stopping VMware services: Virtual machine monitor done Trying to find a suitable vmmon module for your running kernel. None of VMware Workstation's pre-built vmmon modules is suitable for your running kernel. Do you want this program to try to build the vmmon module for your system (you need to have a C compiler installed on your system)? [yes] Using compiler "/usr/bin/gcc". Use environment variable CC to override. What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include] The directory of kernel headers (version 2.4.20-4GB) does not match your running kernel (version 2.4.20-64GB-SMP). Even if the module were to compile successfully, it would not load into the running kernel. What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]
  • ik snap het ook niet helemaal, want in jouw voorbeeld gaat het om kernel-source -2.4.20 Suse 30, maar die je aanraddt te downloaden is kernel-source -2-4-20-Suse-64. Is dat wel goed ? :roll:
  • Ja, die kernel source van de SuSE ftp is ondanks de iets andere naam ook goed. Je meld dus dat je vmware 4.0 hebt, maar je bedoelt waarschijnlijk vmware 4.0.0 Ik heb hier echter vmware 4.0.1 RC1. In de map /vmware-distrib/lib/modules/binary staan de gecompileerde binaries. Vmware 4.0.0 heeft de binaries van SuSE 8.2 nog niet. Wel heb je vmware-distrib/lib/modules/source om te compileren.
  • aha, bedankt voor de hulp !! :D
  • trouwens, waar heb je die dan vandaan ? een b`eta ?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.