Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Shell script Probleem? Of installatie CD-2 brak?

None
18 antwoorden
  • Ik wilde Open OFfice installeren bij een user (setup opstarten), maar het shell script setup wordt niet uitgevoerd (bestand niet begonden).
    Ook executables (bestand niet gevonden).

    Ik heb een flink aantal programma's unistalled.
    Heb ik misschien ook eentje die scripts uitvoert verwijderd?

    Ik heb bash (opnieuw) geinstalleerd, maar niet het gewenste resultaat.
    ksh? zsh? welk programma heb ik nodig?

    kppp stopt na het inbellemn en verbinding hebben er ook plots mee. Heeft dat er ook iets mee te maken?

    :roll:
  • [quote:4c2a6768f8="maximilaan"]Als je geen shell scripts kunt uitvoeren, dan geeft bash geen "bestand niet gevonden", maar "Toegang geweigerd". Het kunnen uitvoeren van scripts is nmlk een rechtenkwestie, geen applicatiekwestie (tenzij je perlscripst wilt uitvoeren zonder dat je perl hebt, maar in principe zijn de meeste scripts die je gebruikt sh-scripts die door bash zelf worden afgehandeld.
    Kun je nagaan door het script in kwrite te openen, bovenin staat welke intepreter verwacht wordt (bijv. #!/bin/perl))
    Als Bash het bestand niet kan vinden, dan ofwel bestaat het bestand niet, ofwel je variabele $PATH spoort niet.
    Probeer eens applicaties te starten door het volledige pad (dus /usr/bin/applicatienaam ) in te voeren.
    Wat kppp betreft, ga even na in het log van kde wat er misgaat..

    Max[/quote:4c2a6768f8]
  • [quote:7a25f91870="maximilaan"]Als je geen shell scripts kunt uitvoeren, dan geeft bash geen "bestand niet gevonden", maar "Toegang geweigerd". [/quote:7a25f91870]
    Ik probeerde het script op te straten vanuit Konquerer en die geeft: Couldn't find the program 'setup'

    [quote:7a25f91870="maximilaan"]Het kunnen uitvoeren van scripts is nmlk een rechtenkwestie, geen applicatiekwestie (tenzij je perlscripst wilt uitvoeren zonder dat je perl hebt, maar in principe zijn de meeste scripts die je gebruikt sh-scripts die door bash zelf worden afgehandeld.
    Kun je nagaan door het script in kwrite te openen, bovenin staat welke intepreter verwacht wordt (bijv. #!/bin/perl)[/quote:7a25f91870]
    !/bin/sh"]
    [quote:7a25f91870="maximilaan"]Als Bash het bestand niet kan vinden, dan ofwel bestaat het bestand niet, ofwel je variabele $PATH spoort niet.
    Probeer eens applicaties te starten door het volledige pad (dus /usr/bin/applicatienaam ) in te voeren.[/quote:7a25f91870]
    /usr/lib/OpenOffice geeft na ingave setup bash: setup: command not found.
    [quote:7a25f91870="maximilaan"]Wat kppp betreft, ga even na in het log van kde wat er misgaat..[/quote:7a25f91870]
    Ik kan het niet 123 reproduceren, maar kppp gaf errorcode 2 en op man kppp (dacht ik dat daar naar verwezen werd) kreeg ik geen duidelijke uitleg van de oorzaak.
  • [quote:41c8129cf9="RvP"]
    Ik probeerde het script op te straten vanuit Konquerer en die geeft: Couldn't find the program 'setup'
    [/quote:41c8129cf9]

    Scripts kun je altijd het beste vanaf de prompt opstarten.
    Dat kan ook in konqueror, door de terminalemulatie op te starten.
    [quote:41c8129cf9]
    [!/bin/sh"]
    [/quote:41c8129cf9]
    Dat is dus een sh-script, welke door bash kan worden uitgevoerd.
    Het script moet wel uitvoerbaar zijn, dat kun je evt bewerkstelligen door als root het volgende commando op te geven:
    [b:41c8129cf9]chmod +x /pad/naar/shellscript
    [/b:41c8129cf9]
    [quote:41c8129cf9]
    /usr/lib/OpenOffice geeft na ingave setup bash: setup: command not found.
    [/quote:41c8129cf9]
    Heb je dit commando uitgevoerd:
    [b:41c8129cf9]/usr/lib/OpenOffice/setup[/b:41c8129cf9]
    of dit:
    [b:41c8129cf9]setup[/b:41c8129cf9]

    Je moet het volledige pad invoeren, omdat de map /usr/lib/OpenOffice zich niet in het zoekpad van bash bevindt.
    Als je in de map /usr/lib/OpenOffice staat met de prompt kun je volstaan met het commando ./setup
    Maar simpelweg setup invoeren werkt in zo'n geval niet.
    [quote:41c8129cf9]
    [quote:41c8129cf9="maximilaan"]Wat kppp betreft, ga even na in het log van kde wat er misgaat..[/quote:41c8129cf9]
    Ik kan het niet 123 reproduceren, maar kppp gaf errorcode 2 en op man kppp (dacht ik dat daar naar verwezen werd) kreeg ik geen duidelijke uitleg van de oorzaak.[/quote:41c8129cf9]
    je moet man pppd doorbladeren.
    Dat kan in Konqueror, typ [b:41c8129cf9]man:/pppd[/b:41c8129cf9] in het
    locatieveld.

    Succes, Max
  • Heeft setup en de andere bestanden wel de goeie rechten?
    Heeft setup wel eXecute rechten?

    M.
  • In de map /usr/lib/openoffice staand het commando ./setup ingeven resulteert in niets. [~openoffice]# verschijnt wederom.

    ls toont wel setup@.

    man pppd (in terminal) doorbladeren (wat ik ook bedoelde) heeft op dit moment niet zoveel zin. Ik kan het niet reproduceren, want ik hou wel verbinding maar er is geen in- en uitgaand verkeer te bespeuren.
    De foutmelding 'error 2 (of ik dacht 10)' verschijnt niet meer.

    Wat betreft die OpenOffice setup: Ik heb MDK8.1 geinstalleerd op een andere pc en daar OpenOffice op geinstalleerd en dat werkte pima. daarna heb ik geupgrade naar MDK 9.0 en dat bleef prima werken.
    Het probleem doet zich voor nu ik direct MDK 9.0 installeer. Op een 3e pc doet ie het ook niet.
    Nu heb ik van MDK9.0 twee cd's (A en B). Bij installatie vraagt ie of ik 'CD international 1 en 2 heb'. MDK8.1 vroeg bij mijn 2-cd's steeds of ik
    'cd 1, 2 en 3 had'. 3 vinkte ik dan uit. Zijn de cd's a en b (van Linuxmagazine UK) soms niet compleet?

    Ik instaleer (altijd) door individuele pakketten te selecteren. vergeet ik soms een essentieel onderdeel? (kan haast niet, want essentials en afhankelijkheden prompt ie prima) of staan er essentailia op de 3e (missing) cd?

    Dat modem probleem kan ik mogelijk wel oplossen door opnieuw te installeren (het heeft immers gewerkt), maar ik ben benieuwd naar de oorzaak waarom het niet meer werkt, om de fout te kunnen voorkomen.
  • Bij OpenOffice/StarOffice moet je in sommige gevallen naast het pakket zelf ook nog de (nederlandstalige of engelstalige) taalmodule installeren.
    Dat is het enige wat ik verder kan verzinnen.

    Het feit dat bash na het invoeren van ./setup terugkeert naar de shell geeft aan dat bash het script kan uitvoeren, maar dat het script zonder verdere melding onmiddelijk stopt.

    Max
  • [quote:570b557ead="maximilaan"]Bij OpenOffice/StarOffice moet je in sommige gevallen naast het pakket zelf ook nog de (nederlandstalige of engelstalige) taalmodule installeren.
    Dat is het enige wat ik verder kan verzinnen.[/quote:570b557ead]

    De taalmodule installeer je nadat je OpenOffice geinstalleerd hebt. Dit heeft alleen betrekking op de spelling- en gramatica checker.

    [quote:570b557ead="maximilaan"]Het feit dat bash na het invoeren van ./setup terugkeert naar de shell geeft aan dat bash het script kan uitvoeren, maar dat het script zonder verdere melding onmiddelijk stopt.[/quote:570b557ead]
    Kun je mij aanduiden welke andere shell scripts ik zou kunnen afstarten om eens uit te vinden of het alleen aan MDK/OpenOffice ligt of aan MDK.
  • startkde is een shellscript
    als kde dus normaal opstart, dan werkt het uitvoeren van shellscripts.
    je kunt het startkde-script ook starten als je in een andere windowmanager zit, door het script aan te roepen vanuit een terminal
    Je krijgt dan een bonte verzameling van vensters die de verschillende onderdelen van kde bevatten ;)

    Max
  • [quote:7a7980b15a="RvP"]

    De taalmodule installeer je nadat je OpenOffice geinstalleerd hebt. Dit heeft alleen betrekking op de spelling- en gramatica checker.
    [/quote:7a7980b15a]

    Niet helemaal waar, de taalmodule bepaalt de taal van de GUI.
    Althans bij StarOffice, bij OpenOffice heb ik me daar nooit in verdiept, maar is vast te lezen op de OpenOffice site.

    Bij StarOffice faalt in ieder geval de installatie als er geen taalmodulle aanwezig is.


    Max
  • [quote:d4afeef6ed="maximilaan"][quote:d4afeef6ed="RvP"]

    De taalmodule installeer je nadat je OpenOffice geinstalleerd hebt. Dit heeft alleen betrekking op de spelling- en gramatica checker.
    [/quote:d4afeef6ed]

    Niet helemaal waar, de taalmodule bepaalt de taal van de GUI.
    Althans bij StarOffice, bij OpenOffice heb ik me daar nooit in verdiept, maar is vast te lezen op de OpenOffice site.

    Bij StarOffice faalt in ieder geval de installatie als er geen taalmodulle aanwezig is.

    Max[/quote:d4afeef6ed]

    Inderdaad, maar ik heb OpenOfice NL geinstalleerd. Dan verschijnt OO met NL titels en menu's. Daarna moet je nog de spelling taal module installeren.
  • [quote:cfa972d4c1="RvP"]
    Inderdaad, maar ik heb OpenOfice NL geinstalleerd. Dan verschijnt OO met NL titels en menu's. Daarna moet je nog de spelling taal module installeren.[/quote:cfa972d4c1]

    OK, dus bij OOo zit de taalmoduele voor de GUI er al in gebakken.

    TNX

    Max
  • Max, (ik werk nu via MDK) alles werkt weer met met het modem.
    Ik heb een herinstallatie (zonder programma toe te voegen)
    gedaan en inderdaad draait alles dan weer.
    Ra, ra wat er mis ging

    Nu resteert alleen nog OpenOffice onder MDK 9.0 aan de praat te krijgen.

    Ik denk dat ik het maar eens zonder OO doe en dan eenaparte OO installatie van
    een HCC of PCM schijfje.

    Duurt nog even, maar ik hou je op de hoogte hoe ik vorder.
  • Vanmorgen MDK9.0 OpenOffice uninstalled.

    Van DOSGG (Softwarebus) versiie 1.0.0 NL geinstalleerd. Werkte prima.
    deze versie weer uninstalled.

    Versie 1.0.1 NL geinstalleerd (in de verwachting dat deze versie automatisch de folders/icoontjes/shortcuts in het KDE3 menu zou plaatsten). OO werkt prima.

    (alles bij elkaar nog geen 15 minuten werk!)

    Ik ga op een andee machine nog wel even door met puzzelen waarom MDK9.0 OO 1.0.1NL zich niet laat installeren.

    Zal ik de benaming van dit Topic aanpassen naar "MDK9.0 Open Offce laat zich niet installeren"

    Max, jij als KDE kei weet natuurlijk zo uit je hoofd hoe ik die items in het KDE menu krijg. Er was ergens een KDE-folder waar ze in moesten.
    Met MDK kan ik ze ook met Drakemenu er bijplaatsen.
  • Een heleboel herinstallaties gedaan. Ja hoor ergens op de 2e cd van MDK 9.0 die ik bezit gaat het fout.
    CD heten Instalation 1 en 2 (op de labels staat A en B) en als op 3/4 van de installatie van programma van de 2e CD hij de bestanden niet kan vinden, dan spuugt ie uit en vraagt om (zeker verkeerd vertaald) de CD: International 2
    OpenOffice werkt pas installatie vanaf andere CD, Xine werkt ook niet. Oggle van andere CD werkt in een tel.
    Ik ga wel even bij Kooplinux.nl kijken. Die hebben wel 9.1 al. 2 CD en (mij onbekend) een derde 'vertaling'.

    Ik pas de titel van dit topic maar even aan.
    Vraag over die KDE(3) plek voor de icoontjes blijft nog open.
  • cd3 van Mandrake bevat volgens mij de localisatie van deze distro (dus alle bestanden om de distro te voorzien van documentatie en gui'meldingen in een bepaalde taal). Mogelijk dat hij tijdens de installatie om deze cd vraagt.

    Max
  • [quote:b11c4be483="maximilaan"]cd3 van Mandrake bevat volgens mij de localisatie van deze distro (dus alle bestanden om de distro te voorzien van documentatie en gui'meldingen in een bepaalde taal). Mogelijk dat hij tijdens de installatie om deze cd vraagt.

    Max[/quote:b11c4be483]
    Da's dan bij MDK 9.1
    Die 9.0 CD's van mij bevatten (net als 8.0 en 8.1) alle GUI-talen. Ik check nog wel even voordat ik koop wat die 3e cd inhoudt.
  • Voor de zoveelste keer (op de 5e machine) MDK9.0 geinstalleerd.
    De laatste keer als 'standaard' installatie. Steeds hetzelfde liedje: systeem is binnen een mum geheel operationeel lijkt het, maar …
    configuratie programma (harddrake, drakeconf ed) en OpenOffice programma starten niet op.

    Wat mij opviel toen ik Mozilla achteraf installeerde is dat deze GCC nodig had en die was nog niet geinstalleerd. GCC heb ik erbij gezet. Mozilla werkt (daar werk ik nu mee)
    Verder zie ik dat al die Drake progjes Perl scripts zijn. Perl heb ik erbij gezet, maar het werkt nog niet. Bij de installatie meldde MDK dat de signature van de Perl.rpm niet klopte !?@#$%*.

    Brengt dit iets meer licht in de zaak? :oops:

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.