Vraag & Antwoord

OS Linux

[Mandrake 9.0)muis doet het niet altijd.

13 antwoorden
  • Ik heb Mandrake 9.0 op mijn pc. De eerste keer als ik de computer start doet alles het prima. Maar als ik daarna ga restarten doet de muis het niet. Als ik daarna weer ga herstarten doet alles het prima. Als ik ga afmelden en opnieuw ga inloggen blijft het probleem. Vandaar de herstart. Iedere keer de 2e als ik de ik linux start doet de muis het niet. Ik vind dit heel vreemd. Onder Windows had ik nergens last van. Ik heb in het verleden vaker deze versie van linux op me PC gehad, en iedere keer had hetzelfde probleem. Ik heb alle updates van Mandrake. En zou goed kunnen dat het probleem pas ging spelen sinds ik die updates heb. Maar dat heb ik niet echt kunnen ervaren, omdat ik de updates onderhand meteen na de installatie van Mandrake heb binnengehaald. Ik heb Mandrake gewoon automatisch laten installeren via de grafische install programma. Dus daar kan niks fout zijn gegaan. De installatie software had gewoon al mijn hardware herkent. Ik gebruik trouwens een grafische inlogmanager, en die staat standaard op KDE. En die gebruik ik ook. Maar kan daar ook bv Gnome kiezen. Kan iemand mij helpen? Als jullie meer info nodig hebben, vraag maar. mvg, Roy
  • Heb je het ook al met een andere muis geprobeerd??
  • Ik heb dit geintje ook eens gehad. Bleek een recursief i/o of irq-conflict in Windows, die Windows telkens op een andere manier ongezien oplostte. Doordat deze waarden in het bios wijzigden kon X de ene keer wel de muis bedienen en de andere keer niet. Probleem aanvankelijk opgelost door in Windows handmatig een i/o of irq op te geven, maar dat gaf weer andere conflcten. Uiteindelijk een andere poort gekozen. Max
  • [quote:8217b99031="roy_startpag"] Ik heb Mandrake 9.0 op mijn pc. De eerste keer als ik de computer start doet alles het prima. Maar als ik daarna ga restarten doet de muis het niet.[/quote:8217b99031] Hoe is die muis aangesloten op je PC? USB, PS/2 of Serial? [quote:8217b99031="maximilaan"] Bleek een recursief i/o of irq-conflict in Windows [/quote:8217b99031] Een echt muis conflict is sinds de ISA kaart vervangen is door de PCI kaart zeldzaam. Een PCI kaart zal, mits in BIOS ingesteld op Auto, nooit dezelfde irq opeisen van een PS/2 of Serial muis. Voor USB is irq delen geen probleem. [code:1:8217b99031] jolo@dual:~> cat /proc/interrupts CPU0 CPU1 0: 923430 0 XT-PIC timer 1: 3810 0 XT-PIC keyboard 2: 0 0 XT-PIC cascade 5: 17135 0 XT-PIC eth0, ohci1394, usb-uhci, usb-uhci 8: 2 0 XT-PIC rtc 9: 18 0 XT-PIC acpi, bttv 10: 1159 0 XT-PIC EMU10K1 12: 268832 0 XT-PIC PS/2 Mouse 14: 20529 0 XT-PIC ide0 15: 151 0 XT-PIC ide1 NMI: 0 0 LOC: 923319 923317 ERR: 1 MIS: 0 jolo@dual:~> [/code:1:8217b99031]
  • Muis is PS/2 aangesloten. ACPI staat in de BIOS op disabled (en dat heb ik gedaan voordat ik linux ging installeren), dus dan worden de IRQ's door het BIOS bepaald en niet door het OS. Of is dat bij linux anders?
  • Dat ACPI disable in de BIOS staat, is wel goed. Ook kan voor Linux het beste in de BIOS Plug & Play O/S No. De irq toewijzing word inderdaad bepaald door de BIOS. De irq van een PS/2 muis is trouwens altijd irq 12. Heb je als root al geprobeerd [code:1:fe5a4f5999] mouseconfig [/code:1:fe5a4f5999]
  • Ik log altijd als root in. Vind ik het makkelijkste omdat ik dan gewoon alles kan doen. Ik krijg wel altijd een waarschuwing als ik als root inlog. Een zogenaamde Krootwarning. Dat ik dingen kan beschadigen etc. Daar bedoelen ze alleen mee dat ik als root alles kan, dus niet zomaar elk commando etc moet gaan uitproberen? Het is toch niet zo dat ik als root inlog dat ik me systeem aangetast wordt? En nu weer ff mijn probleem met de muis: Als ik linux start en de muis doet het gewoon, dan heb ik dit schema van irq's: code: cat /proc/interrupts 0= timer 1= keyboard 2= cascade 5= eth0 8= rtc 10= SiS SI7012 12= PS/2 mouse 14= ide0 15= ide1 Maar als ik linux start en de muis doet het niet, krijg ik dit schema: code: cat /proc/interrupts 0= timer 1= keyboard 2= cascade 5= eth0 8= rtc 10= SiS SI7012 14= ide0 15= ide1 Muis staat er niet bij, ik vind dat heel vreemd. De muis die ik gebruik is trouwens een Logitech Pilot Wheel Mouse. Het is een USB muis die met behulp van een verloopplugje naar PS/2. Dit plugje zat gewoon bij de muis zelf toen ik hem kocht. Ik weet niet of dit een bekend probleem met deze muis en Mandrake 9. Als ik namelijk een andere muis probeer (ander merk), dan werkt het wel. En de muis kan volgens mij niet defect zijn. Want half jaar geleden had ik ook Mandrake 9 op mijn computer, toen had ik dezelfde problemen. Toen ik daarna Windows XP erop zette heb ik nooit meer problemen gehad. En nu heb ik sinds 3 dagen linux en het probleem is weer terug. Ik denk dus dat ik de problemen idd in de richting van irq's, verkeerde drivers etc moet zoeken. De instelling PnP OS staat aan. Kan het daar dan iets mee te maken hebben? Zoja waarom dan? mvg, Roy
  • [quote:0d1b4b1aec="roy_startpag"]Ik log altijd als root in. Vind ik het makkelijkste omdat ik dan gewoon alles kan doen. Ik krijg wel altijd een waarschuwing als ik als root inlog. Een zogenaamde Krootwarning. Dat ik dingen kan beschadigen etc. Daar bedoelen ze alleen mee dat ik als root alles kan, dus niet zomaar elk commando etc moet gaan uitproberen? Het is toch niet zo dat ik als root inlog dat ik me systeem aangetast wordt?[/quote:0d1b4b1aec] Als je continu als root werkt is ondermijn je ten eerste de beveiliging van je systeem. Bijv. virussen die in een user-gebied geen vat op je systeem krijgen kunnen nu de hele boel verzieken. Verder kan je idd dingen beschadigen als je als root werkt, je kunt per ongeluk, al dan niet ongemerkt belangrijke systeemonderdelen wijzigen/verwijderen, waardoor je je systeem kunt vernielen. Bij een distro als Mandrake is er geen enkele reden om continu als root te zijn ingelogd, het systeem biedt voldoende comfortabele manieren om als root in te loggen als je iets wilt wijzigen.. Verder maak je de overstap naar gewone gebruiker alleen maar lastiger, omdat je dan alles weer opnieuw kunt configueren etc... (qua persoonlijke instellingen..) Max
  • Heb nu het verloopplugje verwijdert, en de muis op een usb poort aangesloten. Heb USB in het BIOS ge-enabled. En in linux via het Beheerssingscentrum gekozen voor een USB-muis. En nu heb ik het probleem niet meer. En als ik nu via de opdracht cat /proc/interrupts de irq's ga bekijken, dan zie ik geen PS/2 meer staan. Ik vind dit heel raar. Ook al heb ik niks op PS/2 aangesloten, de poort zou gewoon nog in het irq lijstje moeten staan als het goed is? Het irq van het keyboard (irq 1) staat wel in het lijstje (is ook een PS/2). Ik heb 2 USB poorten en die hebben door het activeren in het BIOS, het irq 5 en 12 gekregen. Ik snap het niet meer. Hoe kan me muis nu PS/2 aansluiten, en op zo een manier dat het werkt? Ik wil me USB namelijk vrijlaten, voor andere apparaten. Moet ik het irq van PS/2 in linux zelf wijzigen? Dus wat maximilaan zei? Of zou een BIOS update helpen? Of.....? mvg, Roy
  • Ik heb hier op mijn Dual Pentium III 1000 Mhz het volgende in Mandrake 9.1 getest. Dan staat mijn PS/2 muis er in een Konsole er wel bij. In tekst mode init 3 staat mijn PS/2 muis alleen in dat /proc/interrupts lijstje indien GPM is geinstalleerd. Dat cat /proc/interrupts geen PS/2 toont, als je PS/2 muis niet is aangesloten is niet zo erg. Wat cat /proc/interrupts wel behoort te tonen hangt van de BIOS van je moederbord af. Dit toont cat /proc/interrupts PS/2 muis niet aangesloten met in BIOS PS/2 mouse function Control op Auto [code:1:83db324d7d] CPU0 CPU1 0: 9550 5664 IO-APIC-edge timer 1: 125 181 IO-APIC-edge keyboard 2: 0 0 XT-PIC cascade 5: 1 1 IO-APIC-level bttv 8: 1 0 IO-APIC-edge rtc 10: 0 0 IO-APIC-level Audigy 12: 287 290 IO-APIC-level usb-uhci, usb-uhci, ohci1394, eth0 14: 4246 1903 IO-APIC-edge ide0 15: 5 31 IO-APIC-edge ide1 NMI: 0 0 LOC: 15130 15130 ERR: 0 MIS: 0 [/code:1:83db324d7d] Dit toont cat /proc/interrupts PS/2 muis niet aangesloten met in BIOS PS/2 mouse function Control op Enable [code:1:83db324d7d] CPU0 CPU1 0: 7130 6710 IO-APIC-edge timer 1: 168 385 IO-APIC-edge keyboard 2: 0 0 XT-PIC cascade 5: 294 289 IO-APIC-level usb-uhci, usb-uhci, ohci1394, eth0 8: 1 0 IO-APIC-edge rtc 9: 1 1 IO-APIC-level bttv 10: 0 0 IO-APIC-level Audigy 14: 3843 2271 IO-APIC-edge ide0 15: 27 9 IO-APIC-edge ide1 NMI: 0 0 LOC: 13756 13755 ERR: 0 [/code:1:83db324d7d] Dat het PS/2 toetsenbord irq 1 is niet fout. IRQ 1 is de standaard irq voor Din-5 en PS/2 toetsenborden. Als er bij het aanzetten van de PC een PS/2 muis is aangesloten, zal de BIOS deze irq 12 toewijzen. Het wijzigen in Linux van de irq van de PS/2 muis is niet mogelijk. Ik denk dat voor jouw PS/2 muis probleem de instelling PnP OS aan niets uitmaakt. Dat neemt niet weg dat het waarschijnlijk toch beter is dat de instelling PnP OS uit staat voor Linux. Een BIOS update heeft waarschijnlijk geen zin, tenzij op de website van je moederbord fabrikant, bij de BIOS updates duidelijk staat vermeld dat er PS/2 muis problemen zijn opgelost voor Linux. Een driver probleem zou kunnen. Als je er voor zorgt dat GPM is geinstalleerd, bijvoorbeeld via rpmdrake, dan kun op het moment dat je PS/2 muis niet meer in X werkt, via Alt Ctrl F1 en door te typen [code:1:83db324d7d] init 3 [/code:1:83db324d7d] [Enter] testen of je muis het nog doet in init 3. Controleer of gpm geinstalleerd is met [code:1:83db324d7d]rpm -qa | grep gpm gpm-1.20.1-2mdk libgpm1-1.20.1-2mdk [/code:1:83db324d7d]
  • Het probleem was dus als volgt: Als ik linux opstart, doet-tie het de eerste keer wel, bij de tweede nieuwe start niet, derde wel, vierde niet. Steeds om en om. En dat is dus met die Logitech Pilot Wheel Mouse, met USB>PS/2 verloopplug. Als de muis het wel doet, staat tie gewoon in het lijstje van irq's onder nr 12. Doet de muis het niet, staat die niet in het lijstje van irq's, ook al is die aangesloten. En dat is juist het rare. Als ik een andere echte PS/2 gebruik (deze heeft geen verloopplug dus) doet deze het prima. Als ik me Logitech Pilot Wheel Mouse USB aansluit, heb ik ook geen problemen. De conclusie die ik hieruit trek, is dat het verloopplugje defect is, of dat linux niet goed met om kan gaan met verloopplug USB>PS/2. Of zie ik dat verkeerd? BTW: ik ga ook nog ff kijken naar de oplossing van jolo. Nog niet getest. Ik laat dat nog weten. gr, Roy
  • [quote:0edf89ab69="roy_startpag"]Als ik een andere echte PS/2 gebruik (deze heeft geen verloopplug dus) doet deze het prima. Als ik me Logitech Pilot Wheel Mouse USB aansluit, heb ik ook geen problemen. De conclusie die ik hieruit trek, is dat het verloopplugje defect is, of dat linux niet goed met om kan gaan met verloopplug USB>PS/2. Of zie ik dat verkeerd? [/quote:0edf89ab69] Als je verloopplugje defect is, zou het toch wel heel toevallig zijn dat je dat alleen merkt na een reboot. Tja ik heb hier 2 USB muizen. 1 Logitech en 1 Microsoft muis. Deze muizen zijn allebei aangesloten via meegeleverde USB>PS/2 verloopplug. Bij mij werkt dit goed in meerdere Linux distro's
  • Er is nog een ander topic (ook Logitech wheel mouse) Voor Mandrake9.0 is er een patch voor wheel mouses. Zie het topic aldaar. Wie weet brengt dat de oplossing Dat de connector usb/ps2 defect is lijkt mij stug, want hij doet het wel onder windows. Daar zou ik het dus niet in zoeken.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.