Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[SuSE 8.2] KDE 3.1.3 Kmix start om en om met X

jolo
21 antwoorden
  • Ik heb zojuist de kde3.1.3 binary rpm's gedownload van ftp://ftp.snt.utwente.nl/pub/software/kde/stable/3.1.3/SuSE/i386/8.2
    Het installeren was deze keer niet zo moeilijk.
    Eerst ging ik naar init 3 via Ctrl Alt F1 root password init 3 [Enter]
    Dan via cd naar de map met de kde3.1.3 binary rpm's
    Het eerste wat opviel was toen ik [b:d2b0c940f8] ls [/b:d2b0c940f8] deed, dat de letters vrijwel onleesbaar rood waren. (De kde3.1.2 binary rpm's had ik nog bewaard. Deze zijn groen en wel leesbaar.)
    De output van [b:d2b0c940f8] rpm -Uvh *.rpm [/b:d2b0c940f8] was in ieder geval leesbaar wit. Ik heb deze keer alleen kdegraphics3-scan-3.1-78.i586.rpm eruit hoeven halen. Daarna deed ik uiteraard [b:d2b0c940f8] SuSEconfig [/b:d2b0c940f8] De update is gelukt, maar wat wel opvalt is dat de letters op de Desktop nu wit zijn ipv zwart. Ik vind deze witte letters op de lichtblauwe achtergrond toch iets minder duidelijk dan de zwarte letters. In Configuratiecentrum > Bureaublad > Uiterlijk staat, Normale tekstkleur nog steeds op zwart. Standaard lettertype staat nog op Nimbus Sans l.

    Wat ook nog opvalt is dat na de kde3.1.3 update dat de fv van de monitor is nu nog maar 59 hz in plaats van 101 hz. Om dit te controleren heb ik op een andere partitie SuSE 8.2 nogmaals geinstalleerd, maar dan uiteraard met kde3.1.1 en daar is de fv 101 hz. Voor beide SuSE 8.2 heb ik dezelfde nvidia driver geinstalleerd. (NVIDIA-Linux-x86-1.0-4496-pkg2.run) En via sax2 dezelfde monitor, resolutie en kleuren geselecteerd. Wel is er een verschil in /etc/XF86Config
    Dit deel is in beide SuSE 8.2 hetzelfde.
    [code:1:d2b0c940f8]
    Section "Monitor"
    Option "CalcAlgorithm" "CheckDesktopGeometry"
    HorizSync 27-86
    Identifier "Monitor[0]"
    ModelName "VISION MASTER MF8617T"
    Option "DPMS"
    VendorName "IIYAMA"
    VertRefresh 50-160
    UseModes "Modes[0]"
    EndSection
    [/code:1:d2b0c940f8]
    En dit deel zit wel in de SuSE 8.2 met kde3.1.1 maar niet in SuSE 8.2 met kde3.1.3
    [code:1:d2b0c940f8]
    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1024x768" 61.19 1024 1040 1216 1400 768 768 775 802
    Modeline "1024x768" 71.39 1024 1040 1216 1400 768 768 776 802
    Modeline "1024x768" 81.59 1024 1040 1216 1400 768 768 777 802
    Modeline "1024x768" 91.79 1024 1040 1216 1400 768 768 781 802
    Modeline "1024x768" 101.99 1024 1040 1216 1400 768 768 781 802
    Modeline "1024x768" 114.21 1024 1040 1216 1400 768 768 781 802
    Modeline "800x600" 37.44 800 816 928 1072 600 600 605 626
    Modeline "800x600" 43.68 800 816 928 1072 600 600 606 626
    Modeline "800x600" 49.92 800 816 928 1072 600 600 607 626
    Modeline "800x600" 56.16 800 816 928 1072 600 600 613 626
    Modeline "800x600" 62.40 800 816 928 1112 600 600 613 626
    Modeline "800x600" 68.64 800 816 928 1112 600 600 613 626
    Modeline "800x600" 74.88 800 816 928 1112 600 600 613 626
    Modeline "800x600" 81.12 800 816 928 1112 600 600 613 626
    Modeline "800x600" 89.44 800 816 928 1112 600 600 613 626
    Modeline "640x480" 23.96 640 656 720 864 480 480 484 501
    Modeline "640x480" 27.96 640 656 720 864 480 480 485 501
    Modeline "640x480" 31.95 640 656 720 864 480 480 485 501
    Modeline "640x480" 35.94 640 656 720 864 480 480 491 501
    Modeline "640x480" 39.94 640 656 720 864 480 480 491 501
    Modeline "640x480" 43.93 640 656 720 864 480 480 491 501
    Modeline "640x480" 47.92 640 656 720 864 480 480 491 501
    Modeline "640x480" 51.92 640 656 720 864 480 480 491 501
    Modeline "640x480" 55.91 640 656 720 904 480 480 491 501
    Modeline "1024x768" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
    EndSection
    [/code:1:d2b0c940f8]
    Ik heb de Nvidia driver die pas uit kwam geinstalleerd na de kde3.13 update.
  • Waarom zit Suse/KDE in vredesnaam in XF86COnfig te knoeien? En die sectie, die kun je toch gewoon toevoegen?
  • De installatie van KDE kan niet je video-instellingen hebben beinvloed. SuSEConfig volgens mij ook niet, maar aangezien die vrij veel configuratiebestanden doorloopt en wijzigingen doorvoert kan het zijn dat juist die de boosdoender is geweest.

    Enfin, je hebt nu 2 SuSE-installaties op hetzelfde systeem?
    Pak dan het configuratiebestand voor X van het ene systeem en gebruik die op het andere systeem.

    Max
  • [quote:08934ee199="jolo"]En dit deel zit wel in de SuSE 8.2 met kde3.1.1 maar niet in SuSE 8.2 met kde3.1.3[/quote:08934ee199] Ik heb gisteren toch niet helemaal goed gekeken. Ook die SuSE 8.2 met kde3.1.3 heeft een Section "Modes". Maar omdat deze kleiner is dan de Section "Modes" in SuSe 8.2 met kde3.1.1 zal ik deze gisteren wel over het hoofd hebben gezien.
    [code:1:08934ee199]
    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1024x768" 65.00 1024 1048 1184 1344 768 771 777 806
    EndSection
    [/code:1:08934ee199]
    [quote:08934ee199="maximilaan"]De installatie van KDE kan niet je video-instellingen hebben beinvloed. SuSEConfig volgens mij ook niet, maar aangezien die vrij veel configuratiebestanden doorloopt en wijzigingen doorvoert kan het zijn dat juist die de boosdoender is geweest.[/quote:08934ee199] Ik had die installatie van de nieuwe nvidia driver en sax2 uitgevoerd na de kde3.1.3 update. Er staan inderdaad 2 SuSE 8.2 installaties op hetzelfde systeem. Handmatig aanpassen of kopieren van de /etc/X11/XF86Config vanuit de SuSE 8.2 met kde3.1.1 is uiteraard te proberen. Dan blijft toch de vraag waarom sax2 na de kde3.1.3 update de Modes voor de monitor kleiner maakt. Bovendien bovenaan de /etc/X11/XF86Config staat
    [code:1:08934ee199]
    # /…/
    # SaX generated XFree86 config file
    # Created on: 2003-08-03.
    #
    # Version: 4.7
    # Contact: Marcus Schaefer <sax@suse.de>, 2002
    #
    # Automatically generated by [ISaX] (4.7)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    [/code:1:08934ee199]
  • He wat gek, iemand heeft dus via SaX je video-instellingen gewijzigd.
    Heeft niemand toegang gehad tot je pc?

    Max
  • [quote:6b0d6593c3="maximilaan"]He wat gek, iemand heeft dus via SaX je video-instellingen gewijzigd.[/quote:6b0d6593c3] Uit wat blijkt dat?
    [quote:6b0d6593c3="maximilaan"]Heeft niemand toegang gehad tot je pc?[/quote:6b0d6593c3] Nee, niet fisiek. Ik heb zojuist even getest via www.grc.com
    [code:1:6b0d6593c3]
    GRC Port Authority Report created on UTC: 2003-08-04 at 10:04:30

    Results from scan of ports: 0-1055

    0 Ports Open
    0 Ports Closed
    1056 Ports Stealth
    ———————
    1056 Ports Tested

    ALL PORTS tested were found to be: STEALTH.

    TruStealth: FAILED - ALL tested ports were STEALTH,
    - NO unsolicited packets were received,
    - A PING REPLY (ICMP Echo) WAS RECEIVED.
    [/code:1:6b0d6593c3]
  • [quote:93432165b1="jolo"][quote:93432165b1="maximilaan"]He wat gek, iemand heeft dus via SaX je video-instellingen gewijzigd.[/quote:93432165b1] Uit wat blijkt dat?[/quote:93432165b1]
    [code:1:93432165b1]
    /…/
    # SaX generated XFree86 config file
    # Created on: 2003-08-03.[/code:1:93432165b1]


    Max
  • Maar gisteren had ik toch voor het laatst sax2 gebruikt. Ik heb het nog een keer geprobeerd met sax2. Ik ging weer naar init 3 via Ctrl Alt F1 root password init 3 [Enter] En startte sax2 die de monitor niet meer leek te kennen. Ik selecteerde opnieuw de juiste monitor. Ook de resolutie moest ik weer opnieuw selecteren. Het resultaat.
    [code:1:ce57e458d6]
    # /…/
    # SaX generated XFree86 config file
    # Created on: 2003-08-04.
    [/code:1:ce57e458d6] Dat is toch in orde lijkt me. Maar van Section "Modes" is nu nog minder over gebleven,
    [code:1:ce57e458d6]
    Section "Modes"
    Identifier "Modes[0]"
    EndSection
    [/code:1:ce57e458d6]
    De fv is nu [b:ce57e458d6] 84 hz [/b:ce57e458d6] dus dat is nu wel voldoende. Alleen is niet duidelijk wat sax2 met die Modes uitspookt en welke invloed kde3.1.3 erop heeft.
    Overigens de Desktop letters zijn sinds de kde3.1.3 update nog steeds wit. Wit in init 3 was wel OK, maar de witte lettes op de Desktop vind ik lelijk.

    Bovendien sinds de kde3.1.3 update start nu ook elke keer Kmix gelijk met KDE. Ik heb daar geen opdracht voor gegeven.
  • kmix kan in een sessie zitten, of wordt opgestart via KDE_HOME/Autostart of KDEDIR/share/autostart

    Max
  • In ~/.kde/Autostart staat alleen [b:eab98b9d14] .directory [/b:eab98b9d14] Dat bestand bedoel je toch niet.
    [code:1:eab98b9d14]
    [Desktop Entry]
    Type=Directory
    Name=Autostart
    Name[af]=Outomatiese begin
    Name[az]=z-zn Balama
    Name[bg]=
    Name[ca]=Autoengega
    Name[el]=
    Name[eo]=Memlano
    Name[es]=Autoinicio
    Name[fa]=
    Name[fi]=Kynnist
    Name[fr]=Dmarrage automatique
    Name[he]=
    Name[hr]=Pokreni automatski
    Name[hu]=Automatikus indts
    Name[is]=Sjlfrsing
    Name[it]=Avvio automatico
    Name[ja]=
    Name[ko]=
    Name[lo]=
    Name[lt]=Autostartas
    Name[lv]=Autostarts
    Name[mk]=
    Name[mt]=Awto-bidu
    Name[nso]=Thomo yago Itirisa
    Name[pt]=Arranque
    Name[pt_BR]=Inicializao Automtica
    Name[ru]=
    Name[sk]=Autotart
    Name[sl]=Samodejni zagon
    Name[ta]=
    Name[th]=
    Name[tr]=Otomatik Balat
    Name[uk]=
    Name[ven]=Thoma
    Name[xh]=Isiqalo esizenzekelayo
    Name[zh_CN]=
    Name[zh_TW]=
    Name[zu]=Ukuqala ngokuzenzekela
    [/code:1:eab98b9d14]
    Opmerking: op de lege plekken achter de = tekens staan letters met trema's en andere tekens er boven. Deze worden bij het kopieren naar het Plaats een Reactie formulier niet meegenomen.
  • Nog even een andere vraag: waarom heb je die rpm los gedownload. Zijn dit nog geen officiele oid? Normaliter kun je toch automatisch upgraden?
  • [quote:e640aa57e5="jolo"]In ~/.kde/Autostart staat alleen [b:e640aa57e5] .directory [/b:e640aa57e5] Dat bestand bedoel je toch niet.
    [/quote:e640aa57e5]

    Nop, die bedoel ik idd niet, dit bestand bevat de eigenschappen voor de map (pictogram, naam, vertaling, weergavevolgorde, etc..)
    Als beide autostartmappen niks bevatten, en kmix ook niet in de sessie vast zit, dan is de laatste mogelijkheid dat kmix via een opstartscript wordt gestart.
    Te denken valt aan [u:e640aa57e5]KDEDIR/bin/startkde[/u:e640aa57e5].

    Dat kun je overigens even nagaan door via een nieuwe gebruiker kde op te starten.

    Max
  • [quote:773d0aecd8="maximilaan"]Dat kun je overigens even nagaan door via een nieuwe gebruiker kde op te starten. [/quote:773d0aecd8] Ik heb een nieuwe gebruiker aangemaakt via Kuser met de usernaam test. Maar als ik probeer in te loggen met de usernaam test en het wachtwoord dat ik ingevoerd heb ik Kuser, dan faalt de login. Ik heb het wachtwoord al enkele malen veranderd via Kuser, maar kan met deze nieuwe user niet inloggen. Er is overigens in de map /home wel een map test aangemaakt. Er is dus iets dat het inloggen van deze nieuwe gebruiker blokkeert.
  • Doe eens vanaf de prompt
    [b:531a6f9671]passwd test[/b:531a6f9671]
    en vul dan een nieuw wachtwoord in.
    Probeer vervolgens vanaf de prompt eens in te loggen onder deze naam.

    max
  • Eerst had ik nog een gebruikersnaam aangemaakt met useradd
    [code:1:14ea5e6788]useradd -u 501 -g audio -G sys -d /home/test2 -s /bin/bash -p test123 -r test2[/code:1:14ea5e6788] waar ik ook niet mee kon inloggen. Ook had test2 geen map in /home
    [quote:14ea5e6788="maximilaan"]Doe eens vanaf de prompt
    passwd test [/quote:14ea5e6788] Ja, dat werkt dan kan ik wel inloggen met gebruikersnaam test. Alleen is het probleem hetzelfde. Het viel me niet direct op, maar Kmix start niet elke keer na het inloggen in kde3.1.3, maar om en om. Dus de eerste keer wel, de tweede keer niet, de derde keer wel, de vierde keer niet enz. De Desktop letters met gebruiker test zijn ook wit.
  • Inmiddels heb ik SuSE 8.2 opnieuw schoon geinstalleerd, dus met het formatteren van de root partitie. En KDE 3.1.3 rpm's opnieuw geinstalleerd. Voor de update werkt alles nog goed. Na de update, start nog steeds Kmix om en om op na het starten van X. Dus wel, niet, wel, niet…enz.
    De zwarte letters op de KDE Desktop die na de KDE 3.1.3 update wit zijn geworden zijn lelijk.

    Ik heb op dezelfde PC ook nog Mandrake 9.2 Beta 2 ook met KDE 3.1.3 Deze heeft ook witte letters op de KDE Desktop, maar deze letters zijn wel goed. Dat probleem met Kmix is niet in Mandrake 9.2 Beta 2.

    Dus vraag ik me af waarom deze problemen er dan wel zijn in SuSE 8.2 KDE 3.1.3
    Opmerking: ik heb de topic titel aangepast. :roll:
  • Tja, dat laatste kan alleen SuSE beantwoorden vrees ik.
    KDE 3.1.3 van SuSe 8.1 heeft dit euvel overigens ook niet.

    Wat je kunt doen is bij SuSE een bugrapport indienen hierover.
    Heb je bij de herinstallatie nieuwe rpm-bestanden gedownload?

    Max
  • [quote:3da3d8b415="maximilaan "]Heb je bij de herinstallatie nieuwe rpm-bestanden gedownload?[/quote:3da3d8b415] Nee, welke heeft de voorkeur? System update of Online update?

    Update:

    Ik neem aan dat je deze updates bedoelt. Zo te zien is het grootste deel security updates. Kdebase3-SuSE 8.2 misschien?
  • Nee, ik bedoel de rpm-bestanden voor KDE die op ftp.kde.org te vinden zijn.
    SuSEvernieuwt deze om de zoveel tijd, waarbij foutjes uit de vorige compilatie worden verwijderd.
    Dus als er een fout in de rpm-bestanden zat die je eerst gebruikte bestaat er de kans dat de huidige bestanden op ftp de fout niet meer hebben.

    Max
  • Maar dan kom ik hier op uit ftp://bolugftp.uni-bonn.de/pub/kde/stable/3.1.3/SuSE/i386/8.2 die rpm's hebben dezelfde datum, als de rpm's die ik heb gedownload. 26-7-2003

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.