Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

[gentoo] kernel 2.6 en AWE problemen

None
17 antwoorden
  • Hmmm ik ben gaan spelen met de nieuwe kernel-beta 2.6-tets2. Nu is bijne alles goed verlopen, maar als ik reboot en in lilo kies voor de 2.6-kernel dan krijg ik na de reboot de melding "… localhost.local domain (linux 2.4.21)".

    Dat vind ik raar. Ik had echt 2.6 gecomplied en opgestart. Ere kwma zelfs een melding na het bootmenu met "loading kernel 2.6".

    Weet iemand hoe dit zit?
  • 1) heb je wel arch/i386/bzImage gekopieerd naar je boot-dir?
    2) heb je dat bestand wel toegevoegd aan lilo en lilo gedraaid?
    succes!
  • Bah waarom kan linux niks fout doen :lol: Ik had een bash-scripje gemaakt waarin een verkeerde bzImage (van kernel 2.4) werd gekopieerd i.pv. de 2.6 bzImage. Nu zijn er nog wel wat andere problemen, maar die ga ik eerst zelf proberen op te lossen.
  • Oke hier snap ik niks van[code:1:7496744425] CC sound/oss/awe_wave.o
    sound/oss/awe_wave.c: In function `awe_probe_isapnp':
    sound/oss/awe_wave.c:4804: warning: impliciete declaratie van functie `isapnp_find_dev'
    sound/oss/awe_wave.c:4807: warning: toewijzing maakt pointer van integer zonder een cast
    sound/oss/awe_wave.c:4808: structure has no member named `prepare'
    sound/oss/awe_wave.c:4810: structure has no member named `activate'
    sound/oss/awe_wave.c:4812: structure has no member named `deactivate'
    sound/oss/awe_wave.c:4813: structure has no member named `deactivate'
    sound/oss/awe_wave.c: In function `awe_deactivate_isapnp':
    sound/oss/awe_wave.c:4832: structure has no member named `deactivate'
    make[2]: *** [sound/oss/awe_wave.o] Fout 1
    make[1]: *** [sound/oss] Fout 2
    make: *** [sound] Fout 2
    [/code:1:7496744425]
    ik krijg mijn soundblaster niet aan de praat. Wie helpt?
  • [quote:63cfe6820c="Demonaz"]ik krijg mijn soundblaster niet aan de praat. Wie helpt?[/quote:63cfe6820c] Misschien kunnen we elkaar helpen. Ik ben ook bezig met Beta Linux kernel 2.6.0-test2 maar dan in Slackware 9.0 (Dual Pentium III) Ik heb modules gemaakt. De bzImage naar /boot gekopieerd. Hetzelfde geld ook voor de System.map en grub menu.lst aangepast.
    [code:1:63cfe6820c]
    root (hd0,12)
    File system is ext2fs partition type 0x83
    kernel /boot/vmlinuz-2.6.0-test2 root=/dev/hda13 hdc=ide-scsi

    [Linux-bzImage, setup=0x1400, size=0x159ae8]

    Uncompressing Linux… OK, booting the kernel.
    [/code:1:63cfe6820c] Hier bliijft de kernel hangen. Heb je behalve de beta kernel nog iets anders geinstalleerd?
    Als die geluidskaart van jou een Creative Labs AWE64 dan heb ik hier wel een vergelijkbare geluidskaart, namelijk een Creative Labs AWE32 in een Pentium 166MMX. Daar heb ik ook Slackware 9.0 op en ga ik de beta kernel ook op proberen.

    Voordat ik het vergeet, omdat je nu een compleet ander probleem hebt dan je topic titel, kun je deze beter wijzigen in [b:63cfe6820c] [Gentoo] Beta Linux kernel 2.6.0-test2 AWE64 [/b:63cfe6820c] oid.
  • Heb je ook de modules geinstalleerd?

    He ik wist nietd at je de titel kon veranderen. Erg handig.
  • [quote:8ac2f6fc98="Demonaz"]Heb je ook de modules geinstalleerd?[/quote:8ac2f6fc98] Uiteraard, met [b:8ac2f6fc98] make modules_install [/b:8ac2f6fc98] die zijn dan ook in de /lib/modules/2.6.0-test2
    Inmiddels heb ik de beta kernel via mijn netwerk gekopieerd en uitgepakt op die Pentium 166MMX met die AWE32 erin. Het compileren op die pc test ik morgen wel.
  • En hoe is de test gegaan? Ik heb de 2.6 kernel aan de praat, Ik heb de awe als ALSA-driver en met OSS-emulatie aan de praat gekregen.
  • [quote:89c998ecdd="Demonaz"] En hoe is de test gegaan?[/quote:89c998ecdd] De test is nog niet voltooid. De 2.6.0-test2 start inmmidels al wel op, maar er zijn nog wel problemen met modules. Mijn AWE32 werkt nog niet.

    Zou je de output kunnen posten van je [b:89c998ecdd] lsmod [/b:89c998ecdd]
  • Module Size Used by
    nls_cp437 5632 2
    tuner 14724 0
    tvaudio 20864 0
    bttv 103296 0
    video_buf 17408 1 bttv
    i2c_algo_bit 9736 1 bttv
    i2c_core 20868 4 tuner,tvaudio,bttv,i2c_algo_bit
    v4l2_common 4096 1 bttv
    videodev 8960 1 bttv
    ide_scsi 13184 0
  • Hmm, dat zijn hoofdzakelijk modules voor je tv-kaart. [quote:a1697d835b="Demonaz"]Ik heb de awe als ALSA-driver en met OSS-emulatie aan de praat gekregen.[/quote:a1697d835b] Dan had ik nog wat andere modules in je lsmod output verwacht. Bij mij heb ik de test met beta2.6.0-test2 kernel in Slackware 9.0 op mijn Pentium 166MMX met die AWE32 beeindigd. Ik heb Slackware verwijderd. Daarvoor in de plaats heb ik de Knoppix 3.2-HD install gedaan. Het compileren van de test2-kernel gaat heel traag en is ruim 2 uur bezig.
    Deze modules worden voor mijn AWE32 in de Knoppix 3.2-HD install met kernel 2.4.20 geladen.
    [code:1:a1697d835b]
    awe_wave 155488 0 (unused)
    sb 7732 0 (unused)
    sb_lib 33294 0 [sb]
    uart401 5988 0 [sb_lib]
    sound 54540 0 [awe_wave sb_lib uart401]
    soundcore 3364 6 [sb_lib sound]
    [/code:1:a1697d835b] In die output van jou had ik deze eigenlijk ook verwacht. Want de AW32 en de AWE64 gebruiken dezelfde modules.
  • Ik heb alles niet als module gecompileerd. Misschien is dat het?
  • Het ligt meer voor de hand om, voor je geluidskaart gebruik te maken van modules ipv built-in. In de Knoppix 3.2-hd install ofwel Debian is bij mij de beta2.6.0-test2 kernel gecompileerd. Eerst wilde depmod, insmod, lsmod, modprobe en rmmod niet werken. Er werden helemaal geen modules geladen. Ook al had ik modutils-2.4.5 module_init-tools-0.7 en module_init-tools-0.9.12 al geinstalleerd. Toen bleek er toch nog een nieuwere versie te zijn. Namelijk module-init-tools_0.9.13-pre-1_i386.deb na deze te hebben geinstalleerd, werkte depmod enz weer wel. Dit is mijn lsmod output nu. [code:1:1f16b57e1c]
    Module Size Used by
    sr_mod 12992 0
    sb_lib 42768 0
    uart401 8996 1 sb_lib
    sound 69396 2 sb_lib,uart401
    soundcore 6112 2 sb_lib,sound
    8139too 20032 0
    mii 3872 1 8139too [/code:1:1f16b57e1c]
    module sb ontbreekt nog. Dit is mijn dmesg output.
    [code:1:1f16b57e1c]
    <knip>
    sb: Init: Starting Probe…
    sb: Init: Done
    AWE32: not detected
    <knip>
    [/code:1:1f16b57e1c]
  • Ah Demonaz…. ben jij jasper-j… leuke site van je…. moet nog wel vanalles op he…. maar je bent goed op weg!
  • [quote:7c9be23dff="MrLeeJohn"]Ah Demonaz…. ben jij jasper-j… leuke site van je…. moet nog wel vanalles op he…. maar je bent goed op weg![/quote:7c9be23dff] yep yep ik ben een beetje spleten van binnen :lol: . Maar hij is inderdaad nog erg leeg. Het duurde even voordat ik een leuke structuur voor mij reviews gevonden had.

    Heb jij nog tips qua opbouw van de stukken? En heb je zin om oom een onderdeel ervoor te schrijven?
  • Nou…. je kunt een stukje schrijven over hoe windows en linux goed te integreren…. de mogelijkheden op een standalone pc en op een netwerk. Waar is windows sterker in en waar linux. Hoe je een inlog-server kunt maken met roaming profiles en zo. Wat linux zoal kan betekenen voor de windows-client.

    Mijn site is ontstaan door de praktische problemen die ik met RedHat (mijn favo distro) had en hoe ik die oplostte. De rest is er omheen geflatst. Er is niet echt structuur en ik heb bewust geen css en php en zo.

    Ik heb niet echt tijd stukken te schrijven…. zit doordeweek al 40 uur achter de pc. Vind ik genoeg, naast wat hobbywerk op de pc. Is me al vaker gevraagd… forum-moderator ben ik wel geweest en zo…. howto's schrijven is ook leuk… maar mijn tijd is me te kostbaar geworden… sorry.
  • Oke dan bedankt voor de tips. Langzaam aan wil ik er inderdaad meer van maken, maar zoals ie nu is wordt wel de basis. Ik wil vooral voor niemand conclusies trekken. Dat mag men lekker zelf doen.

    En ik gebruik de site om te experimenterne met site maken. Dus vandaard at ik er eht een en ander zoals PHP gebruik. Is wel erg handig hoor. De reviews zijn opgebouwd uit een file waarin elk onderdeel ingevoegd wordt.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.