Vraag & Antwoord

OS Linux

[SuSE 8.2]Radeon drivers compatibiliteit

Anoniem
jolo
86 antwoorden
  • /jolo
    Bedankt man voor je advies :) Ik ga dr vanaaf mee aan de slag.. Hoop dat de smurf dan wel wil laden :)!

    P.S. naah de ATI website is niet zo 'duidelijk'.. Kom op :) het is grote tiefus rotzooi.. k snap niet hoe je aan die link ben gekomen, maja in elk geval mega hartelijk bedankt!!

    Als ik weer op probs stuit, horen jullie t wel :)

    Greetz!
  • Ik heb hier ook nog wat getest. Ik heb mijn Radeon 9000 even overgezet, naar mijn Athlon XP 1700+ met 512 MB RAM. Ik kon de driver rpm zonder problemen installeren. Als ik in fglrxconfig [quote:02211fb0b8]Do you want to use the external AGP GART module (y/n)?[/quote:02211fb0b8] met y beantwoord, dan start X alleen op, nadat module agpgart is geladen. Antwoord ik n, dan is module agpgart niet nodig. Maar voor Tuxracer maakt dat geen verschil. Op de Athlon XP crashed deze ook.
  • Conclusie: het ligt niet aan de driverversie…..

    Het zelfde probleem nog steeds :(, echt vaag
  • jah.. maja mijn prob is dat ik heel X niet meer aan de praat krijg, na de driver installatie…

    ik heb alle dingen met fglrx config al geprobeerd, maar dit werkt allemaal niet.. Beetje vaag dus

    heb ook totaal geen id meer wat ik moet doen, en SuSE helpdesk is ook niet zo snel tegenwoordig……
  • Je zou de outputs kunnen posten, van je [b:6133e5f1ef] /sbin/lsmod [/b:6133e5f1ef] en je [b:6133e5f1ef] dmesg | grep agp [/b:6133e5f1ef]
  • Hallo lui,

    Ik zit met het volgende 'probleempje': Op de site van ATI (deze dan eh) staat aangegeven, dat de 'drivers' compatible zijn met Xfree86 versie 4.1.0 of met versie 4.2.0. Aangezien er bij SuSE 8.2 versie 4.3.0 wordt bijgeleverd, was mijn vraag oof een van deze 2 drivers op deze versie zoudenn kunnen draaien. En aanders de vraag: waar kan ik anders die drivers vandaan vissen??

    Bij voorbaad dank voor jullie respons,

    E-razoor
  • http://www.schneider-digital.de/html/download_ati.html
  • ——
  • dank je marcel voor de link! hier kan ik verder mee :)

    Enkel resteerd 1 vraagje… Welke Fire staat gelijk aan de 9700 pro?
    [EDIT] lama zitte, heb t al :oops: :oops: :oops: :oops:
    Maar alsnog bedankt!


    Greetz,

    E-razoor
  • ik heb enkel nog 1 vraagje. In de readme staat dit:
    Currently ATI provides Linux drivers for only one version
    of the c runtime library:

    - glibc22 (also known as libc62)

    To find out which c library you have, download the script
    'Check.sh' and run it:

    sh Check.sh

    -
    [EDIT] Ik gebruik dus Xfree86 4.3.0, zoals standaard is opgenomen in de SuSE distro, en heb dus ook de Xfree86 4.3.0 versie driver gedownloaded.
    -
    en uit dit check script komt dit:
    =====================================================================
    ATI Technologies
    =====================================================================
    Checking which OS you're running…
    uname reports 'Linux' version '2.4.20-4GB-athlon', architecture 'i686'.
    Object format is 'ELF'.
    libc version is '6.3'.

    XFree86 Version 4.3.0 is installed.

    No package available for glibc 2.3. Try fglrx-glibc22.tgz
    Binary package name is 'fglrx-glibc21.tgz'

    kan ik deze drivers nu wel of niet draaien?????
    B.v.D. E-razoor
  • Gewoon doen, ik heb dat hele check gebeuren nooit gedaan. Je ziet het vanzelf als het misgaat :P
  • Tijdens de driver installatie, merkte het programma ongeveer t volgende op:

    Tailored Kernel module for fglrx not present on the system
    /lib/modules/fglrx/build_mod " ./make.sh"
    /lib/modules/fglrx "./make_install.sh"
    Error: no kernel module build environment
    installed: qt3 (gcc3.2) based control panel application

    Dit zal wel te maken hebben dat de kernel aangepast moet worden, voordat de 3D acceleratie gaat werken. Probleem is: Ik ken geen C (laatstaan C+)

    Na deze installatie (en na fglrxconfig te hebben gedraaid) kan ik mijn monitor instellingen niet meer via YAST weizigen. Ook van ATI control panel is nog niets te bekennen in het KDE menu….

    Iemand suggesties? Misschien een meegelverde kernell update van SuSE ofzo??

    B.V.D.

    E-razoor
  • Controleer is of je kernel-source er wel op staat.
    [code:1:c18f534b99]
    ls /usr/src[/code:1:c18f534b99]

    daar moet een symlink linus zijn en een map met de kernel-source, als deze er niet na staat kun je bij pro nainstalleren van de cd en bij personal vanaf internet
  • ik zie dit staan in /usr/src:

    PC@PC:~> ls /usr/src
    fglrx_panel_sources.tgz fglrx_sample_source.tgz packages

    PC@PC:~> ls /usr/src/packages
    BUILD RPMS SOURCES SPECS SRPMS

    PC@PC:~> ls /usr/src/packages/SRPMS
    PC@PC:~>

    PC@PC:~> ls /usr/src/packages/SOURCES
    PC@PC:~>


    t lijkt erop dat deze beide folders leeg zijn. Waarschijnlijk dus, zal dit het probleem moeten zijn. Enkel tussen ' installeren nieuwe software' staat nergens een kernell module tussen mbt fglrx. Ook kan ik niets vinden wat hier ook maar enige betrekking op kan hebben…

    detail: als ik bovengenoemd make.sh script uitvoer, geeft de shell die aan (ongeveer):

    ATI module generator V2.0
    kernell includes at /usr/src/linux/ not found or incomplete
    file: /usr/src/linux/include/linux/version.h

    voor de rest doet ie nix..niet goed IMHO..
    Advies?
  • Oke je moet dus idd de kernel sources installeren. Je kunt deze gewoon in rpm voor downloaden en dan via YAST2 installeren.

    Je kunt gewoon een source toevoegen aan YAST2 en dan via de packetmanager gewoon een vinkje zetten bij de kernels-source.
  • hmm bedoel je toevallig dit?

    In dat geval, ben ik een stukje verder gekomen :) dank u voor de hulp!
  • Yep dat bedoel ik. Staat ook gewoon in de lijst van packages in YAST als je een ftp server toevoegt, installeer deze en probeer het dan opnieuw, zou moeten werken.
  • owk we maken enigszins progressie……

    enkel geeft ie nu weer een foutmelding:

    Error:
    kernel includes at /libs/modules/2.4.20-4GB-athlon/build/include
    do not match current kernel
    They are versioned as 2.4.20-4GB instead of
    2.4.20-4GB-athlon
    You might to adjust your symlinks
    - /usr/include
    - /usr/src/linux

    owk, hier snap ik dus weer vrij weinig van.. Enkel dat ie mn athlon kernel niet mag… ik heb btw enkel de source geinstalleerd die betrekking heeft tot de lik hierboven..

    Alvast bedankt voor hulp,
  • Ik snap het al, de gecompileerde kernel die je gebruikt is anders dan de settings van de kernel sources.
    Je kunt de settings van je huidige kernel als het goed is uit je /proc device halen en vervolgens gewoon kopiëren naar de .config file in de kernel-sources.

    Iemand anders kan het waarschijnlijk wel iets gedetailleerder uitleggen.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.