Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

OS Linux

Aiptec pocketcam 3 mega in SuSE 8.2 pro

jolo
23 antwoorden
  • Hallo, ik probeer over te stappen naar Linux, hoe krijg ik mijn Aiptec digitale kamera werkende in linux? Het is een usb apparaat, kan ik ook gewoon via een map mijn afbeeldingen zien zoals ik dat had in xp? Daar kwam gewoon een station bij met mijn afbeeldingen, dank bij voorbaat, greets, SuSE fan
  • [quote:fa1550e94c="Brammy"]hoe krijg ik mijn Aiptec digitale kamera werkende in linux? [/quote:fa1550e94c] Ik heb zelf geen digitale camera, maar volgens de SuSE 8.2 user guid, hoeft de camera alleen maar in een usb poort te worden gestopt. [quote:fa1550e94c="Brammy"]kan ik ook gewoon via een map mijn afbeeldingen zien [/quote:fa1550e94c] Ja, SuSE gebruikt daarvoor package [b:fa1550e94c] gtcam [/b:fa1550e94c] Meer info: http://www.gphoto.org/ en http://www.thekompany.com/projects/gphoto/
  • thx ik ga direct eens kijken, ik had eens de usb stekker in geplugd en der gebeurde niets… maar kga nu nog eens proberen thx
  • Het gaat niet mijn digi cam is nl. niet ondersteund… Heeft iemand een programma die deze kamera wel ondersteund?
  • [quote:cbbbbf325e="Brammy"]Het gaat niet mijn digi cam is nl. niet ondersteund.[/quote:cbbbbf325e] Maar welke stappen heb je gevolg, nadat je digitale camera had ingeplugd? KDE menu Grafisch > Viewer > Gtkam. Camera > Add Camera. Bij Model Detect. Werd de camera dan niet herkent?

    Zo niet. Start dan eens [b:cbbbbf325e] usbview [/b:cbbbbf325e] Ziet usbview de camera? En typ eens [code:1:cbbbbf325e] /sbin/lsmod | grep usb [/code:1:cbbbbf325e] en ook [code:1:cbbbbf325e] dmesg | grep usb [/code:1:cbbbbf325e] en post deze outputs.

    Update:

    Deze staat in de Gtkam camera lijst
    [quote:cbbbbf325e] Aiptek:1.3 mega PocketCam [/quote:cbbbbf325e] of is dat 'm niet.
  • nee idd. de mijne is de 3 mega versie…
  • Een beetje camera kun je als blockdevice mounten, alsof het een lokale harde schijf betreft.
    Dan heb je geen applicaties als gphoto of kamera nodig..
    Kijk even of dat ook voor jouw camera geldt.


    Max
  • [quote:6332434e48="Brammy"]nee idd. de mijne is de 3 mega versie…[/quote:6332434e48]
    Ik heb gezocht via google, google discussiegroepen, Linuxquestions.org en sourceforge. Maar ik vond geen bruikbare applicatie. Ik denk dat jouw camera nog te nieuw is.
    [quote:6332434e48="maximilaan"]Een beetje camera kun je als blockdevice mounten, alsof het een lokale harde schijf betreft. [/quote:6332434e48] Daarom vroeg ik ook om enkele outputs [quote:6332434e48="jolo"]
    [code:1:6332434e48]/sbin/lsmod | grep usb[/code:1:6332434e48] en
    [code:1:6332434e48] dmesg | grep usb [/code:1:6332434e48] [/quote:6332434e48] en of usbview de camera ziet.
  • Als ik usbview in typ in de console, zegd hij: commando niet gevonden
  • Ik heb nu ook eens die commando's geprobeerd hier is de uitslag:

    Bram@linux:~> /sbin/lsmod | grep usb
    usb-storage 56596 0
    usbserial 18460 0 (autoclean) (unused)
    usb-uhci 22096 0 (unused)
    usbcore 57836 1 [usb-storage usbserial usb-uhci ehci-hcd]
    Bram@linux:~> dmesg | grep usb
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb.c: new USB bus registered, assigned bus number 1
    usb-uhci.c: $Revision: 1.275 $ time 18:24:43 Mar 17 2003
    usb-uhci.c: High bandwidth mode enabled
    usb-uhci.c: USB UHCI at I/O 0xd800, IRQ 5
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 2
    usb-uhci.c: USB UHCI at I/O 0xd000, IRQ 11
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 3
    usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 9
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 4
    usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
    usb.c: USB device 2 (vend/prod 0xb05/0x6206) is not claimed by any active driver.
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 147 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d015e0, burb c2d014e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d015e0, burb c2d014e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d015e0, burb c2d014e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d015e0, burb c2d014e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d015e0, burb c2d014e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d015e0, burb c2d014e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d014e0, burb c2d015e0
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 9 ret -6
    usb-uhci.c: ENXIO 80000280, flags 0, urb c2d01460, burb c2d01660
    usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 147 ret -6
    usb.c: registered new driver serial
    usbserial.c: USB Serial support registered for Generic
    usbserial.c: USB Serial Driver core v1.4
    usb.c: USB device 2 (vend/prod 0x8ca/0x2011) is not claimed by any active driver.
    usb.c: registered new driver usb-storage
    usb-uhci.c: interrupt, status 2, frame# 481
  • Je /sbin/lsmod output is inderdaad, zoals die zou moeten, voor een extern usb opslag media. Je had behalve je usb camera, toch geen andere usb opslag media aangesloten, zoals usb zip, of usb harddisk?

    Voor wat betreft je dmesg | grep usb is de regel [b:242d033ab1] usb.c: registered new driver usb-storage [/b:242d033ab1] voor je externe opslag media.

    Alleen de regels in je dmesg | grep usb met failed
    [code:1:242d033ab1] usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 147 ret -6 [/code:1:242d033ab1] zou op een usb probleem kunnen duiden. Controleer voor alle zekerheid je gehele dmesg output. Het deel van je dmesg output waar je dan vragen over heb, post je.

    Je zou ook nog je volgende outputs kunnen posten. [code:1:242d033ab1] cat /proc/scsi/scsi [/code:1:242d033ab1] Als daar info over je camera instaat, kun je 'm proberen te mounten. Om te weten waar je camera kunt mounten. Log eerst in als superuser. kopie en plak. [code:1:242d033ab1] sfdisk -l [/code:1:242d033ab1] Als je 'm typt, maak hier dan a.u.b. geen typ fouten.
  • Alleen mijn asus adsl usb modem was ook nog aangesloten, ik wil eigenlijk gewoon de map weten van die kamera waar ik de pics in vind… Hier de uitslag van de commando's:

    Bram@linux:~> cat /proc/scsi/scsi
    Attached devices:
    Host: scsi0 Channel: 00 Id: 00 Lun: 00
    Vendor: LITE-ON Model: LTR-52246S Rev: 6S0D
    Type: CD-ROM ANSI SCSI revision: 02
    Host: scsi1 Channel: 00 Id: 00 Lun: 00
    Vendor: 3MegaCam Model: Rev: 1.00
    Type: Direct-Access ANSI SCSI revision: 02
    Bram@linux:~> sfdisk -l
    bash: sfdisk: command not found
  • [quote:382d926464="Brammy"]Vendor: 3MegaCam Model: Rev: 1.00 [/quote:382d926464] Dat ziet er goed uit.

    [quote:382d926464="Brammy"]Bram@linux:~> sfdisk -l
    bash: sfdisk: command not found[/quote:382d926464] Zoals ik in mijn vorige post al opmerkte, is het voor deze command nodig, ingelogd te zijn als superuser [code:1:382d926464] su [/code:1:382d926464] [Enter] + root password. Of gebruik de root bash.

    De camera zal waarschijnlijk ergens op /dev/sda1 oid zitten. Om de camera te kunnen gebruiken, op je pc als gewone gebruiker, behoort de te mounten map in je /etc/fstab te staan.
    Type om te controleren of er, met de camra aangesloten, of er al iets instaat, dat lijkt op /dev/sda
    [code:1:382d926464] cat /etc/fstab [/code:1:382d926464]

    Bij mij is het zo, dat zodra ik mijn usb zip inplug, er na een minuutje, er een zip icoon verschijnt, op de KDE Desktop.
  • mmm, /dev/sda en /dev/sda1 zijn geen mappen maar bestanden hoe open ik nu mijn map met foto's?
  • Met de te mounten mappen bedoel ik uiteraard /mnt/camera of in SuSE heet dat waarschijnlijk /media/camera. Om te zien welke sub mappen, /media/ heeft typ
    [code:1:3c875d0899]ls /media[/code:1:3c875d0899] Als daar niets staat, wat op camera lijkt, dan maak je die daar als superuser.
    [code:1:3c875d0899] mkdir /media/camera [/code:1:3c875d0899] In je /etc/fstab komt dan zoiets als dit te staan
    [code:1:3c875d0899]/dev/sda1 /media/camera vfat noauto,user,exec 0 0[/code:1:3c875d0899] Dat wil zeggen, zodra je zeker weet, dat /dev/sda1 de camera is.
    Dan mount je [code:1:3c875d0899]mount /media/camera[/code:1:3c875d0899]
    U(n)mounten [code:1:3c875d0899]umount /media/camera[/code:1:3c875d0899]
  • Mja, nu heb ik dat gedaan en krijg ik de volgende fout:

    Bram@linux:~> mount /media/camera
    mount: /dev/sda1 is geen geldig blok-apparaat

    Maar als ik de usb stekker uittrek zegd hij geen medium gevonden dus het moet toch al een goede stap in de juiste richting zijn…
  • Wil er aub iemand antwoorden? :'(
  • [quote:c11fa688f3="Brammy"]Bram@linux:~> mount /media/camera
    mount: /dev/sda1 is geen geldig blok-apparaat[/quote:c11fa688f3]

    [quote:c11fa688f3="Brammy"]Maar als ik de usb stekker uittrek zegd hij geen medium gevonden dus het moet toch al een goede stap in de juiste richting zijn…[/quote:c11fa688f3]Ik heb dit inderdaad kunnen reconstrueren. Dus met stekker usb zip drive eruit, geen medium. Maar geen geldig blok-apparaat, krijg ik alleen, als ik niet het juiste device neem voor de usb zip.

    Dus weet je zeker dat je camera /dev/sda1 is? Wat is de output van [code:1:c11fa688f3] /sbin/fdisk -l /dev/sda [/code:1:c11fa688f3] Als superuser uiteraard.
  • Andere vraag, zijn camera's zgn blokapparaten??

    Max
  • Ik heb dat commando uitgevoerd en er stond dit:

    linux:~ # /sbin/fdisk -l /dev/sda
    linux:~ #

    Niets dus…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.